Raspberry Pi 4 Manjaro KDE 20.06 - unable to connect to any wifi (not just 5 GHz)

I saw others had issues connecting to 5 GHz networks, but I'm unable to connect to 2.4 GHz networks also.

The wifi dock indicator is able to scan networks as normal, and I clicked my home network and entered the password. It scans for a while, then returns "[network SSID] disconnected".

To try troubleshooting, I tried following the instructions from the Archwiki on using WPA_Supplicant to connect manually.

I created a basic wpa_supplicant.conf file as instructed. When I run:

# wpa_supplicant -B -i *interface* -c /etc/wpa_supplicant/wpa_supplicant.conf

I get the output:

Successfully initialized wpa_supplicant
l80211: deinit ifname=wlan0 disabled_11b_rates=0
wlan0: Failed to initialize driver interface

Anyone know what's going on and have suggestions for fixing it?

I'm amazed this doesn't work out of the box, the RPi4 is a well know piece of kit... I've never had issues with it before, but have always used ethernet previously.

All works seems to work here. I noticed you have not logged in in a long time. Is everything up to date on your system?

I had problems too, my router filters MAC addresses when I added raspberry MAC's I could not connect other WiFi devices so I disabled MAC filtering, I was using it like that for two days without problems then I decided to do MAC filtering again and since then it works... I do not know where the problem was, but it works, maybe 5 times router rebooted? :man_shrugging:

Network:   Message: No ARM data found for this feature. 
           IF-ID-1: eth0 state: up speed: 1000 Mbps duplex: full mac: dc:a6:32:94:9d:9e 
           IP v4: 192.168.0.142/24 type: dynamic noprefixroute scope: global 
           IP v6: fd6c:b749:6c41:7400:d5ce:3db0:86e7:e5d6/64 type: dynamic noprefixroute scope: global 
           IP v6: fe80::5076:eef3:7eb4:15ac/64 type: noprefixroute scope: link 
           IF-ID-2: wlan0 state: up mac: dc:a6:32:94:9d:9f 
           IP v4: 192.168.0.199/24 type: dynamic noprefixroute scope: global 
           IP v6: fd6c:b749:6c41:7400:c8a8:c77b:1809:8574/64 type: dynamic noprefixroute scope: global 
           IP v6: fe80::9f3e:fac8:90b1:9a75/64 type: noprefixroute scope: lin
Linux raspberry 5.7.9-1-MANJARO-ARM #1 SMP PREEMPT Mon Jul 20 15:42:25 CDT 2020 aarch64 GNU/Linux
 pacman -Ss raspberrypi-bootloader                                                                                    
core/raspberrypi-bootloader 20200713-1 [installed]
    Bootloader files for Raspberry Pi
core/raspberrypi-bootloader-x 20200713-1 [installed]
    Bootloader with extra codecs for Raspberry Pi

 rpi-eeprom-update                                                                                                    
BCM2711 detected
Dedicated VL805 EEPROM detected
BOOTLOADER: up-to-date
CURRENT: Mon 15 Jun 2020 13:36:19 UTC (1592228179)
 LATEST: Mon 15 Jun 2020 13:36:19 UTC (1592228179)
 FW DIR: /lib/firmware/raspberrypi/bootloader/stable
VL805: version unknown. Try sudo rpi-eeprom-update
CURRENT: 
 LATEST: 000137ad

Good observation - yes, it's been a while. But I downloaded a fresh image of 20.06 yesterday, so assuming it's up to date.

If it matters, I'm running from a USB stick. I used Rasperry Pi OS to update the firmware, and successfully booted RPiOS from the stick. To install Manjaro, I downloaded the latest image and used Etcher to install on the USB stick. As far as I can tell most other things work as expected, though for some reason the settings panel causes some weird flickering, and I'm unable to change the theme or wallpaper... Related?

I'm not doing anything like that with my router. Very plain vanilla setup. Never had an issue with other devices, including visitors.

I did fresh install today on SSD, I use XFCE4 with i3.

I have been running on a usb stick. I took off my short usb extension to test as I have to have it because of usb 3.0 interference to see if I had issues. I do not seem to have a problem either with wifi but my router is about a foot away so probably not a good test. I did notice as before that I had horrible desktop experience with my wireless mouse opening windows or things in the menu.

If you have a short usb extension try placing it inline with your usb stick to try to separate it from the pi4 board and see if it helps.

I don't think I do, but I'll take a look through my box of odds and ends. It doesn't sound like there should be any issues per se with the way I installed Manjaro to the drive, so that's a relief. Though - as I write this, it occurs to me that as a test I should install the same OS image to an SD card to see if I have the same issues or not...

USB 3.0 and HDMI can interfere with the RPI4 WIFI.
You can also try to set your HDMI to 50hz.

Interesting. Could this affect connection, but not scanning? Because I'm able to see networks, I just can't connect.

For some reason 30 Hz is the fastest refresh rate I'm seeing (it's a 4k screen - is that the max possible with 4k?) EDIT: I checked the RPi 4 specs, and it should be able to do 60 Hz. Hmm, so it seems there are many things going on with this particular install...

Do you have hdmi_enable_4kp60=1 in config.txt.

Some one here had a similar monitor and I believe he had to also with his: install xf86-video-fbturbo-git and change the gpu_mem in config.txt to 320 for a smoother desktop. This makes it use llvmpipe for a renderer instead of V3D which is the RPi default way. You might have to experiment which way is best.

That did it - my desktop is much smoother!

I don't have a USB extension. But I installed Manjaro to a spare SD card, and wifi works so it must be something to do with my USB stick. Well, wifi worked... once I'd installed updates and overclocked the Pi and rebooted, wifi stopped working again. Sigh :frowning:

OK, so I finally got wifi working again. I noticed my Android phone had the option of sharing network over bluetooth, so I thought that might be worth a try. I enabled that setting, and turned bluetooth on the Pi on, and.... I couldn't figure it out. But as I was fiddling around with it, I just happened to notice that wifi had connected - I don't know why, but hooray! So, before it had a chance to change it's mind, I made sure to install the missing packages to make 5 Ghz wifi work. With that done, I turned bluetooth back off. Wifi still works! So, I now have functional wifi, and to top it off proper 60 Hz display.

Thanks everyone for the suggestions along the way!

Forum kindly sponsored by