Random freezes in fresh install

Hello everyone,

I just bought a MSI Bravo 15 laptop without pre-installed OS and I have installed Manjaro with KDE desktop. This laptop runs on an AMD Ryzen 7 4800H processor and has a Raedon RX 5500M GPU.

During the first minutes after the installation it seemed to be fine but then the desktop started to freeze randomly (I could see the screen but mouse and keyboard would not respond) and it did it so often that it almost became unusable.
I have tried to troubleshoot it without much success but what I have noted so far is that the crashes seem to start once I disconnect from the laptop the battery charger. Also, the battery got drained from 100% to 15% in about 2 hours without running any program at all and also got quite warm in the process

I thought it could be related to the drivers and I installed, fron the AUR, the amdgpu-pro-libgl drivers (which I think are basically the Radeon Software for linux) but the, after shutting down, the computer wont boot anymore.

I don’t mind too much reinstalling the system because I just did some minor configurations but I would love to get some help from you to solve these freezing issues and correctly install whichever driver is necessary.

Thank you very much!


Could you provide some basic information?

sudo inxi -Fxxxa --no-host

Have a look also here:

Thank you :wink:

After little research i guess there is problem with the power management. With amdgpu.runpm=0 you can disable it.

Just add amdgpu.runpm=0 at GRUB_CMDLINE_LINUX= in /etc/default/grub after install and run “sudo update-grub”… reboot.

Or it is worth a try to test a new kernel. linux58 (beta) or linux59 (experimental).

1 Like

try with theses iso

Thank you for answering! Now I don’t have access to the laptop but tomorrow I will post all the information and try you advise. :slight_smile:

Hello, thank you for answering! just to understand better, how these isos differ from the stable one in the manjaro webpage? From the answer above I assume they run in a different kernel?

i think it’s 5.7 series

This is the result of typing sudo inxi -Fxxxa --no-host:

System:    Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=a4e2aa4a-2720-4f44-99ab-442aed43a28d rw amdgpu.runpm=0 
           quiet apparmor=1 security=apparmor resume=UUID=35899005-70ed-416f-b3e7-6d7062498f7e udev.log_priority=3 
           Console: tty 1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: Bravo 15 A4DDR v: REV:1.0 serial: 9S716WK12007ZK6000184 Chassis: type: 10 
           serial: 20PN013182 
           Mobo: Micro-Star model: MS-16WK v: REV:1.0 serial: BSS-0123456789 UEFI: American Megatrends v: E16WKAMS.10D 
           date: 05/19/2020 
Battery:   ID-1: BAT1 charge: 42.9 Wh condition: 48.9/51.3 Wh (95%) volts: 12.3/11.4 model: MSI Corp. MS-16WK type: Li-ion 
           serial: N/A status: Discharging 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600102 L1 cache: 512 KiB L2 cache: 4096 KiB L3 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92662 
           Speed: 1398 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1265 5: 1297 
           6: 1343 7: 1749 8: 1841 9: 1398 10: 1405 11: 1397 12: 1396 13: 1397 14: 1397 15: 1284 16: 1397 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: Micro-Star MSI 
           driver: amdgpu v: kernel bus ID: 03:00.0 chip ID: 1002:7340 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 07:00.0 
           chip ID: 1002:1636 
           Display: server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting,radeon alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~120Hz 
           OpenGL: renderer: AMD RENOIR (DRM 3.36.0 5.6.15-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 03:00.1 chip ID: 1002:ab38 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Micro-Star MSI 
           driver: N/A bus ID: 07:00.5 chip ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 07:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 04:00.0 chip ID: 8086:2723 
           IF: wlp4s0 state: down mac: 3a:f7:da:e9:9e:04 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 00:d8:61:e7:a9:d6 
Drives:    Local Storage: total: 476.94 GiB used: 7.90 GiB (1.7%) 
           ID-1: /dev/nvme0n1 model: SSSTC CL1-8D512 size: 476.94 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: 00201510079Q rev: 1.01 scheme: GPT 
Partition: ID-1: / raw size: 460.02 GiB size: 451.80 GiB (98.21%) used: 7.90 GiB (1.7%) fs: ext4 block size: 4096 B 
           dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 16.62 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 39 C device: amdgpu temp: 44 C fan: 65535 
Info:      Processes: 321 Uptime: 5m Memory: 15.11 GiB used: 1.29 GiB (8.6%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash (sudo) v: 5.0.17 running in: yakuake inxi: 3.0.37

You should update your kernel, the 5.6 is EOL ( end of live), and because of your hardware I would use the 5.8, it bring a lot of improvements for ryzen4000

I have posted the information you were requesting and I have modified the /etc/default/grub file and for the moment the behaviour of the laptop seems more stable. Eventhough I will try it for a bit more just to mark it is solved.

Regarding your suggestions and that one of stephane of changing the kernel, what advantage would it give? Could I just wait until a more stable version is released?

Also I would appreciate if you could point me to a manual or the documents where it is explained what is the effect of disabling the power management.

Thank you very much

Hi, thanks for the added info! Isn’t the 5.8 kernel a beta kernel? That might be a bit unstable for an average noob like me… That’s the main reason I am thinking twice for changing

The 5.8 is the latest stable one, I’m using it in 2 ryzen machines without problems

1 Like

Nope, 5.9 is the RC (sort of like) beta at the moment. 5.8 is the stable one. The good practice is to have at least two kernels installed. The latest LTS (currently 5.4) and latest stable one (currently 5.8), then use the latter.
Each new kernel version have more features and driver improvements, especially for AMD hardware, so it’s beneficial to have at least the latest stable kernel.

Kernels are not like other software and since years they are super stable (aside RC versions), so in most cases all works well. There is no reason to hold on to older kernel, unless you notice that it causes problems. But that’s the beauty of Manjaro, you can easily install, switch kernels and use the best one for you at the moment, so it’s easy to jump to the latest stable kernel.

In my 5-6 years of using Manjaro, I have never noticed any major issues with any of the kernels, so the problems are really rare. They do happen but for the minority, so there is really no reason to be scared to try out any kernel you want. You can always uninstall or switch to any available kernel.


Ok, so I tried kernel 5.8 (removing amdgpu.runpm=0 at GRUB_CMDLINE_LINUX= in /etc/default/grub) but the laptop became unstable again. So for the moment I am am using kernel 5.8 and put back the modified /etc/default/grub file which for the moment seems to be the solution. Once I test this configuration for some time I will let you know.

Sounds like you aren’t alone in this:

When the amdgpu kernel module is loaded, all resolutions are possible, both using the X fbdev driver and the X amdgpu driver. However, using graphics when the amdgpu module is loaded is very, very unstable. Usually in X, the system crashes within seconds. Yes, even when using the fbdev driver. I have reported this as a kernel bug (208149 – amdgpu makes system crash (even when using fbdev for X)).

I was not able to check if video out works with amdgpu, as the system just crashes too soon.

The fix they used was the same as what you did as well with the kernel parameter:

P.P.P.P.S.: Kernel 5.7.4 with amdgpu.runpm=0 works very well for me, thanks to oknozor for coming up with that configuration. X is now stable on both Vega iGPU and Navi dGPU. Without amdgpu.runpm=0 it crashes instantly on starting X. However, there still is a problem with resuming after suspend-to-disk.

1 Like

On the other side, it will consume power. Hope that helps :wink:

runpm (int)

Override for runtime power management control for dGPUs in PX/HG laptops. The amdgpu driver can dynamically power down the dGPU on PX/HG laptops when it is idle. The default is -1 (auto enable). Setting the value to 0 disables this functionality.

drm/amdgpu AMDgpu driver — The Linux Kernel documentation

After using it for a while, the system is stable so I mark it as the correct solution.
Thank you so much!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.