Random freeze after keeping the laptop for idle

Hello,
After updating the manjaro kde plasma, i'm getting random freezes after being idle
and even after using it for 1-2 hr the mouse doesn't work ,but cursor is moving but i cannot click on anything with my mouse and touch-pad(laptop latitude e5430)I can use tabs to close certain programs.

Things i tried:
1.Kernel change still freezes
2. pacman -Syyu
3.changed mouse settings for USB mouse only when connected still no change getting random freezes

inxi -Fxxxza --no-host

Info
System:    Kernel: 5.4.48-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
           root=UUID=88323b49-8653-4202-98d0-84068a0ba3b2 rw quiet apparmor=1 security=apparmor 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.19.2 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude E5430 non-vPro v: 01 serial: <filter> Chassis: 
           type: 9 serial: <filter> 
           Mobo: Dell model: 0F5PHF v: A00 serial: <filter> BIOS: Dell v: A03 date: 06/03/2012 
Battery:   ID-1: BAT0 charge: 0% condition: 1.5/62.2 Wh (2%) volts: 8.5/11.1 
           model: LGC-LGC2.8 DELL HMYXT28 type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge 
           family: 6 model-id: 3A (58) stepping: 9 microcode: 21 L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20739 
           Speed: 1196 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1196 2: 1196 3: 1196 4: 1197 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0166 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
           alternate: fbdev,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.1.1 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k5.4.48-1-MANJARO 
Network:   Device-1: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel port: f040 
           bus ID: 02:00.0 chip ID: 8086:422b 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Broadcom and subsidiaries NetXtreme BCM5761 Gigabit Ethernet PCIe vendor: Dell 
           driver: tg3 v: 3.137 port: f040 bus ID: 0c:00.0 chip ID: 14e4:1681 
           IF: enp12s0 state: down mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 179.15 GiB (38.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000LPLX-75ZNTT0 size: 465.76 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A01 scheme: MBR 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 
           bus ID: 00:1f.2 chip ID: 8086.282a rev: 04 
Partition: ID-1: / raw size: 465.76 GiB size: 457.45 GiB (98.22%) used: 179.15 GiB (39.2%) fs: ext4 
           dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 59.0 C mobo: 46.0 C sodimm: 49.0 C 
           Fan Speeds (RPM): cpu: 2778 
Info:      Processes: 210 Uptime: 30m Memory: 3.73 GiB used: 1.55 GiB (41.7%) Init: systemd v: 245 
           Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37

htop

Info

1 [|||| 7.3%] Tasks: 109, 416 thr; 1 running
2 [|||||| 11.0%] Load average: 2.27 1.53 0.98
3 [||||| 10.4%] Uptime: 00:15:27
4 [|||||| 11.7%]
Mem[|||||||||||||||||||||||||||||||1.89G/3.73G]
Swp[ 0K/0K]

PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command

1178 parkar_br 20 0 3432M 206M 125M S 11.8 5.4 0:25.98 /usr/bin/kwin_x11
6817 parkar_br 20 0 1218M 84956 68308 D 5.9 2.2 0:01.37 /usr/bin/konsole
875 root 20 0 373M 46880 31476 S 5.9 1.2 0:24.82 /usr/lib/Xorg -nolisten tcp -auth /var/r
1246 parkar_br 20 0 1946M 250M 115M S 2.0 6.6 0:16.15 /usr/bin/plasmashell
7685 parkar_br 20 0 8540 4612 3468 R 2.0 0.1 0:00.36 htop
1179 parkar_br 20 0 3432M 206M 125M S 2.0 5.4 0:05.26 /usr/bin/kwin_x11
1294 parkar_br 9 -11 1253M 13752 10096 S 1.3 0.4 0:02.06 /usr/bin/pulseaudio --daemonize=no
6000 root 20 0 17060 7696 6564 D 0.7 0.2 0:01.09 /usr/bin/systemd-tmpfiles --clean
2140 parkar_br 20 0 1114M 234M 110M S 0.7 6.1 0:24.64 /home/parkar_brothers/Downloads/Discord/
1557 parkar_br 20 0 716M 226M 125M S 0.7 5.9 0:44.85 /opt/google/chrome/chrome
2059 parkar_br 20 0 587M 125M 89580 S 0.7 3.3 0:06.83 /home/parkar_brothers/Downloads/Discord/
1595 parkar_br 20 0 312M 90656 63332 S 0.7 2.3 0:05.81 /opt/google/chrome/chrome --type=utility
2312 parkar_br 20 0 716M 226M 125M S 0.7 5.9 0:00.13 /opt/google/chrome/chrome
1926 parkar_br 20 0 8744M 230M 101M S 0.7 6.0 1:22.01 /opt/google/chrome/chrome --type=rendere
1161 parkar_br 20 0 262M 39708 35276 S 0.7 1.0 0:00.21 /usr/lib/kf5/klauncher --fd=9
1285 parkar_br 20 0 219M 21656 19664 S 0.7 0.6 0:00.10 /usr/bin/gmenudbusmenuproxy
F1Help F2Setup F3SearchF4FilterF5Tree F6SortByF7Nice -F8Nice +F9Kill F10Quit

lspci -k

Info
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
        Subsystem: Dell Device 053c
        Kernel driver in use: ivb_uncore
lspci: Unable to load libkmod resources: error -12
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
        DeviceName:  Onboard IGD
        Subsystem: Dell Device 053c
        Kernel driver in use: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: mei_me
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
        Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
        Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
        Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
        Kernel driver in use: pcieport
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
        Kernel driver in use: pcieport
00:1c.6 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 7 (rev c4)
        Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: lpc_ich
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
        Subsystem: Dell Device 053c
        Kernel driver in use: i801_smbus
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
        Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
        Kernel driver in use: iwlwifi
0b:00.0 SD Host controller: O2 Micro, Inc. OZ600FJ0/OZ900FJ0/OZ600FJS SD/MMC Card Reader Controller (rev 05)
        Subsystem: Dell Device 053c
        Kernel driver in use: sdhci-pci
0c:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM5761 Gigabit Ethernet PCIe (rev 10)
        Subsystem: Dell Device 053c
        Kernel driver in use: tg3

lsusb

Info

Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:6449 Microdia
Bus 001 Device 003: ID 1c4f:0034 SiGma Micro
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

UPDATE: When i use tty(ctrl + alt +F6) and back to main screen it unfreezes
i kept my laptop for idle and couldn't click but after using tty it working again.
So why is this happening?

Hello there!
I can understand your issue, but it would be wise of you if you could share the screenshot of "neofetch" command in your terminal. If you don't have neofetch installed, install it from the software launcher.
It's very important to know your system information.

neofetch

Info

██████████████████ ████████ @Homelaptop
██████████████████ ████████ --------------------------
██████████████████ ████████ OS: Manjaro Linux x86_64
██████████████████ ████████ Host: Latitude E5430 non-vPro 01
████████ ████████ ████████ Kernel: 5.7.6-1-MANJARO
████████ ████████ ████████ Uptime: 12 mins
████████ ████████ ████████ Packages: 1341 (pacman), 11 (snap)
████████ ████████ ████████ Shell: bash 5.0.17
████████ ████████ ████████ Resolution: 1366x768
████████ ████████ ████████ DE: Plasma
████████ ████████ ████████ WM: KWin
████████ ████████ ████████ WM Theme: Layan
████████ ████████ ████████ Theme: Layan [Plasma], Breath [GTK2/3]
████████ ████████ ████████ Icons: Tela [Plasma], Tela [GTK2/3]
Terminal: konsole
Terminal Font: Noto Mono 10
CPU: Intel i5-3320M (4) @ 3.300GHz
GPU: Intel 3rd Gen Core processor Graphics Controller
Memory: 867MiB / 3817MiB

There are a lot of intermittent freeze threads on the forum these days. They are hard to diagnose because they are hard to reproduce with just a couple of quick steps. There aren't enough clues here, though it is plausible that the update had a regression. Restoring the backup from prior to the update could help narrow that down (first backup any data new since that update.)

I see you've tried both kernel 5.4 and 5.7. It might be worth trying 5.6. If that works, then recent kernel maintenance (regression) is likely a fault. Some intermittent problems come from heat (dust clogged vents) or too many open tabs (low memory). These causes seem less likely in this case, but are worth checking. It might be worth running the self-test in setup mode (BIOS firmware) to make sure the hardware checks OK. Otherwise, keep reading this (and other) forums, especially other threads about freezing.

I'm sure of the freeze happens without any programs running because i tried different scenarios
like i started my laptop and kept it for idle after login after 20-30 mins the freezes starts but after using tty sometimes it unfreezes but most of the time i have to hard restart.
Different scenarios sometimes it works seamlessly but most of the times it is freezing which is pain in the ass.

I will try these methods for time being :smiley: thank you for suggestions.
any applications or program to record such things so i can update to the forum.

Generally, if a hard reset is needed to recover from a freeze, there is rarely a useful log. The freeze usually occurs before an error message can be generated. After I searched the forum for "KDE freeze", I saw that your system might benefit from kernel 4.14(LTS). The newest kernels typically work best with the newest hardware. 4.14 uses an older I/O scheduler that often works better with older hardware.

Freezing is a symptom of many different problems. Searching is your friend.

1 Like

Changed kernel 4.14(LTS) and kept it idle for 30 mins still freezes,but unfreezes after using tty (CRTL+ALT+F6) and back to main screen but starts freezing after 30 mins within use

Try masking or uninstalling tlp and see if there is any difference.

can you give me some CLI for it.
idk much about it so learning

https://forum.manjaro.org/search?q=sudo%20systemctl%20mask%20tlp%20%40tbg

tlp.service
     Loaded: masked (Reason: Unit tlp.service is masked.)
     Active: active (exited) since Tue 2020-06-30 15:43:44 IST; 3h 5min ago
   Main PID: 856 (code=exited, status=0/SUCCESS)
     CGroup: /tlp.service

Jun 30 15:43:43 Homelaptop systemd[1]: Starting TLP system startup/shutdown...
Jun 30 15:43:44 Homelaptop tlp[856]: Applying power save settings...done.
Jun 30 15:43:44 Homelaptop tlp[856]: Setting battery charge thresholds...done.
Jun 30 15:43:44 Homelaptop systemd[1]: Finished TLP system startup/shutdown.

Forum kindly sponsored by