Radeon RX 6800 with Kernel 5.10, black screen


recently I got myself a new Radeon RX 6800 (Power Color Red Devil, Silent BIOS). Searching the web I saw, that it should be supported by Linux, so I made a fresh install of the latest Manjaro (Nibia).
Unfotunately, there is only a black screen with a cursor after booting.

Using Strg+Alt+F2 I switched to tty and upgraded the Kernel from 5.9 to 5.10, but there is still a black screen. Mesa 20.3 is installed. I have no idea, what the problem is.

Is this new graphics card not supported? I thought that an up-to-date Kernel and Mesa would be sufficient. Do I have to wait for the next official Manjaro release?

My other hardware is:
Gigabyte B550 Aorus Pro V2
Ryzen 9 3900X

Thanks and best regards

Please check with inxi -Gazy if the amdgpu driver is bound to the device, then - if you use Xorg - you could run startx -keeptty -logverbose 99 -verbose 99 and see if that reveals any problems.

Thank You for the reply.

inxi -Gazy gives:

Device-1: AMD vendor: Tul driver: amdgpu v:kernes bus ID: 0b:00.0
chip ID: 1002:73bf
Display: server: Xorg 1.20.10 driver: ati,radeon unloaded: modesetting
alternate: fbdev, vesa tty: 240x67
Message: Advanced graphics data unavailable in console. Try -G --display

Your second command gives alot of text and the following error (I believe):

Using config directory: “/etc/X11/xorg.conf.d”
Using system config directory: “/usr/share/X11/xorg.conf.d”
Couldn’t exec xterm: No such file or directory
xinit: connection to X server lost
waiting for X server to shut down (II) Server terminated successfully(0).

What does that mean? The driver should be there but xserver/xterm is not installed properly? Besides the newer kernel I did not change anything after the fresh Manjaro install.

Thanks and best regards

Is xf86-video-amdgpu installed?

Yes. I just tried to install it but it is already there and up to date.

Do you have any custom Xorg configuration? /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/*?

Under /etc/X11/ there is:

  • mhwd.d
  • xinit
    xinitrc, xinitrc.d, xserverrc
  • xorg.conf.d

Can you run startx -keeptty -logverbose 99 -verbose 99 2>&1 | tee xorg.out, and then run cat xorg.out | curl -F 'clbin=<-' https://clbin.com, and post the link you get?

I am not allowed to post a link in this forum, but this is the end of the clbin-link:

Please also run cat ~/.local/share/xorg/Xorg.0.log | curl -F 'clbin=<-' https://clbin.com and post the link. And which desktop environment do you use? And what’s the output of mhwd -li?

Thank You that You are taking time for me.

I downloaded Manjaro Xfce.

mhwd -li gives:
Name: video-linux Version: 2018.05.04 Freedriver: true Type: PCI
No installed USB configs

The Xorg.log is under clbin:

I cannot see anything wrong with it. Please run

systemctl status lightdm.service | curl -F 'clbin=<-' https://clbin.com

I gather the installer worked OK and the screen functioned?

Yes, the installer functioned normally and without problems.

The lightdm.service-Log (it seems Light Display Manager didnt start properly):

What happens if you run sudo systemctl restart lightdm.service? If that doesn’t do anything, try:

sudo systemctl isolate multi-user.target
sudo systemctl isolate graphical.target

sudo systemcrtl restart lightdm.service
got me to the login and Desktop!

But after a computer-restart I end up in the black screen with blinking cursor again. So it seems, that I would have to restart the service after every boot. What is wrong with my installation or hardware?

sudo systemctl isolate graphical.target also got me into Login and Desktop. The default target for systemctl is already the graphical target. Still, I have to type this on every boot…

I think I was able to fix it and it could be helpful for some people. This is the info from the ArchWiki about LightDM:

It may happen that your system boots so fast that LightDM service is started before your graphics drivers are properly loaded. If this is your case, you will want to add the following config to your lightdm.conf file:


This command indeed helped me booting through to the login. Thank You very much pobrn for Your help and patience!

Thanks for sharing! But wow how stupid is that :woman_facepalming::man_facepalming:

Another thing which might help is adding the amdgpu module to the initial ramdisk:


(and then regenerating the image).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.