Radeon RX 6600 XT not booting to desktop, only black screen unless I use a TTY

Hi There, I tried to install my new Radeon RX 6600 XT GPU, and I can enter BIOS, and I can enter TTY, but it only boots to black screen with no desktop? It does however work with latest image from an USB, and apparently loads the correct FREE driver.

My old card is an RX 560, so I thought I could just swap them, as they both use video-linux.
I’ve already tried:

  1. Re-install kernel 5.13.13 and tried 5.14 too.
  2. sudo mhwd -a pci free 0300
    Told me driver was already installed.
  3. sudo mhwd -f -i pci video-linux
    Installed but still didn’t work
  4. Boot from USB stick apparently worked, and used correct driver for RX 6600 XT.
    I tried to install steam for testing, but steam-manjaro doesn’t currently work with my old GPU either, it only shows black screen in steam. Steam-native works, but repositories are not included to install that from USB. So I never really verified that the GPU was capable of gaming, but I’m pretty sure it would be.
  5. Tried to read the Xorg.0.log, and Xorg tries all sorts of very old Radeon drivers, I couldn’t see anything starting with RX was tried, RX 480 is from 2016, and the system works with my RX 560.

So my question is, how do I make my current install, work with the correct driver that is already installed, like the USB image apparently does?

Last resort would be a complete reinstall of my system, but I’d prefer not to have to do that.

Sorry for the long post, but I am very puzzled, I hope it helps pinpoint something?

P.S. Thanks to everybody involved with Manjaro, it’s absolutely my preferred distro. :slight_smile:

Hello @Buffalox :wink:

Would you like to share this log here as code?

Here it is explained, how to share information here, so that it is readable for everyone:

Did you try to start the display-manager manually?

sudo sysemctl start display-manager.service
1 Like

I don’t have the bootlog from the failed boot anymore, but I’ll get back to it when I have time to fiddle again.
I didn’t try to start display manager manually, Ill try that too next time.
I did run htop, and there are no display manager or desktop items running in the background.

1 Like

Then show the output of top on consle also.

P.S. can you post /var/log/Xorg.0.log ?

1 Like

I chose to reinstall, and now it works fine, games and all.
But I wonder why it didn’t work to swap out a Radeon RX 560 with a 6600 XT, when they both use video-linux? And why it works now, with the same kernel and drivers installed?

Without you giving us:

inxi --admin --verbosity=7 --filter --no-host --width
mhwd --listinstalled

for both the old setup and the new setup, no one will be able to answer “Why?”


P.S. As you chose to re-install, your original issue is now moot, so I’ll close this question now.