R7000P laptop can not access the system. Black screen in hybrid mode

  1. Laptop model: Lenovo R7000P 2023
  2. System information::manjaro linux 6.6 kde
  3. Problem Description:
  • You cannot enter tty with a black screen.
  • In the use of independent graphics card direct mode can be normal access to the system.
  • When using the mixed mode, grub needs to add the boot parameter acpi=off or nomodeset to enter the system normally.
  • The same problem occurs in ubuntu, deepin, arch, manjaro no matter what desktop environment.
  • Works fine under windows11.
  1. The computer configuration is as follows:
CPU:    AMD Ryzen 7 7840H w/ Radeon 780M Graphics 8 cores
Main board:    Lenovo LNVNB161216
RAM:    Hynix 16GB DDR5 5600MHZ ( 8GB + 8GB )
GPU:    AMD Radeon(TM) 780M ( 512MB / Lenovo ),NVIDIA GeForce RTX 4060 Laptop GPU ( 8GB / Lenovo )
Display screen:    NE160QDM-NYC [ BOE BOEOB38] ( 15.7 inch )
Hard disk:    UMIS RPEYJI T24MKN2QWY ( 1024GB ),WD_BLACK SN750 SE 500GB ( 500GB )
sound card:    AMD High Definition Audio Device,Realtek High Definition Audio,NVIDIA High Definition Audio
Network card:    ReaItek PCIe GbE Family Controller,RZ616 Wi-Fi 6E 160MHz
  1. Replenishment:

This is expected - not a quality seal though - as most devices are built for Windows.

This indicates that Linux kernel support with 6.6 for the apu is less than desirable.

Have you tried the latest mainline kernel?

sudo mhwd-kernel -i linux67

Vendors do not need to support Linux OOB but they do need to support Windows as the dominating system.

With Lenovo only a few systems has official Linux support

I tried linux 6.7 but it didn’t work either. A while ago my machine was fine, but after a reboot it was dead, but I’m sure I didn’t actively change anything.

That sounds strange … actually more like possible hardware failure?

Frankly I am a little confused where you think the issue is rooted.

Have you tried booting an ISO from USB - to hopefully rule out hardware issues?

Does it work with the APU only or is the combination with Nvidia which makes it fail.

Does this mean that your system can boot with the Nvidia GPU but not the AMD APU?

Could be … if that works then it is fine - I assume.

Dual graphics work differently with Linux that with Windows.

With a dual graphics - what I assume your translation mixed mode refers to - you have to specify if the app should use the dGPU

prime-run <appname>

From what I see on the forum this should not be done with steam.

Please use the forum search-function :mag: in upper right corner - Search results for 'prime-run' - Manjaro Linux Forum - I have no experience with dGPU and gaming.

1 Like

Since I haven’t found any specific beside on aliexpress, I would assume that this model is pretty a much china-only model?

No idea what you mean here. Usually and that is the case for most products, the integrated GPU will be the main one. That is what Linux require by default.

What do you mean by “mixed mode” ? Hybrid Mode is managed by Linux here and not by the BIOS/UEFI. So you boot into with your first main gpu, which is amd, and then switch on demand to the dedicated GPU, which is nvidia. Probably “mixed mode” on the UEFI Settings is a requirement of Windows?

Most laptops have their dGPUs not hardwired to the monitor, therefore the iGPU is used.

1 Like

Have you tried booting an ISO from USB - to hopefully rule out hardware issues?
Answer: If use Hybrid mode, The same question will result in a black screen in ISO from USB.

Does this mean that your system can boot with the Nvidia GPU but not the AMD APU?
Answer: I was able to work normally yesterday.

I don’t know where the problem occurred, but I feel like it was caused by the system accidentally modifying something because it was able to run normally before.

I have seen reviews of this laptop on foreign websites, and it seems that it is not exclusively supplied from China, and I am not very clear about it

Hybrid mode: In hybrid mode, the laptop utilizes both the integrated graphics card and the dedicated graphics card simultaneously. The integrated graphics card handles general graphics tasks and low-power applications, while the dedicated graphics card is used for more demanding tasks like gaming or graphic design. The system automatically switches between the two cards based on the application’s requirements, providing an optimal balance between performance and power efficiency.

Discrete mode: In discrete mode, the laptop exclusively uses the dedicated graphics card to handle all graphics tasks, without utilizing the integrated graphics card. This mode is ideal for users who require higher graphics performance, such as gamers or professional graphic designers. By relying solely on the dedicated graphics card, the laptop can deliver enhanced graphical capabilities and a smoother visual experience.

Then in traditional sense that means:

  • Hybrid mode: Boot with iGPU
  • Discrete mode: Boot with dGPU

What do you mean by that then?

This is a log file.
https://0x0.st/HIhJ.txt

In Discrete mode, the system can boot up normally without experiencing any black screen issues.

These two modes can be selected in the BIOS settings.

Ah alright, then you installed straight nvidia-only? If installed with mhwd, then there must be a config in /etc/X11/xorg.conf.d/90-mhwd.conf. That says to xorg, that there is only nvidia and ignore anything else. Thus you see at Hybrid Mode a black screen. I guess that makes sense now.

The black screen issue occurred before installing the NVIDIA driver.


Alright, I hear you. Any logs for that? I don’t see any problems in log which you provided, regarding to the amdgpu driver.

How it should work:

  • Hybrid mode:
    • No config
  • Discrete mode:
    • With config
  • Config: /etc/X11/xorg.conf.d/90-mhwd.conf

In Hybrid Mode you can switch the gpu with software like:

which are also in the official repo of Manjaro.

1 Like

I have been trying to locate information on Legion R7000P 2023.

I can find references but further down it appears to be a device which is only available for east asia.

The APU 7840H is the same as is has long been advertised for by some Linux laptop vendors - although those systems seems to be - mostly - withdrawn now - possible it is either supply issues or technical issues.

I have found that [Tuxedo Pulse] appears to be based on a similar APU 7840HS.

For your further troubleshooting I suggest you try figuring out where the problem is rooted.

If the firmware permits it

  • disable the Nvidia card

Then get the APU in a functional state.

When you know how to operate the system without Nvidia you are better equipped to troubleshoot the Nvidia GPU configuration.

I don’t know, I couldn’t find anything valuable in the log either.

There is no such folder.
/etc/xorg.conf.d

There is this folder.
/etc/X11/xorg.conf.d
There are the following files:
-rw-r–r-- 1 root root 232 1月11日 05:41 00-keyboard.conf
-rw-r–r-- 1 root root 131 1月 2日 09:43 30-touchpad.conf

Then I really wonder if you use the nvidia gpu…

Please check:

glxinfo -B

and

echo $XDG_SESSION_TYPE

Since you don’t have any configuration partaining Nvidia - one has to speculate - how did you install the Nvidia driver?

Using Nvidia’s installer on an Arch based system is a no-go - it only creates problems.

Using mhwd - will create a drop-in folder /etc/Xorg/mhwd.d with a configuration symlinked into /etc/Xorg/xorg.conf.d - as @megavolt mentions.

1 Like

I am currently in the “nomodeset” state. Here are the outputs of the two commands.

glxinfo -B                                                                                                                                                           
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa (0xffffffff)
    Device: llvmpipe (LLVM 16.0.6, 256 bits) (0xffffffff)
    Version: 23.1.9
    Accelerated: no
    Video memory: 15166MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 31 MB, largest block: 31 MB
    VBO free aux. memory - total: 11624 MB, largest block: 11624 MB
    Texture free memory - total: 31 MB, largest block: 31 MB
    Texture free aux. memory - total: 11624 MB, largest block: 11624 MB
    Renderbuffer free memory - total: 31 MB, largest block: 31 MB
    Renderbuffer free aux. memory - total: 11624 MB, largest block: 11624 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 4293288272 MB
    Total available memory: 4293303438 MB
    Currently available dedicated video memory: 31 MB
OpenGL vendor string: Mesa
OpenGL renderer string: llvmpipe (LLVM 16.0.6, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 23.1.9-manjaro1.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 23.1.9-manjaro1.1
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.1.9-manjaro1.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
echo $XDG_SESSION_TYPE                                                                                                                                               
x11

These two software programs are not effective; the black screen issue still persists.