Question about new 5.10 kernel and nvidia-prime support

i’m still on 5.9.16-1
i just installed the latest update and dealt with uninstalling the old 455xx nvidia packages,got the new ones and installed the non-free nvidia driver.
the installation seemed to have gone smooth,but i haven’t tried running on the nvidia GPU yet.

now i’m on a laptop(intel/nvidia)and saw in a topic that @philm said that:
" linux510 doesn’t support nvidia-prime . You may want to use linux54 or linux59 ."
does that mean that if i was to update the Kernel to 5.10,i would have to use the nouveau driver and loose the ability to use the proprietery driver?
my card is a 1050.

PRIME render offload should work on 5.10, at least it did work when I last tried it.

1 Like

What? i’m on 5.10 and have nvidia-prime and its working perfectly. I have a i5 7300HQ and GTX 1050 Ti.

1 Like

For me nvidia-prime does not work on kernel 510, works fine on 59, so I am guessing it is hit and miss.

1 Like

Show please the contents of pacman -Q | grep nvidia , you have linux510-nvidia there?

(Related to the discussion here [Testing Update] 2020-12-31 - Kernels, Mesa, XFCE 4.16, Deepin, Haskell, Python)

Nvidia prime is working for me on 5.10 with latest Nvidia driver. All my steam games work and

prime-run glxinfo | grep OpenGL

Shows the nvidia card is being used

1 Like

There was an issue for some reason that linux510-nvidia package was missing. I readded that now to our stable branch.


Yes its there

❯ pacman -Q | grep nvidia
lib32-nvidia-utils 455.45.01-3
linux510-nvidia 455.45.01-8
mhwd-nvidia 455.45.01-3
mhwd-nvidia-390xx 390.138-1
nvidia-prime 1.0-4
nvidia-utils 455.45.01-2

i have a question,
as i said;the OS update with kernel 5.9 and after removing old NVIDIA packages and installing the new ones, everything works fine for me,
but it seems I’ll probably have to get the 5.10 kernel;
-do i need to do something with the current NVIDIA packages i have?(uninstall,)or does the update takes care of it?
i mean right now i have

linux59-nvidia 455.45.01-6
and the new one is  linux510-nvidia 455.45.01-8

what should i do?

pacman -Q | grep nvidia
lib32-nvidia-utils 455.45.01-3
linux59-nvidia 455.45.01-6
mhwd-nvidia 455.45.01-3
mhwd-nvidia-340xx 340.108-1
mhwd-nvidia-390xx 390.138-1
nvidia-prime 1.0-4
nvidia-utils 455.45.01-2

If you install 5.10 with mhwd then you should be fine. You can always boot back into 5.9 from grub if there’s any issues

sorry,but i don’t fully understand.
as you can see,i have the same nvidia packages as @XRaTiX after his update to 5.10 kernel,appart from the


when i browse pamac, i see there is a

linux510-nvidia 455.45.01-**10**.0

so should i first update to the 5.10 kernel and then remove the linux59-nvidia and install the linux510-nividia,or should i do it before hand?
or maybe remove all the NVIDIA packages and then after the 5.10 kernel update reinstall them all again?(and this time with linux510-nividia),
or does the kernel update does it automatically?or do you suggest updating to 510 kernel and then run sudo mhwd -a pci nonfree 0300 ?

Update to 5.10 kernel with the Manjaro Settings Manager,then reboot and change to that kernel,it does all the packages automatically.

When everything is working with the new kernel you can remove the 5.9 kernel,all the packages from 5.9 is gonna be removed.

When you are in kernel 5.10 you can install the new driver with the GUI or with sudo mhwd -a pci nonfree 0300 and thats it,I did this in this order.

The only problem I had is that there was a conflict installing the new driver because there was a nvidia-455xx-utils package,I remove that package in pamac manually and then i was able to install the new driver then I reboot,I don’t know if that has been resolved already.


Thanks you
I’ll probably try that soon and report back.

the kernel upgrade seems to have went well so far.
in hardware configuration, video-hybrid-intel-nvidia-prime is installed on proprietary and in nvidia xserver settings it says i’m running the 455.45.01 driver
i changed with optimus-managet-qt to nvidia and it works,but i have quit poor performance with it on regular browsing on which I’ll post in another thread(mostly screen tearing).