Question about autocpu-freq and battery saving

My last laptop was a late 2011 MacBook Pro dual boot Manjaro and OSX. It died a year ago so to say that I am a laptop newbie is correct.

Currently running 5.10.83-1 Manjaro stable with Plasma on a HP Pavilion Gaming laptop with a Ryzen 7 4800H CPU, Radeon or NVidia GTX 1650TI graphics. I pretty much nuked Windoze 10 off the SSD and installed Manjo. Where I live in Ecuador this was the best performance /price point laptop that was available and my first HP as well. I took a Manjaro bootable thumb drive to the shop before I bought it and had a number of people standing around wondering “what is that” running Manjo in live mode.

The battery isnt huge…this version of the Pavilion Gaming comes with a 51.7Wh battery limited by a SATA drive bay (which I am going to put to use with the install of a 1 Tb SATA SSD) so I knew that I was going to have to do some system optimizing. In process of my reading I installed autocpu-freq. I installed it where it would run in daemon mode. When I “autocpu-freq --stats” before it starts it’s 5 second page renewal with whats happening with the CPU I get a couple of warning messages one that its unable to detect whether TLP is running or not and warnings about conflicts there… and the second a warning about gnome power profiles daemon service and a possible conflict there… I uninstalled TLP and still receive the warning. In trying to determine if there is a problem with Gnome’s profiles I run powerprofilesctl and get command not found so think the Gnome power profiles may not be there.

I have read pretty extensively here on the laptops section both before I bought the HP and since. Can anyone point me to more power saving hints ? I am getting, with low screen brightness, browsing and some word processing, between 4 and 5 hours of battery life. This before I installed autocpu-freq. Any pointers or suggestions appreciated.


I do not recommend using auto-cpufreq. The code is improving, but is still a mess, is not designed for being installed with a package manager and the AUR maintainers don’t seem to notice or care.

It [auto-cpufreq] doesn’t take user-intent into account, doesn’t have a D-Bus interface and
seems to want to work automatically by monitoring the CPU usage, which kind
of goes against a user’s wishes as a user might still want to conserve as
much energy as possible under high-CPU usage.

I suggest using tlp, but also keep an eye on power-profiles-daemon.

1 Like


Thanks for the suggestions. Does TLP conflict with power-profiles-daemon??
Interestingly when I run powerprofilesctl it shows the package not installed…

Yes. Only one should be installed and enabled at a time as they all attempt to do the same thing in different ways.

That’s fine, don’t bother installing it right now.

1 Like

Thanks very much for this. I have reinstalled TLP. Also checked with glxinfo | grep render to see which GPU was running things on battery mode and it is the AMD Renoir. So that seems to be operating as I think it is supposed to. When starting nvidia-settings (on battery mode) via su, I get a message that the X Server is not accessible and that app profiles will continue to work but values can not be pre populated or validated. When going to the NVidia GUI control panel there are no pŕofiles listed. So one wonders while the GTX 1650 TI may not be running the graphics if in fact it is powered down.

Interestingly in my further exploration about being able to power down the 1650TI I was led to the Arch howtos here
Hybrid graphics - ArchWiki and attempted the acpi_call method. Unfortunately installing acpi_call via pacman -S didnt yield the results indicated in the Arch wiki particularly the script used to find out which data bus the (in my case) Nvidia card was on and turn the power to it off… So I checked in the packages available, uninstalled acpi_call and installed acpi_call dkms via pamac. Rebooted and could not get the acpi_call module to even load on my kernel so I am at somewhat of a loss. Is anyone using acpi_call to power off their Nvidia?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.