Qualcomm WiFi suddenly not working

I booted up my Dell XPS laptop this morning and it didn’t even try to connect to WiFi. I hooked up a USB Ethernet adapter to get online, and that works. But the internal Qualcomm wifi adapter has stopped working for some reason.

I tried using ip link to bring it up, but no dice.

Here is the relevant output from dmesg, ip, and inxi:

dmesg | grep ath10k
[    2.508433] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    2.769587] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:143a
[    2.769589] ath10k_pci 0000:02:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[    2.769986] ath10k_pci 0000:02:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[    2.834005] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 20d869c3
[    3.413252] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
[    3.415799] ath10k_pci 0000:02:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    3.500445] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
4: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ba:db:40:1d:b2:9d brd ff:ff:ff:ff:ff:ff
    
inxi -Fx
System:
  Host: jw-dx13 Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.14.5 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 13 9370 v: N/A 
  serial: <root required> 
  Mobo: Dell model: 0H6H3J v: X00 serial: <root required> 
  UEFI [Legacy]: Dell v: 1.4.0 date: 05/25/2018 
Battery:
  ID-1: BAT0 charge: 52.0 Wh condition: 52.0/52.0 Wh (100%) 
  model: SMP DELL G8VCF6C status: Full 
  Device-1: hid-34:88:5d:89:bc:a2-battery 
  model: Bluetooth Mouse M336/M337/M535 charge: N/A status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
  Speed: 600 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 600 2: 600 
  3: 600 4: 600 5: 600 6: 600 7: 600 8: 600 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.2 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.16-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: f040 
  bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: ba:db:40:1d:b2:9d 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 2-1.2:7 
  IF: enp0s20f0u1u2 state: up speed: 1000 Mbps duplex: full 
  mac: 3c:18:a0:9c:18:23 
Drives:
  Local Storage: total: 238.47 GiB used: 80.36 GiB (33.7%) 
  ID-1: /dev/nvme0n1 model: SSDPEKKF256G8 NVMe INTEL 256GB size: 238.47 GiB 
Partition:
  ID-1: / size: 217.34 GiB used: 80.36 GiB (37.0%) fs: ext4 
  dev: /dev/nvme0n1p1 
  ID-2: swap-1 size: 16.64 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 206 Uptime: 2h 28m Memory: 15.12 GiB used: 1.58 GiB (10.4%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.30 

A couple more outputs that may be helpful in diagnosing this:

lsmod | grep ath
ath10k_pci             61440  0
ath10k_core           532480  1 ath10k_pci
ath                    36864  1 ath10k_core
mac80211              929792  5 rtl_usb,rtl8192cu,rtlwifi,rtl8xxxu,ath10k_core
cfg80211              778240  4 rtlwifi,ath,mac80211,ath10k_core

rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

I can also report that, when booting from a live USB, wifi works flawlessly.

So it’s not a hardware issue.

Have you tried removing your stored SSID/password and reconnecting to the wifi?

My USB was disconnecting randomly after the upgrade. I wasn’t sure if it was caused by the upgrade, or my router. I removed my stored password, rebooted both the PC and router/modem and all was well again.

1 Like
1 Like

rodneyck, good thought about the stored SSID/passwords, but unfortunately that had no effect.

I should be more clear in my description of the problem: the system doesn’t even try to connect. I don’t even see a list of nearby SSIDs.

1 Like

FadeMind, I’m on 4.19 and firmware-6.bin is present. So it seems like that shouldn’t be the issue?

This may be another Atheros firmware issue. Unfortunately it doesn’t have an easy solve like the qca9377. Switching the firmware between version 4, 5, or 6 hasn’t seemed to help with this adapters issues.

one thing I can suggest is to put your laptop into suspend, then resume and see if the status changes. The problems with this adapter just started cropping up recently but no fixes have started working yet.

See this current thread:

If you adapter works on the live disk then that tends to indicate a kernel change or a change in network manager is responsible. Test as many different kernels as possible.

Installing networkmanager-noscan from the AUR might be another possible option.

2 Likes

which live iso did you test with? a slightly older one or one you just downloaded? and is it a kde iso?

1 Like

I tested with the manjaro-kde-18.0.2-stable ISO.

did you do an update the night before and go to use it and wifi didnt work? possibly see which update could of cause it and see if you can downgrade?

Perhaps try downloading the newest firmware from github.

Do not overwrite the old firmware in /lib/firmware. Either rename or move the old firmware to a backup location.

That’s the funny thing. I reboot after every update, and just like every time before, I rebooted after yesterday’s update. And everything came up fine, and continued working for hours.

It was only this morning, when I booted my laptop, that the problem occurred. And nothing I’ve done has made it even do a search for nearby SSIDs (aside from booting the live USB).

Have you tried deleting the connection in Network Manager and then recreating it?

Have you tried running any ping commands (disconnect LAN).

ping -c5 8.8.8.8

ping -c5 google.com

ping -c5 127.0.0.1 

ping -c5 localhost

Please post the outputs.

1 Like

tbg, unfortunately new firmware didn’t fix it.

Here are the ping outputs you requested:

[jwalsh@jw-dx13 ~]$ ping -c5 8.8.8.8
connect: Network is unreachable
[jwalsh@jw-dx13 ~]$ ping -c5 google.com
ping: google.com: Name or service not known
[jwalsh@jw-dx13 ~]$ ping -c5 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.050 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.132 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.121 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.128 ms
^C
--- 127.0.0.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 31ms
rtt min/avg/max/mdev = 0.050/0.107/0.132/0.035 ms
[jwalsh@jw-dx13 ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.055 ms
^C
--- localhost ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.055/0.055/0.055/0.000 ms
[jwalsh@jw-dx13 ~]$ 

Did you make the firmware executable and reboot?

Sorry, but the forum connection is so poor that I don’t think I can provide support ATM. The forum is stalling and failing to connect all day on my end.

cat /etc/resolv.conf

I did reboot, but didn’t make the file executable. The existing ones did not appear to be.

sudo chmod +x /path/to/firmware

Making the firmware executable had no effect.

Forum kindly sponsored by Bytemark