QtCreator 4.6.1 troubles

qt5

#1

when we build and run Example projects, after coping them to home folder, we get 2 errors:

  1. Cannot read /home/gmat/Workspace/qt/rasterwindow/rasterwindow.pri: No such file or directory
  2. qmake.stash file or directory is not present.
    (screenshot attached)
  3. you are using /usr/bin/g++ but qmake spec has /bin/g++
    (screenshot attached)

Also, there are two seperate g++ executable files in my manjaro. Is this an anomaly?
(screenshot attached)Screenshot_20180529_215429


#2

No Manjaro user is facing this issue?


#3

The second part - /bin is a symlink to /usr/bin so it is reporting the same file twice.


#4

If it was symbolically linked, would not it have shown by below command?
ls -al


#5

The folder is linked.

Try this

cd /
ls -la *bin*
lrwxrwxrwx 1 root root 7 Apr 27 12:51 bin -> usr/bin
lrwxrwxrwx 1 root root 7 Apr 27 12:51 sbin -> usr/bin

Also

locate g++  | grep -i  bin                                                  
/usr/bin/clang++
/usr/bin/g++
/usr/bin/wineg++
/usr/bin/x86_64-pc-linux-gnu-g++

#6

you should check your PATH environment variable
what is the output of
echo $PATH

as which g++ should return you /usr/bin/g++

check your sddm config like as under


#7

Sir,
If I reinstall from scratch using Manjaro Architect, will the problem and other potential problems like

It’s also possible to have other weird problems in some scripts because of this

be solved?


#8

if you check and change the sddm config like as explain you should not have problem anymore. (if it was wrong) after the change a logout-login is required (maybe even a reboot).
and check your PATH again to don’t have /bin it it.
if it does not solve the qt problem, maybe try to delete the config file of qt-creatore and/or reimport the project.


#9

Point no 3 is solved through the solution provided by learned user scachemaille.
Point 1 and 2 remains.


#10

It was a qtcreator bug which has been resolved in qtcreator version 4.6.2

Hoping to get the update soon in stable.


#11

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.