Qt5 linked to openssl 1.1 ? (Renderman installation)

I’m told that my Qt version is linked to my openssl 1.1, but Qt5 doesn’t support openssl 1.1.
How can I check what my Qt is linked to ?

pacman -Qi qt5-base
.

Depends On : libjpeg-turbo xcb-util-keysyms xcb-util-renderutil libgl fontconfig xcb-util-wm libxrender libxi sqlite xcb-util-image icu tslib libinput libsm libxkbcommon-x11 libproxy libcups openssl-1.0

Both 1.1 and 1.0 packages are available

core / openssl 1.1.0.f-1 [installed]
extra / openssl-1.0 1.0.2.l-1 [installed]

Thanks, I also have 1.0 in the dependencies. However the person who told me about that is insisting that Qt5 is trying to do things with ssl-1.1 or that it’s missing some ssl features required to install my program properly.
I don’t know what to do from there.

"your program"
Ok what exactly are you doing, and what errors are you getting ?
As you can see from above OpenSSL (V.1.1) is part of ‘core’ … as in you definitely have it, unless your install is on fire. ‘openssl-1.0’ is in ‘extra’ but is required by qt5 … so on a system like KDE it is rather required as well.

Please explain what you are installing, how, and share whatever errors you are encountering.
[copy/paste]

QT5 is using openssl-1.0.

Sure, so I’m trying to install Renderman (the free non commercial version). I’ve managed to install it and get it working on Ubuntu and OpenSUSE and on these distros I only have one openssl version (1.0).
When I run the installer in Manjaro (as root as I should), I get this error in the terminal :

Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

The installer opens anyway and I enter my credentials and click next and this popup appears :

Failed to get license file
Failed to query serial number:
an unknown network-related error was detected

and when I close the installer the terminal gives this :

RenderMan Installer[1601]: RenderMan Installer Warning: QSslSocket: cannot call unresolved function CRYPTO_num_locks
RenderMan Installer[1601]: RenderMan Installer Warning: QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
RenderMan Installer[1601]: RenderMan Installer Warning: QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
RenderMan Installer[1601]: RenderMan Installer Warning: QSslSocket: cannot call unresolved function ERR_free_strings

None of these errors happened in the other 2 distros.

How do you install it? It seems to be designed for OpenSSL v1.0 rather than v1.1 we have. Try to run the following before starting the installer: export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'

I extract the content of the rpm package to /opt/pixar and run

su
./RenderManInstaller

like I did for the other distros.

running export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto' before RenderManInstaller didn’t seem to change anything. I still get the same errors.

I’m quite stuck at the moment. Help is very welcome.

In your renderman installation folder, does it have a lib folder? If so, you could try to make a symlink to the openssl 1.0

or you could try to copy /usr/lib/libcrypto.so.1.0.0 and /usr/lib/libssl.so.1.0.0 to your installation folder and see what happen…

I have a lib folder but can you clarify “try to make a symlink to the openssl 1.0” ?

Also I really don’t see how simply copying libcrypto and libssl to the installation folder can do anything if those files are not referenced in the installed files

Assuming something without trying it out really won’t solve the problem…

Do this if you want to prove me wrong :

  • Try installing openssl-1.0 first
sudo pacman -S openssl-1.0
  • Then copy /usr/lib/openssl-1.0/libcrypto.so and /usr/lib/openssl-1.0/libssl.so to the lib folder that located in your installation folder

  • Then do the installation again :

su
export QT_X11_NO_MITSHM=1
./RenderManNC-Installer

Note : I added export QT_X11_NO_MITSHM=1 so we can bypass this error on Arch/Arch-based distro (That is if we can bypass openssl issue ):

NCRInstaller[13547]: ncr Warning: X Error: BadAccess (attempt to access private resource denied) 10  
…

Source :
https://bbs.archlinux.org/viewtopic.php?id=187234

Hope this helps…

My binary installer file is not named RenderManNC-Installer but simply RenderManInstaller. Where did you get yours from ? Mine is from the rpm package named RenderMan-InstallerNCR-21.4.0_1747743-linuxRHEL6_gcc44icc150.x86_64.rpm

Anyway I tried what you said but nothing changed.
My installation folder tree goes like this, in case it helps :

opt
└ pixar
  └ RenderMan-Installer-ncr-21.4
    ├ bin
    └ lib
      ├ 3rdparty
      │ └ Qt-5.6.1
      │   ├ lib
      │   └ plugins
      │     ├ iconengines
      │     ├ platforms
      │     └ imageformats
      └ Resources
        ├ images
        └ stylesheets

I have both openssl-1.0 (extra) and 1.1 (core) installed and tried copying libcrypto.so and libssl.so in the first lib folder, then running the commands you gave under the bin folder but I got the exact same errors as before. I also tried moving the libssl and libcrypto files in the second lib folder (under QT5) and then I tried with symlinks instead of the files themselves. Still the same.

However I found that these files under lib/3rdparty/Qt-5.6.1/lib/ contain the word “openssl” in them :

libQt5Network.so.5
libQt5Network.so
libQt5Network.so.5.6.1
libQt5Network.so.5.6

should I do something about them ?

Hmmm not sure, but I suggest the above method before from this thread below. It might worth check it out :
* Look at post #545

https://blenderartists.org/forum/showthread.php?375734-Pixar-RenderMan-for-Blender!/page28

The above will also explain why I add ./RenderManNC-Installer (Because that was for blender’s renderman…Sorry!)

That’s crazy. I tried that yesterday and it didn’t work, but now it did !
I don’t know what I did wrong. Maybe a typo in a symlink or something stupid like that.

Anyway, thank you so much. I honestly didn’t think simply putting a symlink in the right folder would make the installer go "oh, there’s libssl 1.0 here, I can use that !"
let me do that for ya :
𝕋𝕙𝕖𝕄𝕠𝕣𝕖𝕐𝕠𝕦𝕂𝕟𝕠𝕨
===============★

And yeah, the plan is also to have it for Blender. High five !
But guess what, you break a wall and behind it… is another wall !
Now I can’t enable the add-on and it gives me this when I try checking the box in the Add-ons tab :

Traceback (most recent call last):
  File "/home/caetano/Installed_programs/blender/2.78/scripts/modules/addon_utils.py", line 349, in enable
    mod.register()
  File "/home/caetano/.config/blender/2.78/scripts/addons/RenderManForBlender-master/__init__.py", line 121, in register
    load_addon()
  File "/home/caetano/.config/blender/2.78/scripts/addons/RenderManForBlender-master/__init__.py", line 95, in load_addon
    if guess_rmantree():
  File "/home/caetano/.config/blender/2.78/scripts/addons/RenderManForBlender-master/util.py", line 553, in guess_rmantree
    "Error loading addon.  RMANTREE %s is not valid.  Correct RMANTREE setting in addon preferences." % rmantree)
  File "/home/caetano/.config/blender/2.78/scripts/addons/RenderManForBlender-master/util.py", line 59, in throw_error
    raise ImportError(msg)
ImportError: Error loading addon.  RMANTREE  is not valid.  Correct RMANTREE setting in addon preferences.

See? I told you so!

And dont forget mark my post as a solution! :ballot_box_with_check:

Try setting your RMANTREE in your add on preferences…

well I was trying to find what it means but I don’t find any option when expanding the renderman add-on in the prefs.

1 Like

I’ll research this later when I’m home…

Until then, best of luck! :kissing_closed_eyes:

Please look at this …

That seems like the answer but I don’t have these Preferences.
Note that I have them on OpenSUSE

Forum kindly sponsored by