qt5 commonly breaks something?!

Using testing manjaro deepin, occasionally updates of qt5 packages break stuff. Last thing that broke was Ultimaker Cura 4.1 (3d printing software), cura package from community repo. Luckily there is Ultimaker Cura 4.1 appimage that works.
And yeah, there is "huge viber" issue too, related to qt scaling factor. Finally fixed it by setting env QT_AUTO_SCREEN_SCALE_FACTOR=0. Setting env QT_SCALE_FACTOR=1 was hit and miss.
Do you guys also experience random issues due to updating qt packages or am I only lonely angry wolf? :smiley:

No you're not alone...

QT is system-wide dependency for systems like Deepin & KDE, as well as half of all programs - so any slightly small typo or bug in it certainly will affect a lot...

It makes me quite sad :worried:

1 Like

Yeah, it's annoying that QT 5.11+ broke Cura 4.1 and Teamviewer 14 on my system. It's annoying and I have to use both the Cura AppImage and TeamViewer 14 with QT_SCREEN_SCALE_FACTORS=1 to get some decent display.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by