Qt-based applications stopped working on Manjaro-Gnome

Can’t imagine that the following helps, but at least it’s a test for inserting system information:

LC_ALL=C  inxi -v7azy                                                                                                                                                                    
✔ System:
  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=b363c8c9-8b22-4f3c-a757-e62b7a203746 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: FUJITSU product: ESPRIMO D538 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: FUJITSU model: D3600-A1 v: S26361-D3600-A1
    serial: <superuser required> UEFI: FUJITSU // American Megatrends v:
    R1.21.0 for D3600-A1x date: 07/04/2019
  Message: No system battery data found. Is one present?
  System RAM: total: 32 GiB note: est. available: 30.21 GiB
    used: 8.59 GiB (28.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Pentium Gold G5600 bits: 64 type: MT MCP arch: Coffee Lake
    level: v2 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 0xB (11) microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1232 high: 1400 min/max: 800/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1400 2: 800 3: 1330
    4: 1400 bogomips: 31211
  Flags: 3dnowprefetch abm acpi aes aperfmperf apic arat arch_capabilities
    arch_perfmon art bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    flexpriority flush_l1d fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
    hwp_notify ibpb ibrs intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Fujitsu Solutions
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:3e91 class-ID: 0300
  Display: x11 server: X.org v: with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Samsung S27D390 serial: <filter>
    built: 2015 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    device-ID: 8086:3e91 memory: 29.5 GiB unified: yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Fujitsu Solutions
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Fujitsu Solutions driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter driver: N/A
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:6
    chip-ID: 0bda:f179 class-ID: 0000 serial: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.79 TiB used: 606.7 GiB (21.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P3SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 31.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EFRX-68EUZN0
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A82 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: Ultra Fit
    size: 57.84 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1.00
    scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 93.13 GiB size: 91.11 GiB (97.83%) used: 24.08 GiB (26.4%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 label: cme1t.manjaro_g
    uuid: b363c8c9-8b22-4f3c-a757-e62b7a203746
  ID-2: /boot/efi raw-size: 954 MiB size: 952.1 MiB (99.80%)
    used: 5.4 MiB (0.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: CME1T_EFI uuid: 4A16-8340
  ID-3: /home raw-size: 93.13 GiB size: 91.11 GiB (97.83%)
    used: 2.07 GiB (2.3%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: cme1t.mg_home uuid: fea79138-08a0-4ad1-acbf-cf0dbf147c0a
  ID-4: /mnt/data raw-size: 372.72 GiB size: 365.81 GiB (98.15%)
    used: 44.49 GiB (12.2%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: cme1t.data uuid: 75b32bf9-4850-4499-94d6-cb737cc173d9
  ID-5: /mnt/dt.bkp raw-size: 908.58 GiB size: 893.25 GiB (98.31%)
    used: 522.26 GiB (58.5%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: wd2t.bkp
    uuid: 0ccc4358-5553-49be-a2d5-62fcce9e24d9
  ID-6: /mnt/sys.ts raw-size: 931.51 GiB size: 915.82 GiB (98.32%)
    used: 2 MiB (0.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: wd2t.ts
    uuid: 46399e9f-c924-418b-b49e-fd610ab96b4f
  ID-7: /run/media/tn/Transporter raw-size: 57.84 GiB
    size: 56.63 GiB (97.91%) used: 13.79 GiB (24.3%) fs: ext4 dev: /dev/sdb1
    maj-min: 8:17 label: Transporter uuid: 6b52de8e-1520-4301-baa8-263317452d48
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 36.32 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2 label: cme1t.swap
    uuid: 8a3d6405-5b6b-4989-9631-0d94e08239f5
  ID-1: /dev/nvme0n1p4 maj-min: 259:4 size: 93.13 GiB fs: ext4
    label: cme1t.ubuntu_u uuid: 10735d2a-ef74-4298-9717-7a61f392b017
  ID-2: /dev/nvme0n1p6 maj-min: 259:6 size: 93.13 GiB fs: ext4
    label: cme1t.uu_home uuid: 70039cea-c21a-45e9-b71e-fa26cbba05de
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-1:2 info: SanDisk Ultra Fit type: mass storage
    driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s (57.2 MiB/s)
    lanes: 1 mode: 2.0 power: 224mA chip-ID: 0781:5583 class-ID: 0806
    serial: <filter>
  Device-2: 1-5:3 info: Areson Corp 2.4G Wireless Receiver
    type: keyboard,mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 25a7:fa10 class-ID: 0301
  Device-3: 1-6:4 info: Shenzhen Rapoo 5G Wireless Device
    type: keyboard,mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 24ae:2002 class-ID: 0301
  Hub-2: 1-7:5 info: Genesys Logic Hub ports: 4 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-8:6 info: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter
    type: WiFi driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s)
    lanes: 1 mode: 2.0 power: 500mA chip-ID: 0bda:f179 class-ID: 0000
    serial: <filter>
  Hub-3: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 42.0 C pch: 44.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 259 Uptime: 1h 20m wakeups: 0 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1552 libs: 377
  tools: gnome-software,pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.30

If I knew what information is necessary to answer that question, I might have been able to find it myself.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Post error messages from a qt application that doesn’t work. Try to start one then use journalctl -S -2m --no-pager to get the last 2 minutes of system log.

And use 3 backticks to format command output.

Well, in those tutorials, for example, you might have noticed that placing all that pasted text between backticks (```), top and bottom, would have produced a more human-readable preformatted text container:

Hi, I am an example of preformatted text.
Each line of the original text stays on it own
line, and makes it easier to read. 

The information was important as it helps others to help you. For example, knowing your system information may help someone decide if an issue is a commonly known problem, or specific to your system.

We’re here to help, if we can, but you need to help us too; we’re not mind-readers. :slightly_smiling_face:

All the Qt applications don’t work anymore.
Or, they pretend to work (open and close (on clicking the “×” in Gnome’s extra decoration (title bar)) without complaint), but the graphics is corrupt and clicks in the application’s window hardly work at all, at least don’t work as they did before.

E.g. settings manager:
Bildschirmfoto vom 2023-10-17 12-28-39

Icon and title clipped and clicking has either no effect or effects nothing but an eternal hourglass mouse pointer.

And they don’t send error messages - journalctl doesn’t get any related information.

(If any reader knows an easy markdown editor with preview and integrated cheat sheet, please let me know!)

How long is it since you updated your system? Not too long, I imagine, judging by the kernel. You might try reverting to the 6.1 LTS kernel to see if that makes any difference.

Without results from commands such as that given by MrLavender above, it’s difficult for anyone to diagnose.

Create a new user and login on that. Is the problem present there?

Yes = system problem

No = user configuration problem (probably theme related)

The problem seems to be in the system configuration (hopefully not deeper) and affects all users.
If I knew where to find all files for Qt-related settings …
(the (only) one I’ve found so far and have reported in #1, doesn’t seem to affect it - or I don’t know how to change that file effectively)
… I could check them one by one and try to fix the problem there.

Have you tested that theory? How? What are the results?

( … gosh, I sound like my old physics professor … )

The original of that config-file, /etc/profile.d/qt-theming.sh is dated 23-08-30.
So I assume that the update of 8/30 has caused the problems.
(there have been more than 50 further updates in the meantime)

Or, it didn’t need to be updated. I have one just like it. That’s not an issue.

Try this suggestion, and report back.

Logged in as another user - same behavior as with my standard user.

better not - my physics professor (phd tutor) died a few years ago

see above

sorry for that typo - had corrected it to 8/30, probably while you were typing your answer

The point is, that’s a script; and it seems as it should be, at first glance. It’s likely that didn’t need to be upgraded, so it wasn’t. If your theory is based solely on the content of that script, it’s probably wrong.

The problem is something else. Being that you’re using Gnome, which I have no interest in, it’s likely I’m no direct help, but I’m sure someone else might be. Help them as much as you can. If someone asks you do do something, do it, and more importantly, report back the results.


/etc/profile.d/qt-theming.sh is owned by the package manjaro-gnome-settings.

pacman -Ql manjaro-gnome-settings will list all other files in that package. See also pacman -Ql qt5ct.

1 Like

uhh - that’s a lot!
But looks promising!
Will check them - and need a few hours, maybe till tomorrow, to report about the outcome.

Well, didn’t take that long.
… and didn’t seem to keep the promise: most of the files show hardly any relation to Qt-fine-tuning.
And most are specific for one (and only that one) application: so cannot contain a setting affecting all Qt-applications simultaneously.

BUT: there’s one exception.
Have seen that earlier, but never thought it could have an effect for my ordinary 2K-Monitor (all but high-dpi).
But It has!! :+1:

Setting the QT_AUTO_SCREEN_SCALE_FACTOR (from 1.0) to 0.8 reveals a larger part of the Qt-application’s window …

… compared to the screenshot in #6. And makes the items clickable!

Remains to find the correct scale factor - just a matter of patience.

BIG thanks @ “MrLavender”!

I’m afraid it’s not that simple. But it points in the decisive direction.
It’s about a global scale factor. And the one I used to get Gnome using the screen estate in a sensible way, i. e. not destroying it (the screen estate) by abusing 60% of it for its huge decorations.

… and yes I see why Gnome has lost popularity. Versions >4 make it more and more useless. But it’s the only DE I found that allows to have two docks, a horizontal and a vertical one at 2 sides of the screen (via its extensions dash to panel and dash to dock) and an applications overview without a multiply nested menu.

Need to find another way to scale the Gnome - back to a gnome from the bloated giant.

p.s.: This topic is definitely solved - at a high price.
Fear that current Gnomes require an 8k Monitor or better to become sensible - but that would be a new topic.

(Still don’t know why it had worked before that update.)


Don’t get it to work: “xrandr: Configure crtc 0 failed”
Would probably need umpteen additional settings.
And: " This article or section is out of date … Gnome Shell Toolkit … looks unmaintained since 2009"

But I don’t think that this direction to fix these new display problems of Qt applications will work ever.
My Notebook with a <2 k display works perfectly including Qt with Linux 6.4.14-1 and Gnome 44.4 … and doesn’t complain about pending updates although I just switched it on after almost 3 months of inactivity.

→ All the ~100 update sessions since end of August on this (“desktop”) computer ¹ seem to have tried Linux 6.5 related bug fixing - to no avail.
¹) currently with Linux 6.5.5-1 and Gnome 44.5

p.s.: Well, the notebook does offer almost 3GB of updates …
But I’m not going to kill my only flawlessly working Manjaro installation before I’ve prepared the space for Timeshift and configured it.

It’s not an incompatibility of Gnome 44.5 and its settings with Qt and Linux 6.5 doesn’t break the compatibility.
Something had gone wrong during automatic processing of the update on 8/30.

Searching a possibility to go back to the flawlessly working system ¹ with Gnome 44.4 and Linux 6.4 (without a snapshot of the old system) looked more and more desperate.
Probably always a bad idea to go back with a rolling release, anyway.
¹) including the, also desperate, resort of a fresh re-install (and months of work to configure it)

So I tested a fresh installation on a separate partition. (and have been agreeably surprised to find the new Uranos .iso-image)
Installed it and found that none of the problems I got with the current Talos appeared.

So the next question arises:
How to upgrade the current Talos to a new Uranos and preserve the configuration of the Ui, the file system and the applications?

I have a separated home directory, parts of which are overwritten automatically during installs and an additional partition, which is (hopefully) never touched by automatic processes, containing additional configuration and the working data.

@ Yochanan:
Should I open a new topic for this question or would I be blamed for opening multiple topics for the same question?

If the system was fine with 6.4 kernel, why not use that instead? The 6.6 kernel isn’t that far away from its official release; just wait for that, to see if anything changes for you. Cheers.