Hey All,

Since this group helped me so much with DaVinci Resolve in the past, I thought I would start here again.

I have been using QGIS for around 6 years as part of my GIS arsenal of tools to do any work for everyone all the time. I know I have used las2dem successfully just last year when I converted drone data from a point cloud to a DEM. Now, I get the error below. I notice it states: No such file or directory. Does that refer to the tool or where my data is located. I have already tried this on 3 machines, 2 Linux and 1 windows. I have also tried this tool with the current version and long term release of QGIS, but always the same error.

Thanks in advance,


QGIS version: 3.28.6-Firenze
QGIS code revision: 868c9fa0
Qt version: 5.15.8
Python version: 3.9.9
GDAL version: 3.5.2
GEOS version: 3.11.2-CAPI-1.17.2
PROJ version: Rel. 8.2.1, January 1st, 2022
PDAL version: 2.4.3 (git-version: Release)
Algorithm started at: 2023-05-09T18:25:18
Algorithm ‘las2demPro’ starting…
Input parameters:
{ ‘ADDITIONAL_OPTIONS’ : ‘’, ‘ATTRIBUTE’ : 0, ‘CORES’ : 4, ‘CPU64’ : True, ‘FILTER_RETURN_CLASS_FLAGS1’ : 7, ‘GUI’ : False, ‘INPUT_DIRECTORY’ : ‘/run/media/map/Working/ArcFiles/NoState2Show/Denton/NoName2Show/DEM/PointCoud’, ‘INPUT_WILDCARDS’ : ‘*.las’, ‘OUTPUT_APPENDIX’ : ‘’, ‘OUTPUT_DIRECTORY’ : ‘/run/media/mapman97/Working2/ArcFiles/Texas/Denton/LegacyDrFriscoTX/DEM/PointCoud’, ‘OUTPUT_RASTER_FORMAT’ : 0, ‘PRODUCT’ : 0, ‘STEP’ : 0.5, ‘USE_TILE_BB’ : False, ‘VERBOSE’ : False }

LAStools command line
C:\LAStools/bin/las2dem -cpu64 -i “/run/media/mapman97/Working2/ArcFiles/Texas/Denton/LegacyDrFriscoTX/DEM/PointCoud*.las” -keep_class 2 -step 0.5 -odir “/run/media/mapman97/Working2/ArcFiles/Texas/Denton/LegacyDrFriscoTX/DEM/PointCoud” -otif -cores 4

LAStools console output
/bin/sh: line 1: C:LAStools/bin/las2dem: No such file or directory
Execution completed in 0.14 seconds

{‘’: None}
Loading resulting layers
Algorithm ‘las2demPro’ finished


Most likely you have to install AUR (en) - lastools-git
pamac install base-devel && pamac build lastools-git

Thank you for your response. I do have that installed. I narrowed it down to all the tools are not free. So, some LAStools work and others don’t. Thanks again.