QCA6174 - Atheros Wifi - Suspend and many other issues (Lenovo Miix 520)

It could be called suspend state or be hidden in an advanced option sub-menu. I could be wrong , but I think most computers generally have the option to change your sleep state.

I thought it was strange too - it’s the first laptop I’ve had that hasn’t had such options.

There are some power management controls like DPTF and Cool Mode, but no advanced submenus to be seen.

1 Like

I think from your error messages that the Network Manager power saving configuration file is not having the settings applied properly.

There is another method via udev that can be used if you want to test it out.

Disable wifi power saving features with udev.

First you need to install a package to add support for the iw command.

sudo pacman -S wireless_tools         

Then create a udev rule to disable WiFi power saving features.

Create (or modify):

/etc/udev/rules.d/70-wifi-powersave.rules

Add the following content:

ACTION=="add", SUBSYSTEM=="net", KERNEL=="wlp*", RUN+="/usr/bin/iw dev %k set power_save off"

Save and reboot.

2 Likes

Just tried that, but still no luck:

dmesg | grep ath10
[    2.865233] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    3.116810] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[    3.116813] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[    3.117405] ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.4.4.1-00132-QCARMSWP-1 api 6 features wowlan,ignore-otp,mfp crc32 79f4db86
[    3.183303] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[    3.259353] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    3.279186] ath10k_pci 0000:01:00.0: htt-ver 3.60 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    3.370198] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
[    3.594685] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    3.930359] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[  147.541361] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[  147.541387] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 0: -11
[  147.541394] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[  147.541401] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 0: -11
[  147.541619] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[  147.553956] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[  150.587680] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  153.607763] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  153.607765] ath10k_pci 0000:01:00.0: failed to wait for target init: -110
[  153.608948] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 0: -108
[  153.609004] Modules linked in: ccm rfcomm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio hid_sensor_hub arc4 snd_hda_codec_hdmi intel_ishtp_hid snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio sd_mod bnep btusb btrtl btbcm btintel ip6_tables bluetooth iptable_filter uas hid_multitouch usb_storage joydev mousedev ecdh_generic intel_rapl i915 x86_pkg_temp_thermal intel_powerclamp coretemp nls_iso8859_1 nls_cp437 vfat fat ath10k_pci fuse snd_soc_skl ath10k_core snd_soc_hdac_hda snd_hda_ext_core crct10dif_pclmul snd_soc_skl_ipc snd_soc_sst_ipc wacom kvmgt vfio_mdev crc32_pclmul spi_pxa2xx_platform usbhid mdev ath vfio_iommu_type1 snd_soc_sst_dsp 8250_dw snd_soc_acpi_intel_match vfio hid_generic snd_soc_acpi mac80211 ghash_clmulni_intel snd_soc_core kvm snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel snd_hda_codec iTCO_wdt iTCO_vendor_support wmi_bmof
[  153.609395] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 0: -108
[  153.609397] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 0: -108
[  153.609399] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 0: -108
[  153.609400] ath10k_pci 0000:01:00.0: failed to set preamble for vdev 0: -108
[  153.609402] ath10k_pci 0000:01:00.0: failed to down vdev 0: -108
[  153.609404] ath10k_pci 0000:01:00.0: failed to submit vdev param txbf 0x0: -108
[  153.609406] ath10k_pci 0000:01:00.0: failed to recalc txbf for vdev 0: -108
[  153.609409] ath10k_pci 0000:01:00.0: failed to set vdev wmm params on vdev 0: -108
[  153.855131] ath10k_pci 0000:01:00.0: device successfully recovered

I’ve tried to find some references to the unsupported HTC service id: 1536 error that only happens on boot, and what the vdev errors mean - wondering whether it’s a broader issue with communicating with the modem, given that there are multiple failures?

Anyway, am downloading some other versions to try live booting.

This is probably a low percentage fix, but it’s worth a try as it’s easily reversible. Bluetooth can interfere with wifi, so temporarily disabling bluetooth is worth testing.

The best method to disable bluetooth is to add the following entry to the configuration file:

/etc/modprobe.d/blacklist.conf 

Add this line to the conf file:

install bluetooth /bin/false 

Save the changes with root privileges, and exit your text editor.

Then, disable the bluetooth service:

sudo systemctl stop bluetooth
sudo systemctl mask bluetooth

Then, restart.

That should completely disable bluetooth, disabling any bluetooth related modules or service. You can easily enable bluetooth again by commenting out (or remove) the entry in /etc/modprobe.d/blacklist.conf, and then re-enable/unmask the Bluetooth service.

To enable the bluetooth service:

sudo systemctl unmask bluetooth
sudo systemctl enable bluetooth

Then, restart.

1 Like

Have you tested older kernels back as far as 4.4. I seem to recall dealing with a similar issue that the older kernels 4.4, 4.9, 4.14 might not have exhibited these problems. Definitely test some of the older kernels.

It seems like each time I start writing that a solution appears to have delivered a fix, I discover that my connection has gone down again while drafting!

dmesg looks the same on boot with bluetooth enabled, and the same failures appear in the logs when restarting networking. So, will try out changing kernels - currently on 5.0.1 after initially having the issue on 4.19.28-1.

Does your connection exhibit exactly the same symptoms on other networks. Have you tested your laptop at an internet cafe, library, etc.

Issues with ath10k adapters not being initialized at boot or dropped connections can sometimes be corrected with a kernel boot parameter.

Set Active-State Power Management (ASPM) to off at runtime.

Open the grub configuration file located in:

/etc/default/grub

Add the “pcie_aspm=off” kernel boot parameter to the the end of the grub load line.

The line you will need to edit will look similar to the line below:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=e677590f-a8b0-49ad-a6a1-bed005449d2f"

Add this parameter at the end of that line:

pcie_aspm=off 

The modified grub load line should now look similar to this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=e677590f-YOUR-NUMB-BERS-HEREo449d2f pcie_aspm=off"

After adding the boot parameter and saving your changes, run:

sudo update-grub 

This parameter will disable pcie Active-State Power Management (ASPM).

Using this parameter should have minimal impact on your laptop’s run time while on battery.

I found a PKGBUILD for the ath10k firmware that was posted on github 12 days ago. There have been many issues with the ath10k firmware recently. Installing the ath10k firmware with this PKGBUILD may prove more successful than doing it yourself manually.

This is the link to the PKGBUILD on github:

And here is a link explaining how to build and then install the PKGBUILD:

Thanks @tbg, have had ASPM switched off since about post 13.

Tried the UberLambda PKGBUILD, encountered the same issues with bluetooth enabled. Same dmesg output as usual.

I am now running the latest drivers installed via UberLambda’s PKGBUILD, with ipv6, ASPM & bluetooth off. This is giving me the most stable connection yet, but it is still unreliable. For e.g, had a connection on boot, went to type this post, connection was down when I clicked ‘reply’, so we’re still talking less than five minutes in the worst cases.

Funnily enough, I have only noticed this on my home network, but it hasn’t had much use elsewhere.

Try this as a kernel boot parameter:

ath10k_core.skip_otp=y

or

ath10k_core.nohwcrypt=1
sudo update-grub

Reboot.

Using nohwcrypt=1 seems to break wireless completely; skip_otp=y doesn’t result in marked improvement. I was using my phone as a hotspot a bit earlier and had a stable connection for a half hour. Is there anything on the router side you’d recommend I look at?

I might try the Board firmware here, given the device contains the same chipset: Reddit - Surface Go Linux

Yes there is, this adapter has issues sometimes with using the higher bandwidths. Try switching from 20/40 Channel Bandwidth to just 20. Also try setting a fixed channel.

Router setup and troubleshooting tips:

Also, try this method to set your regulatory domain parameter:

Create the file:

/etc/modprobe.d/cfg80211.conf 

Containing the following content:

options cfg80211 ieee80211_regdom=DE

Substitute your country code for “DE” in the above line.

Source for Regulatory Domain Country Codes - Wikipedia

1 Like

This command will log live output when you try to connect to your wifi network.

journalctl -u NetworkManager -f   

Let the command run in the terminal while you are online and making connection attempts. Let it log 50-100 lines of output then post the log.

Haven’t tried the router recommendations yet, will do that and the region now. Here is some more logging: network down happened just before 1553214516.9270 - it doesn’t look like it throws any errors or warnings when the connection goes down. 1553214516.9270 - 1553214624.2369 shows a disconnect and reconnect that did not result in a stable connection, requiring another restart.

-- Logs begin at Tue 2019-03-19 22:34:41 AEDT. --
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2343] device (wlp1s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2372] device (wlp1s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2382] device (wlp1s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2400] manager: NetworkManager state is now CONNECTED_LOCAL
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2491] manager: NetworkManager state is now CONNECTED_SITE
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2495] policy: set 'TIMBERLINE_LODGE_5G' (wlp1s0) as default for IPv4 routing and DNS
Mar 22 10:29:46 a-pc NetworkManager[537]: <info>  [1553210986.2548] device (wlp1s0): Activation: successful, device activated.
Mar 22 10:29:47 a-pc NetworkManager[537]: <info>  [1553210987.1337] manager: NetworkManager state is now CONNECTED_GLOBAL
Mar 22 11:03:52 a-pc NetworkManager[537]: <info>  [1553213032.2884] agent-manager: req[0x55d7d110b520, :1.153/org.gnome.Shell.NetworkAgent/1000]: agent registered
Mar 22 11:26:30 a-pc NetworkManager[537]: <info>  [1553214390.3844] agent-manager: req[0x55d7d10f6280, :1.153/org.gnome.Shell.NetworkAgent/1000]: agent registered
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9270] manager: disable requested (sleeping: no  enabled: yes)
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9272] manager: NetworkManager state is now ASLEEP
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9282] audit: op="networking-control" arg="off" pid=11492 uid=0 result="success"
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9283] device (wlp1s0): state change: activated -> deactivating (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9349] device (wlp1s0): state change: deactivating -> disconnected (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9354] dhcp4 (wlp1s0): canceled DHCP transaction
Mar 22 11:28:36 a-pc NetworkManager[537]: <info>  [1553214516.9354] dhcp4 (wlp1s0): state changed bound -> done
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.2076] device (wlp1s0): set-hw-addr: set MAC address to CA:30:2B:A6:BB:B6 (scanning)
Mar 22 11:28:46 a-pc NetworkManager[537]: <warn>  [1553214526.2077] platform-linux: do-change-link[2]: failure changing link: failure 108 (Cannot send after transport endpoint shutdown)
Mar 22 11:28:46 a-pc NetworkManager[537]: <warn>  [1553214526.2227] sup-iface[0x55d7d104af00,wlp1s0]: connection disconnected (reason -3)
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.2228] device (wlp1s0): supplicant interface state: completed -> disconnected
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.2232] device (wlp1s0): supplicant interface state: disconnected -> disabled
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.2234] device (wlp1s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.4580] device (wlp1s0): set-hw-addr: reset MAC address to 98:22:EF:FB:11:69 (unmanage)
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.4857] manager: enable requested (sleeping: no  enabled: no)
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.4858] device (wlp1s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.4878] manager: NetworkManager state is now DISCONNECTED
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.4883] audit: op="networking-control" arg="on" pid=11504 uid=0 result="success"
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.7454] sup-iface[0x55d7d104aa30,wlp1s0]: supports 5 scan SSIDs
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.7463] device (wlp1s0): supplicant interface state: starting -> ready
Mar 22 11:28:46 a-pc NetworkManager[537]: <info>  [1553214526.7463] device (wlp1s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6187] policy: auto-activating connection 'TIMBERLINE_LODGE_5G' (62e5e395-ca66-4a91-bd2e-ffd4a8f1a128)
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6209] device (wlp1s0): Activation: starting connection 'TIMBERLINE_LODGE_5G' (62e5e395-ca66-4a91-bd2e-ffd4a8f1a128)
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6213] device (wlp1s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6223] manager: NetworkManager state is now CONNECTING
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6235] device (wlp1s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6245] device (wlp1s0): Activation: (wifi) access point 'TIMBERLINE_LODGE_5G' has security, but secrets are required.
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6246] device (wlp1s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6321] device (wlp1s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6332] device (wlp1s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6339] device (wlp1s0): Activation: (wifi) connection 'TIMBERLINE_LODGE_5G' has security, and secrets exist.  No new secrets needed.
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6339] Config: added 'ssid' value 'TIMBERLINE_LODGE_5G'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6340] Config: added 'scan_ssid' value '1'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6340] Config: added 'bgscan' value 'simple:30:-80:86400'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6341] Config: added 'key_mgmt' value 'WPA-PSK'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6342] Config: added 'auth_alg' value 'OPEN'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.6342] Config: added 'psk' value '<hidden>'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7430] device (wlp1s0): supplicant interface state: ready -> authenticating
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7488] device (wlp1s0): supplicant interface state: authenticating -> associating
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7550] device (wlp1s0): supplicant interface state: associating -> associated
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7626] device (wlp1s0): supplicant interface state: associated -> 4-way handshake
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7733] device (wlp1s0): supplicant interface state: 4-way handshake -> completed
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7734] device (wlp1s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "TIMBERLINE_LODGE_5G"
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7741] device (wlp1s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.7753] dhcp4 (wlp1s0): activation: beginning transaction (timeout in 45 seconds)
Mar 22 11:28:51 a-pc NetworkManager[537]: libndp: ndp_sock_open: Failed to create ICMP6 socket.
Mar 22 11:28:51 a-pc NetworkManager[537]: <error> [1553214531.7809] device (wlp1s0): addrconf6: failed to start neighbor discovery: failure creating libndp socket: Address family not supported by protocol (97)
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8044] dhcp4 (wlp1s0):   address 192.168.1.172
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8045] dhcp4 (wlp1s0):   plen 24
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8045] dhcp4 (wlp1s0):   expires in 86400 seconds
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8046] dhcp4 (wlp1s0):   nameserver '192.168.1.1'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8046] dhcp4 (wlp1s0):   hostname 'a-pc'
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8046] dhcp4 (wlp1s0):   gateway 192.168.1.1
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8051] dhcp4 (wlp1s0): state changed unknown -> bound
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8082] device (wlp1s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8109] device (wlp1s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8117] device (wlp1s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8134] manager: NetworkManager state is now CONNECTED_GLOBAL
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8222] policy: set 'TIMBERLINE_LODGE_5G' (wlp1s0) as default for IPv4 routing and DNS
Mar 22 11:28:51 a-pc NetworkManager[537]: <info>  [1553214531.8273] device (wlp1s0): Activation: successful, device activated.
Mar 22 11:29:41 a-pc NetworkManager[537]: <info>  [1553214581.9243] manager: NetworkManager state is now CONNECTED_SITE
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2369] manager: disable requested (sleeping: no  enabled: yes)
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2371] manager: NetworkManager state is now ASLEEP
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2381] audit: op="networking-control" arg="off" pid=11620 uid=0 result="success"
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2383] device (wlp1s0): state change: activated -> deactivating (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2447] device (wlp1s0): state change: deactivating -> disconnected (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2452] dhcp4 (wlp1s0): canceled DHCP transaction
Mar 22 11:30:24 a-pc NetworkManager[537]: <info>  [1553214624.2453] dhcp4 (wlp1s0): state changed bound -> done
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.5132] device (wlp1s0): set-hw-addr: set MAC address to 9E:41:05:0B:60:BB (scanning)
Mar 22 11:30:33 a-pc NetworkManager[537]: <warn>  [1553214633.5133] platform-linux: do-change-link[2]: failure changing link: failure 108 (Cannot send after transport endpoint shutdown)
Mar 22 11:30:33 a-pc NetworkManager[537]: <warn>  [1553214633.5250] sup-iface[0x55d7d104aa30,wlp1s0]: connection disconnected (reason -3)
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.5251] device (wlp1s0): supplicant interface state: completed -> disconnected
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.5276] device (wlp1s0): supplicant interface state: disconnected -> disabled
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.5278] device (wlp1s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.7652] device (wlp1s0): set-hw-addr: reset MAC address to 98:22:EF:FB:11:69 (unmanage)
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.8175] manager: enable requested (sleeping: no  enabled: no)
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.8176] device (wlp1s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.8210] manager: NetworkManager state is now DISCONNECTED
Mar 22 11:30:33 a-pc NetworkManager[537]: <info>  [1553214633.8218] audit: op="networking-control" arg="on" pid=11633 uid=0 result="success"
Mar 22 11:30:34 a-pc NetworkManager[537]: <info>  [1553214634.1124] sup-iface[0x55d7d104a980,wlp1s0]: supports 5 scan SSIDs
Mar 22 11:30:34 a-pc NetworkManager[537]: <info>  [1553214634.1150] device (wlp1s0): supplicant interface state: starting -> ready
Mar 22 11:30:34 a-pc NetworkManager[537]: <info>  [1553214634.1152] device (wlp1s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Mar 22 11:30:38 a-pc NetworkManager[537]: <info>  [1553214638.9936] policy: auto-activating connection 'TIMBERLINE_LODGE_5G' (62e5e395-ca66-4a91-bd2e-ffd4a8f1a128)
Mar 22 11:30:38 a-pc NetworkManager[537]: <info>  [1553214638.9962] device (wlp1s0): Activation: starting connection 'TIMBERLINE_LODGE_5G' (62e5e395-ca66-4a91-bd2e-ffd4a8f1a128)
Mar 22 11:30:38 a-pc NetworkManager[537]: <info>  [1553214638.9966] device (wlp1s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:38 a-pc NetworkManager[537]: <info>  [1553214638.9982] manager: NetworkManager state is now CONNECTING
Mar 22 11:30:38 a-pc NetworkManager[537]: <info>  [1553214638.9996] device (wlp1s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0004] device (wlp1s0): Activation: (wifi) access point 'TIMBERLINE_LODGE_5G' has security, but secrets are required.
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0005] device (wlp1s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0087] device (wlp1s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0102] device (wlp1s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0114] device (wlp1s0): Activation: (wifi) connection 'TIMBERLINE_LODGE_5G' has security, and secrets exist.  No new secrets needed.
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0115] Config: added 'ssid' value 'TIMBERLINE_LODGE_5G'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0115] Config: added 'scan_ssid' value '1'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0116] Config: added 'bgscan' value 'simple:30:-80:86400'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0116] Config: added 'key_mgmt' value 'WPA-PSK'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0116] Config: added 'auth_alg' value 'OPEN'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.0117] Config: added 'psk' value '<hidden>'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1208] device (wlp1s0): supplicant interface state: ready -> authenticating
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1265] device (wlp1s0): supplicant interface state: authenticating -> associated
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1392] device (wlp1s0): supplicant interface state: associated -> 4-way handshake
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1491] device (wlp1s0): supplicant interface state: 4-way handshake -> completed
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1492] device (wlp1s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "TIMBERLINE_LODGE_5G"
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1497] device (wlp1s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1510] dhcp4 (wlp1s0): activation: beginning transaction (timeout in 45 seconds)
Mar 22 11:30:39 a-pc NetworkManager[537]: libndp: ndp_sock_open: Failed to create ICMP6 socket.
Mar 22 11:30:39 a-pc NetworkManager[537]: <error> [1553214639.1567] device (wlp1s0): addrconf6: failed to start neighbor discovery: failure creating libndp socket: Address family not supported by protocol (97)
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1910] dhcp4 (wlp1s0):   address 192.168.1.172
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1911] dhcp4 (wlp1s0):   plen 24
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1911] dhcp4 (wlp1s0):   expires in 86400 seconds
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1912] dhcp4 (wlp1s0):   nameserver '192.168.1.1'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1912] dhcp4 (wlp1s0):   hostname 'a-pc'
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1912] dhcp4 (wlp1s0):   gateway 192.168.1.1
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1919] dhcp4 (wlp1s0): state changed unknown -> bound
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1951] device (wlp1s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1978] device (wlp1s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.1988] device (wlp1s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.2007] manager: NetworkManager state is now CONNECTED_LOCAL
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.2103] manager: NetworkManager state is now CONNECTED_SITE
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.2111] policy: set 'TIMBERLINE_LODGE_5G' (wlp1s0) as default for IPv4 routing and DNS
Mar 22 11:30:39 a-pc NetworkManager[537]: <info>  [1553214639.2169] device (wlp1s0): Activation: successful, device activated.
Mar 22 11:30:40 a-pc NetworkManager[537]: <info>  [1553214640.0144] manager: NetworkManager state is now CONNECTED_GLOBAL

This has worked before with the signs I’m seeing in your log.

Try this:

sudo systemctl stop NetworkManager

sudo mv /var/lib/NetworkManager/NetworkManager.state  /var/lib/NetworkManager/NetworkManager_state.bak

sudo systemctl start NetworkManager

You may need to reboot.

If there is no improvement, you can return the file to its original state:

sudo cp /var/lib/NetworkManager/NetworkManager_state.bak  /var/lib/NetworkManager/NetworkManager.state

Your connection is going to sleep according to your logs.

Try adding this trick to the above changes if it has not completely fixed your disconnect issues.

ping -s 16000 192.168.0.1

You may need to change the address from “192.168.0.1” to your routers assigned gateway address.

Keeping the connection continually active sometimes helps prevent this issue.

1 Like

Thanks - the manager: NetworkManager state is now ASLEEP logs were appearing after using sudo nmcli networking off and on to cycle the connection.

I have renamed the NetworkManager.statefile though; I have had a stable connection since, have just rebooted because while it was working, the wifi symbol was showing a question mark in it. This has resolved on reboot.

Have also had a tinker with the router - I was having an issue where even when the internet was working, I could not connect to 192.168.1.1 (my assigned gateway address). Have updated the firmware, checked auth mode, and changed channel bandwidth from 20/40/80MHz to 40MHz - will step down again if the issue is persisting. UPnP is turned on and DHCP is looking fine. IPv6 is also disabled on the router. The channels I’m using are clear, I have very few neighbours to compete with at this time of the year!

Will update in a few hours.

1 Like

I was fairly sure when I saw your last set of logs that I’d found the problem. I think you’ve got it beat now. :smile:

I’m curious if you ever got around to trying the ManjoWish Lxqt edition live boot disk. The reason I wanted you to run that live boot environment is because that edition does not use Network Manager, (it uses connman). That is a much easier method of troubleshooting to find out if Network Manager is causing the connectivity issues.

Luckily I spotted the signs that Network Manager was causing your problems with its state file from your logs. This is a very old network manager bug that was supposed to have been fixed years ago. I’ve seen this issue only rarely in recent times.

I’m actually very surprised this was the cause of your problems. Your adapter has been plagued by kernel/firmware bugs, so that was the first thing I suspected. Then I couldn’t figure out why the power saving changes didn’t help either. The reason was because it wasn’t the power saving options putting the adapter to sleep, it was the network manager bug. Go figure?

The times I’ve seen this, deleting the state file has always fixed things up. So I’m hoping you’re all taken care of now.

1 Like

I’m quite curious if your connection has stayed stable since yesterday. I sure hope so, because I threw almost all the Atheros tricks in the book at this one. This has been a very problematic adapter of late, so it would be nice to know if this case had a positive outcome. Be sure to check back and update us on your wifi’s status. :crossed_fingers:

Forum kindly sponsored by Bytemark