QCA6174 - Atheros Wifi - Suspend and many other issues (Lenovo Miix 520)

Running Manjaro W/ Gnome on a Lenovo Miix 520 - have successfully gotten most components working (and plan on writing a bit of a write-up eventually), but am experiencing issues with WiFi.

I have followed the steps at QCA6174 Freeze After Suspend & used qwalers systemd's. These appear to be running and stopping / starting as they should prior to and after system suspend.

However, still have a stability problem - wifi will work for anywhere between one and twenty minutes before stopping again. running:sudo nmcli networking off sudo nmcli networking on
appears to resolve the problem, again only temporarily. When not working, the tray icon will usually show that the connection is still active or connected, but with a question mark.

When running the networking on function I will usually get an error along the lines of (process:6926): GLib-GIO-WARNING **: 16:12:49.008: ../glib/gio/gdbusobjectmanagerclient.c:1589: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/ActiveConnection/9 but no object proxy exists - this error has shown for ActiveConnections 4,5, and 9.

Please let me know if I can provide any logs to help troubleshoot - I'm very much a beginner at this stage. Any help would be much appreciated because relying on ethernet is a bit antithetical to the purpose of a tablet!

This issue is also sometimes appearing after rebooting, and will not work at startup until running sudo nmcli networking off and on.

Some logs (copying what jwalsh provided at Qualcomm Wifi suddenly not working ):

dmesg | grep ath10k
[    3.146069] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    3.401157] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[    3.401168] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[    3.402785] ath10k_pci 0000:01:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[    3.469263] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[    3.541442] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    3.560413] ath10k_pci 0000:01:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    3.645403] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
[    3.859306] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    4.203314] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 98:22:ef:fb:11:69 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.172/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp1s0
       valid_lft 86312sec preferred_lft 86312sec
    inet6 fe80::71a7:d01a:d1ad:e915/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
$ inxi -Fx
System:
  Host: a-pc Kernel: 5.0.1-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Gnome 3.30.2 Distro: Manjaro Linux 
Machine:
  Type: Detachable System: LENOVO product: 20M3 v: MIIX 520-12IKB 
  serial: <root required> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40697 WIN serial: <root required> 
  UEFI: LENOVO v: 6NCN33WW date: 11/12/2018 
Battery:
  ID-1: BAT0 charge: 40.0 Wh condition: 40.0/38.0 Wh (105%) 
  model: LENOVO SR Real Battery status: Full 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
  Speed: 640 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 701 7: 700 8: 700 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.org 1.20.4 driver: i915 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.4 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging 
  Unit 
  vendor: Lenovo driver: ipu3-imgu bus ID: 00:05.0 
  Device-2: Intel vendor: Lenovo driver: N/A bus ID: 00:14.3 
  Device-3: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.0.1-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 4040 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: 98:22:ef:fb:11:69 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 
Drives:
  Local Storage: total: 931.51 GiB used: 10.26 GiB (1.1%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 228.18 GiB used: 10.23 GiB (4.5%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-2: swap-1 size: 9.31 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p7 
Sensors:
  System Temperatures: cpu: 32.5 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 283 Uptime: 1m Memory: 7.58 GiB used: 1.89 GiB (24.9%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.32 

I am not sure whether it bears mentioning but I did have an initial issue with the modem being hard blocked, which I resolved with echo "blacklist ideapad-laptop" | sudo tee /etc/modprobe.d/ideapad-laptop.conf.

rfkill list all returns:

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

And finally, a dmesg | grep ath10kafter cycling sudo nmcli networking(It took three cycles to achieve a stable connection, which has so far lasted me about 20 mins):

[  133.321765] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[  133.321795] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 0: -11
[  133.321803] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[  133.321810] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 0: -11
[  133.322121] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[  133.334342] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[  133.405144] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 0: -108
[  133.405293] Modules linked in: ccm cmac rfcomm fuse ip6t_REJECT nf_reject_ipv6 ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 hid_sensor_gyro_3d hid_sensor_accel_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common snd_hda_codec_hdmi industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid joydev mousedev snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp intel_rapl snd_soc_acpi_intel_match ip6table_filter ath10k_pci x86_pkg_temp_thermal ip6_tables snd_soc_acpi intel_powerclamp i915 snd_soc_core ath10k_core iptable_filter coretemp wacom hid_multitouch bnep snd_compress ac97_bus kvmgt vfio_mdev mdev vfio_iommu_type1 vfio ath kvm mac80211 snd_pcm_dmaengine snd_hda_intel snd_hda_codec nls_iso8859_1 hid_generic nls_cp437 8250_dw spi_pxa2xx_platform irqbypass i2c_algo_bit snd_hda_core crct10dif_pclmul vfat drm_kms_helper btusb fat crc32_pclmul ipu3_cio2 btrtl btbcm snd_hwdep
[  133.406828] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 0: -108
[  133.406835] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 0: -108
[  133.406841] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 0: -108
[  133.655848] ath10k_pci 0000:01:00.0: device successfully recovered
[  168.308492] ath10k_warn: 14 callbacks suppressed
[  168.308501] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[  168.308520] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 1: -11
[  168.308525] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[  168.308530] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 1: -11
[  168.308786] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[  168.321101] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[  171.354672] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  174.374829] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  174.374831] ath10k_pci 0000:01:00.0: failed to wait for target init: -110
[  174.376069] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 1: -108
[  174.376147] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 1: -108
[  174.376149] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 1: -108
[  174.376151] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 1: -108
[  174.376152] ath10k_pci 0000:01:00.0: failed to set preamble for vdev 1: -108
[  174.376154] ath10k_pci 0000:01:00.0: failed to down vdev 1: -108
[  174.376156] ath10k_pci 0000:01:00.0: failed to submit vdev param txbf 0x0: -108
[  174.376158] ath10k_pci 0000:01:00.0: failed to recalc txbf for vdev 1: -108
[  174.376161] ath10k_pci 0000:01:00.0: failed to set vdev wmm params on vdev 1: -108
[  174.614812] ath10k_pci 0000:01:00.0: device successfully recovered
[  222.281445] ath10k_warn: 9 callbacks suppressed
[  222.281454] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[  222.281476] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 1: -11
[  222.281481] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[  222.281487] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 1: -11
[  222.281737] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[  222.294041] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[  225.328229] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  228.348172] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  228.348174] ath10k_pci 0000:01:00.0: failed to wait for target init: -110
[  228.349455] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 1: -108
[  228.349530] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 1: -108
[  228.349532] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 1: -108
[  228.349534] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 1: -108
[  228.349535] ath10k_pci 0000:01:00.0: failed to set preamble for vdev 1: -108
[  228.349538] ath10k_pci 0000:01:00.0: failed to down vdev 1: -108
[  228.349540] ath10k_pci 0000:01:00.0: failed to submit vdev param txbf 0x0: -108
[  228.349541] ath10k_pci 0000:01:00.0: failed to recalc txbf for vdev 1: -108
[  228.349544] ath10k_pci 0000:01:00.0: failed to set vdev wmm params on vdev 1: -108
[  228.591027] ath10k_pci 0000:01:00.0: device successfully recovered

If you have not done so already, try disabling IPv6 in network manager (set to “ignore”). If IPv6 is already disabled try enabling it.

You could also test different driver options. This method will change the options on the fly and the settings will only last till you reboot.

Some options you could try are:

options ath10k_pci nohwcrypt=1
options ath10k_pci skip_otp=y

They can be tested like like this:

sudo modprobe -r ath10k_pci

sudo modprobe -r ath10k_core

sudo modprobe ath10k_pci skip_otp=y

Or:

sudo modprobe -r ath10k_pci
sudo modprobe -r ath10k_core
sudo modprobe ath10k_pci nohwcrypt=1

They can also be combined like this:

sudo modprobe -r ath10k_pci
sudo modprobe -r ath10k_core
sudo modprobe ath10k_pci nohwcrypt=1 skip_otp=y

If any of those driver options produce a marked improvement then the options can be made permanent with a configuration file in /etc/modprobe.d.

1 Like

This could also be your Wi-Fi power saving settings causing the dropped connections. To change the power saving options, create a default-wifi-powersave-on.conf file:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Add the following contents to the conf file:

[connection]
wifi.powersave = 0

A setting of “0” will totally disable power saving features in the WiFi adapter.

A setting of “2” or “1” will be less aggressive, but still leave powersaving enabled.

Also, if you are having issues with your adapter initializing correctly at start up that can be corrected with a full network restart script run at startup via a service or cronjob such as this:

#!/bin/bash
nmcli networking off
sudo systemctl stop NetworkManager
sudo ip link set wlp1s0 down 
sudo modprobe -r ath10k_pci
sudo modprobe -r ath10k_core
sudo modprobe ath10k_pci nohwcrypt=1 skip_otp=y
sudo ip link set wlp1s0 up
sudo rfkill unblock all
sudo systemctl start NetworkManager
nmcli networking on

This is only an example script. Customize it to the options you want.

I also just found a post stating they had solved their issues with their Atheros adapter not being initialized at boot with a grub kernel boot parameter. If you are unfamiliar with this procedure be sure to research this thoroughly before you make any changes, as you do not want to make any mistakes when altering any option involved in the boot process.

The grub boot parameter that needs to be tested is:

pcie_aspm=off

After adding the boot parameter run:

sudo mkinitcpio -P
sudo update-grub 

Please provide detailed feedback on on my previous suggestions as that will help all Atheros users looking for a solution to these types of issues.

Thanks @tbg - have been taking some time to test each case today.

So far, I found most stability (although still not stable) with power saving disabled (set to 0), ipv6 turned off (via Manjaro Wiki - Turn Off ipv6 ), and no changes to drivers. This worked smoothly for about 5 hours this morning before I started running in to the same problem again.

None of the driver combinations appeared to be making a marked improvement.

today’s dmesg from when I began to run into problems:

[ 4814.335925] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[ 4814.373159] WARNING: CPU: 0 PID: 30134 at drivers/net/wireless/ath/ath10k/mac.c:5708 ath10k_bss_info_changed+0xfb7/0x1120 [ath10k_core]
[ 4814.373161] Modules linked in: tun fuse ccm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 snd_hda_codec_hdmi hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter bnep i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci hid_multitouch wacom ath10k_core snd_soc_skl crct10dif_pclmul snd_soc_hdac_hda crc32_pclmul ath snd_hda_ext_core ghash_clmulni_intel nls_iso8859_1 snd_soc_skl_ipc kvmgt mac80211 nls_cp437 vfio_mdev vfat mdev snd_soc_sst_ipc vfio_iommu_type1 snd_soc_sst_dsp fat vfio snd_soc_acpi_intel_match snd_soc_acpi kvm snd_soc_core spi_pxa2xx_platform hid_generic usbhid snd_compress ac97_bus snd_pcm_dmaengine 8250_dw snd_hda_intel btusb btrtl btbcm irqbypass i2c_algo_bit aesni_intel drm_kms_helper btintel iTCO_wdt aes_x86_64 cfg80211 snd_hda_codec
[ 4814.373316] RIP: 0010:ath10k_bss_info_changed+0xfb7/0x1120 [ath10k_core]
[ 4814.373363]  ? ath10k_conf_tx+0x7a/0x4b0 [ath10k_core]
[ 4814.373769] WARNING: CPU: 0 PID: 30134 at drivers/net/wireless/ath/ath10k/mac.c:5746 ath10k_bss_info_changed+0xf96/0x1120 [ath10k_core]
[ 4814.373770] Modules linked in: tun fuse ccm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 snd_hda_codec_hdmi hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter bnep i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci hid_multitouch wacom ath10k_core snd_soc_skl crct10dif_pclmul snd_soc_hdac_hda crc32_pclmul ath snd_hda_ext_core ghash_clmulni_intel nls_iso8859_1 snd_soc_skl_ipc kvmgt mac80211 nls_cp437 vfio_mdev vfat mdev snd_soc_sst_ipc vfio_iommu_type1 snd_soc_sst_dsp fat vfio snd_soc_acpi_intel_match snd_soc_acpi kvm snd_soc_core spi_pxa2xx_platform hid_generic usbhid snd_compress ac97_bus snd_pcm_dmaengine 8250_dw snd_hda_intel btusb btrtl btbcm irqbypass i2c_algo_bit aesni_intel drm_kms_helper btintel iTCO_wdt aes_x86_64 cfg80211 snd_hda_codec
[ 4814.373909] RIP: 0010:ath10k_bss_info_changed+0xf96/0x1120 [ath10k_core]
[ 4814.373950]  ? ath10k_conf_tx+0x7a/0x4b0 [ath10k_core]
[ 4956.863098] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[ 4956.910802] WARNING: CPU: 3 PID: 30145 at drivers/net/wireless/ath/ath10k/mac.c:5708 ath10k_bss_info_changed+0xfb7/0x1120 [ath10k_core]
[ 4956.910803] Modules linked in: cmac rfcomm tun fuse ccm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 snd_hda_codec_hdmi hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter bnep i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci hid_multitouch wacom ath10k_core snd_soc_skl crct10dif_pclmul snd_soc_hdac_hda crc32_pclmul ath snd_hda_ext_core ghash_clmulni_intel nls_iso8859_1 snd_soc_skl_ipc kvmgt mac80211 nls_cp437 vfio_mdev vfat mdev snd_soc_sst_ipc vfio_iommu_type1 snd_soc_sst_dsp fat vfio snd_soc_acpi_intel_match snd_soc_acpi kvm snd_soc_core spi_pxa2xx_platform hid_generic usbhid snd_compress ac97_bus snd_pcm_dmaengine 8250_dw snd_hda_intel btusb btrtl btbcm irqbypass i2c_algo_bit aesni_intel drm_kms_helper btintel iTCO_wdt aes_x86_64 cfg80211
[ 4956.910854] RIP: 0010:ath10k_bss_info_changed+0xfb7/0x1120 [ath10k_core]
[ 4956.910866]  ? ath10k_conf_tx+0x7a/0x4b0 [ath10k_core]
[ 4956.910943] WARNING: CPU: 3 PID: 30145 at drivers/net/wireless/ath/ath10k/mac.c:5746 ath10k_bss_info_changed+0xf96/0x1120 [ath10k_core]
[ 4956.910944] Modules linked in: cmac rfcomm tun fuse ccm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 snd_hda_codec_hdmi hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter bnep i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci hid_multitouch wacom ath10k_core snd_soc_skl crct10dif_pclmul snd_soc_hdac_hda crc32_pclmul ath snd_hda_ext_core ghash_clmulni_intel nls_iso8859_1 snd_soc_skl_ipc kvmgt mac80211 nls_cp437 vfio_mdev vfat mdev snd_soc_sst_ipc vfio_iommu_type1 snd_soc_sst_dsp fat vfio snd_soc_acpi_intel_match snd_soc_acpi kvm snd_soc_core spi_pxa2xx_platform hid_generic usbhid snd_compress ac97_bus snd_pcm_dmaengine 8250_dw snd_hda_intel btusb btrtl btbcm irqbypass i2c_algo_bit aesni_intel drm_kms_helper btintel iTCO_wdt aes_x86_64 cfg80211
[ 4956.910977] RIP: 0010:ath10k_bss_info_changed+0xf96/0x1120 [ath10k_core]
[ 4956.910986]  ? ath10k_conf_tx+0x7a/0x4b0 [ath10k_core]
[ 5435.437582] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[ 5435.437605] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 0: -11
[ 5435.437611] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[ 5435.437617] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 0: -11
[ 5435.437856] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[ 5435.450185] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[ 5438.484100] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[ 5441.504093] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[ 5441.504095] ath10k_pci 0000:01:00.0: failed to wait for target init: -110
[ 5441.505474] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 0: -108
[ 5441.505529] Modules linked in: cmac rfcomm tun fuse ccm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner arc4 snd_hda_codec_hdmi hid_sensor_accel_3d hid_sensor_gyro_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter bnep i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci hid_multitouch wacom ath10k_core snd_soc_skl crct10dif_pclmul snd_soc_hdac_hda crc32_pclmul ath snd_hda_ext_core ghash_clmulni_intel nls_iso8859_1 snd_soc_skl_ipc kvmgt mac80211 nls_cp437 vfio_mdev vfat mdev snd_soc_sst_ipc vfio_iommu_type1 snd_soc_sst_dsp fat vfio snd_soc_acpi_intel_match snd_soc_acpi kvm snd_soc_core spi_pxa2xx_platform hid_generic usbhid snd_compress ac97_bus snd_pcm_dmaengine 8250_dw snd_hda_intel btusb btrtl btbcm irqbypass i2c_algo_bit aesni_intel drm_kms_helper btintel iTCO_wdt aes_x86_64 cfg80211
[ 5441.506068] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 0: -108
[ 5441.506071] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 0: -108
[ 5441.506073] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 0: -108
[ 5441.506075] ath10k_pci 0000:01:00.0: failed to set preamble for vdev 0: -108
[ 5441.506077] ath10k_pci 0000:01:00.0: failed to down vdev 0: -108
[ 5441.506079] ath10k_pci 0000:01:00.0: failed to submit vdev param txbf 0x0: -108
[ 5441.506080] ath10k_pci 0000:01:00.0: failed to recalc txbf for vdev 0: -108
[ 5441.506085] ath10k_pci 0000:01:00.0: failed to set vdev wmm params on vdev 0: -108
[ 5441.751376] ath10k_pci 0000:01:00.0: device successfully recovered

Any other ideas? I really appreciate the help so far, this one has really been bamboozling me. It seems that I can (rarely) achieve a stable connection for hours, but once the problem begins to arise again that connection time will rarely last for more than five minutes.

Some further speculation: It does appear to be triggered when I plug in to AC, and is more or less stable on battery - does this make any sense at all?

I started encountering issues earlier only after plugging in, so rebooted with power unplugged - no issues - then on inserting charger have started experiencing the problem again. Correlation doesn’t imply causation and all, but it does look like the dmesg output is still suggesting a power issue.

[  307.139786] ath10k_warn: 19 callbacks suppressed
[  307.139796] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[  307.139817] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 1: -11
[  307.139822] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[  307.139827] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 1: -11
[  307.140057] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[  307.152234] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[  310.189651] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  313.209434] ath10k_pci 0000:01:00.0: failed to receive initialized event from target: 00000000
[  313.209437] ath10k_pci 0000:01:00.0: failed to wait for target init: -110
[  313.210844] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 1: -108
[  313.210924] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 1: -108
[  313.210927] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 1: -108
[  313.210929] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 1: -108
[  313.210931] ath10k_pci 0000:01:00.0: failed to set preamble for vdev 1: -108
[  313.210933] ath10k_pci 0000:01:00.0: failed to down vdev 1: -108
[  313.210936] ath10k_pci 0000:01:00.0: failed to submit vdev param txbf 0x0: -108
[  313.210937] ath10k_pci 0000:01:00.0: failed to recalc txbf for vdev 1: -108
[  313.210941] ath10k_pci 0000:01:00.0: failed to set vdev wmm params on vdev 1: -108
[  313.458623] ath10k_pci 0000:01:00.0: device successfully recovered

Also of note is that I can’t see any error marking when things stop working.

If you do not use Bluetooth I would suggest disabling it as a test. There are quite a few different ways to do that. If you use Bluetooth then I guess that’s not really a viable option.

5 hours with a stable connection is certainly a vast improvement, so even if you can’t get it completely resolved that is a drop rate that can probably be tolerated. The scripts I posted should be able to restart your connection without having to resort to a full reboot. That makes the problem far more tolerable.

Good luck with finding the other pieces to the puzzle.

The battery symptom is a huge clue. Try disabling tlp.

sudo systemctl disable tlp

Restart then check your connections stability.

Disabling tlp is not a good full time solution, as it is important for proper laptop power management. If you can trace down the tlp setting causing the issue and disable that individual setting that is the best solution.

Thanks tbg - it’s a fairly new device so definitely discovering these quirks as I go!

Disabling TLP got me a stable connection for ~1600 seconds - have plugged and unplugged from AC, entered in and out of standby a few times, and it was happy, then seemingly randomly stopped again.

[    2.989192] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    3.244892] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[    3.244897] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[    3.246091] ath10k_pci 0000:01:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[    3.316714] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[    3.388985] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    3.408401] ath10k_pci 0000:01:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    3.524567] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
[    3.754606] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[    4.095927] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[ 1628.466839] ath10k_pci 0000:01:00.0: wmi command 36865 timeout, restarting hardware
[ 1628.466862] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 0: -11
[ 1628.466869] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[ 1628.466876] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 0: -11
[ 1628.467213] ath10k_pci 0000:01:00.0: failed to flush transmit queue (skip 1 ar-state 1): 1500
[ 1628.479367] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -16
[ 1628.550683] ath10k_pci 0000:01:00.0: failed to delete peer e0:3f:49:e0:3d:ac for vdev 0: -108
[ 1628.550795] Modules linked in: ccm cmac rfcomm ipt_REJECT nf_reject_ipv4 xt_tcpudp xt_owner hid_sensor_accel_3d hid_sensor_gyro_3d snd_hda_codec_hdmi hid_sensor_trigger industrialio_triggered_buffer kfifo_buf hid_sensor_iio_common arc4 industrialio snd_hda_codec_realtek hid_sensor_hub snd_hda_codec_generic ledtrig_audio intel_ishtp_hid mousedev joydev ip6_tables iptable_filter i915 intel_rapl x86_pkg_temp_thermal intel_powerclamp bnep wacom hid_multitouch coretemp ath10k_pci ath10k_core kvmgt snd_soc_skl vfio_mdev mdev ath vfio_iommu_type1 snd_soc_hdac_hda vfio snd_hda_ext_core mac80211 crct10dif_pclmul snd_soc_skl_ipc crc32_pclmul nls_iso8859_1 nls_cp437 snd_soc_sst_ipc kvm snd_soc_sst_dsp ghash_clmulni_intel snd_soc_acpi_intel_match vfat snd_soc_acpi fat spi_pxa2xx_platform snd_soc_core hid_generic 8250_dw snd_compress btusb ac97_bus btrtl snd_pcm_dmaengine irqbypass btbcm i2c_algo_bit btintel snd_hda_intel fuse iTCO_wdt drm_kms_helper usbhid iTCO_vendor_support snd_hda_codec bluetooth
[ 1628.551861] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 0: -108
[ 1628.551867] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 0: -108
[ 1628.551873] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 0: -108
[ 1628.796697] ath10k_pci 0000:01:00.0: device successfully recovered

I’ll have tried using wifi.powersave = 1 in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf, And have reenabled tlp with the following modification to /etc/default/tlp:

RUNTIME_PM_BLACKLIST="01:00.0"

After toggling networking, I pulled another dmesg, which still returns:

[ 2031.876413] ath10k_pci 0000:01:00.0: failed to set PS Mode 0 for vdev 1: -11
[ 2031.876418] ath10k_pci 0000:01:00.0: failed to setup powersave: -11
[ 2031.876424] ath10k_pci 0000:01:00.0: failed to setup ps on vdev 1: -11

So I think we might be on to something with it being a power issue, but I’m not sure where to look next. Most of the errors also relate to ‘vdev1’ but I’m not sure what this is!

Are there any other logs that I could be pulling that might give a little bit more insight? What’s happening at 1628+, etc is all after running sudo nmcli networking off and on.

All TLP settings are stored in the config file /etc/default/tlp. The config file can be changed with any text editor (root privilege is needed).

Changes to the settings take effect after a reboot.

Parameters ending on _AC are effective with the power supply connected

Parameters ending on _BAT are effective when running on battery.

Parameters containing blanks must be enclosed in double quotes ("").

Have you tested the 2.4 Ghz band for stability?

Have you tried that yet ^^^

Active-State Power Management (ASPM)

Much more info here:

https://wiki.archlinux.org/index.php/Power_management#Kernel_parameters

Also try these options:

sudo modprobe -r ath10k_pci
sudo modprobe -r ath10k_core
sudo modprobe ath10k_core nohwcrypt=1 skip_otp=y

You could also try:

sudo modprobe ath10k_pci irq_mode=1

Thanks - just a typo re TLP, but no change.

I hadn’t tried the ASPM settings, but did not have any luck on boot.

sudo modprobe ath10k_core nohwcrypt=1 skip_otp=y resulted in the modem not working at all, returning this:

[  131.202475] ath10k_pci 0000:01:00.0: failed to recalculate rts/cts prot for vdev 0: -108
[  131.202481] ath10k_pci 0000:01:00.0: failed to set cts protection for vdev 0: -108
[  131.202486] ath10k_pci 0000:01:00.0: failed to set erp slot for vdev 0: -108
[  131.441356] ath10k_pci 0000:01:00.0: device successfully recovered
[  194.052582] ath10k_core: unknown parameter 'nohwcrypt' ignored
[  194.052583] ath10k_core: unknown parameter 'shkip_otp' ignored

Just tried sudo modprobe ath10k_pci irq_mode=1, which resulted in a firmware crash, but recovered to a connection that was stable for about 5 minutes:

[  286.203346] ath10k_pci 0000:01:00.0: limiting irq mode to: 1
[  286.203349] ath10k_pci 0000:01:00.0: pci irq legacy oper_irq_mode 1 irq_mode 1 reset_mode 0
[  286.530035] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[  286.530041] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[  286.531233] ath10k_pci 0000:01:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[  286.597207] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[  286.668835] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[  286.688397] ath10k_pci 0000:01:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[  286.786465] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
[  287.060063] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[  287.431530] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[  305.215427] ath10k_pci 0000:01:00.0: firmware crashed! (guid 73d57b09-6a4f-4d22-8108-da8e312e4abb)
[  305.215475] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[  305.215487] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[  305.217724] ath10k_pci 0000:01:00.0: firmware ver RM.4.4.1.c2-00057-QCARMSWP-1 api 6 features wowlan,ignore-otp,no-4addr-pad,raw-mode crc32 e061250a
[  305.219244] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 4ed3569e
[  305.219256] ath10k_pci 0000:01:00.0: htt-ver 3.56 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[  305.230167] ath10k_pci 0000:01:00.0: failed to get memcpy hi address for firmware address 4: -16
[  305.230180] ath10k_pci 0000:01:00.0: failed to read firmware dump area: -16
[  305.230186] ath10k_pci 0000:01:00.0: Copy Engine register dump:
[  305.230209] ath10k_pci 0000:01:00.0: [00]: 0x00034400  11  11   3   3
[  305.230231] ath10k_pci 0000:01:00.0: [01]: 0x00034800   0   0 205 206
[  305.230252] ath10k_pci 0000:01:00.0: [02]: 0x00034c00  42  42  40  42
[  305.230278] ath10k_pci 0000:01:00.0: [03]: 0x00035000   9   9  11   9
[  305.230300] ath10k_pci 0000:01:00.0: [04]: 0x00035400 121 109 120  56
[  305.230321] ath10k_pci 0000:01:00.0: [05]: 0x00035800   0   0  64   0
[  305.230342] ath10k_pci 0000:01:00.0: [06]: 0x00035c00   3   3   3   3
[  305.230363] ath10k_pci 0000:01:00.0: [07]: 0x00036000   0   1   0   1
[  305.278674] ath10k_pci 0000:01:00.0: failed to read hi_board_data address: -28
[  305.608685] ath10k_pci 0000:01:00.0: unsupported HTC service id: 1536
[  305.715015] ath10k_pci 0000:01:00.0: device successfully recovered

I really appreciate your help so far, please let me know if I should just try a fresh install if all this troubleshooting is getting tedious!

1 Like

Typo there^^^

It is not getting tedious. I enjoy troubleshooting with someone who is capable and “gets it”. Did you read the Arch wiki link. There is some very good info there that might be worth testing out.

Is the 2.4 Ghz band the same issues?

Do you use bluetooth?

I do not think a reinstall is required at this point, but testing different live boot images would be a very good idea.

Try a gnome or kde boot disk and also a ManjaroWish Lxqt boot disk to see if your wifi is better on alternate DE’s. If you find an improvement be sure to copy the firmware that is working to your system.

Let me know what happens.

1 Like

Ha! That’ll teach me to proof read. Not quite sure if I ‘get it’ yet, but eager to learn. I did try it with the typo corrected, the device doesn’t show at all. I’ll have another look at the wiki.

Bluetooth - don’t need right now, but will do eventually. I’ll see if there’s any improvement in the meantime.
Do appear to be having the same issues with 2.4G.

I’ll try a few boot disks, I did have to use an ethernet connection during install - live did not work on the GNOME distro running off of a USB.

You do not need to reinstall with an ethernet connection. Simply download the iso images on any computer with internet and burn the iso to a boot disk using etcher.

Also, I have seen this fix reputed to help with dropped connections with your adapter. In your bios change your sleep settings from S2Idle to S3 (deep).

I meant that I needed to connect to ethernet for the wireless drivers to download before I could use wifi.

Did just try downloading and installing the latest drivers from git, no improvement. Will try the BIOS settings.

  I take it you mean the firmware from kvalo.

Yep, that’s the one - from 4.4.1.

I just had a poke around in BIOS and don’t appear to have any sleep or similar settings available to change.

Forum kindly sponsored by