Qbittorrent crashes when using qt5-base-nosystemd

After today’s update, on testing, qbittorrent stopped working.

Running it from a terminal, I get these errors:

qbittorrent: /usr/lib/libcrypto.so.1.0.0: version OPENSSL_1.0.2d' not found (required by /usr/lib/libQt5Network.so.5) qbittorrent: /usr/lib/libssl.so.1.0.0: versionOPENSSL_1.0.2d’ not found (required by /usr/lib/libQt5Network.so.5)

I replaced qt5-base-nosystemd with qt5-base and it’s working again.

Yes, I get the same error with SMPlayer. qt5-base solves it. Looks like qt5-base-nosystemd needs updating, @artoo.

1 Like

Already rebuilding…

2 Likes

Correct. A rebuild is needed due this. More details about this can be found here.