Python2 upgrade 2.7.18-5 -> 2.7.18-6 tests error

I received a notification to update python2 package, from 2.7.18-5 to 2.7.18-6

$ yay -Syu --aur

And I cleanBuild the package.

When the system is running the tests, I get:

== Tests result: FAILURE ==

371 tests OK.

1 test failed:

23 tests skipped:
    test_aepack test_al test_applesingle test_bsddb185 test_cd test_cl
    test_dl test_gl test_imageop test_imgfile test_kqueue
    test_linuxaudiodev test_macos test_macostools test_msilib
    test_ossaudiodev test_py3kwarn test_scriptpackages test_startfile
    test_sunaudiodev test_winreg test_winsound test_zipfile64
Those skips are all expected on linux2.

Total duration: 8 min 10 sec
Tests result: FAILURE
==> ERROR: A failure occurred in check().

Anyone with this problem as well?

1 Like

Please read Announcement posts:

1 Like

@Yochanan Thank you for your comment.

In that link, I can read:

Is this the reason, i.e. python2 being removed from the repos, why it gives that error when building?

Forgive my ignorance, I’m new in the field.

1 Like

Hmm, " * Python 2 was finally dropped from the repos" about time.
I too had the update message and fail to compile.
After uninstalling python2.
To be sure I ran

locate python2

and removed the remaining rubbish except for what’s in timeshift’s subvolumes.

1 Like

The point of python2 being dropped is that you likely don’t need it either.

Thanks. I’ve tried to remove it, but I get this:

$ sudo pacman -Rsn python2
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python2 breaks dependency 'python2' required by python2-dbus
:: removing python2 breaks dependency 'python2' required by python2-numpy
:: removing python2 breaks dependency 'python2' required by python2-sip-pyqt4

How could I cleanly remove it?

Also remove the (AUR) packages that depend on it.

$ sudo pacman -Rsn python2-pyqt4 python2-numpy

You can use the cascade parameter to remove all packages that depend on python2:
sudo pacman -Rcs python2

or with pamac:
pamac remove --cascade python2


Thanks. I understand packages dropped to AUR can be safely removed.

However, this shouldn’t prevent building the package from AUR.

Hence, what is the origin of this error?

Executing test don’t like most of the terminals seem AUR (en) - python2

Is a good idea to check the AURweb page for comments and solutions AUR (en) - python2

1 Like

The relevant comment is

@micwoj92 adding export TERM=xterm to check() and xterm to checkdepends

edit the package build as stated above

Notes export TERM=xterm must be within the brackets and xterm must look like this ‘xterm’

Not mandatory, it can be whenever in the pkgbuild

also not mandatory, quoting dependencies like that is a waste of quotes, pkgubilds work the same without

I have no idea if you say so I only followed what the comment said so not being an expert on PKGBUILD
I don’t Know?

When i try to install “cndrvcups-lb-bin” for my Canon MF 4410 printer driver, it says “python2 compilation failed”. So i can’t use my printer. But i could easily install the driver and use the printer before. Hope anybody can help me?

See post 12 above.

Couldn’t get it. Sorry.

I’m really got mad at this problem. Manjaro is nice but sometimes it is useless :frowning:

If you can’t play guitar that doesn’t make it useless.

Try to build just python2 and edit the build to include the bits as shown in post 12

(Use pamac gui)