Python IDLE error on startup


I encounter a very strange problem with IDLE. On my laptop n°1, it works flawlessly with the latest Python package (3.10.8-3). Manjaro is installed since months with regular updates.

On my laptop n°2, IDLE crash with the following message

Traceback (most recent call last):
File “”, line 1, in
File “/usr/lib/python3.10/idlelib/”, line 23, in
from idlelib import debugger_r # start_debugger
File “/usr/lib/python3.10/idlelib/”, line 24, in
from idlelib import debugger
File “/usr/lib/python3.10/idlelib/”, line 7, in
from idlelib import macosx
File “/usr/lib/python3.10/idlelib/”, line 7, in
from import requires, ResourceDenied
ModuleNotFoundError: No module named ‘’; ‘test’ is not a package

After that, the IDLE GUI starts with message

Subprocess Connection Error
IDLE’s subprocess didn’t make connection.
See the ‘Startup failure’ section […]

First, I tried with a new clean user account… same result
Then, I tried with with Manjaro fresh install and updated… same result.

But… when I downgrade Python 3.10.8-3 to Python 3.10.7-1, IDLE works like a charm.

To summarize :

  • on laptop 1, IDLE works perfectly with latest Python package (3.10.8-3)
  • on laptop 2, IDLE works only if I downgrade Python package to 3.10.7-1, even with new user, or perfectly clean system.

I really don’t know where to investigate more, and why it’s not reproductible on my laptop 1. Any clue ?


Have you rebuilt idle after updating python?

Thank you for your response, but I’m not using the IDLE AUR package (it is not installed). AFAIK IDLE is provided by the Python package which is coming from Core.

But maybe I don’t understand something ?

Note : AUR previous category on my post was not from me, it was a mistake.

Let’s confirm that.

LANG=C pacman -Qo `which idle`

Actually it does looks like an upstream issue.

Thank you for the link to the Arch BTS.

After reading the comments, I have updated Python again, and try one possible workaround suggested in Arch comments :

If I create an empty file /usr/lib/python3.10/test/__ init, IDLE can start.

But no change, the error remains. Downgrading Python again solve the problem for now on laptop 2.
With laptop 1, no problem that’s very strange.

I think that we have to wait an upstream patch…