Pulseeffects not working, segmentation fault core dumped

Good day my fellow smart people and enthusiasts

i hope ypu are well during this whole pandemic crysis.

This is a pretty short one. I don’t have alot to go on.

I know I should’ve come here alot sooner but at fist, it didn’t bother me. Now the annoyance seem to be increasing.

After an update awhile ago, my pulseeffects don’t launch. i just thought nothing of it as my sound still works. But i really miss the audio clarity of pulseeffects.

This is all i get when trying to run pulseefects using the terminal.

Any ideas?

Thank you

░▒▓    ~  pulseeffects                           INT ✘  at 20:08:49  ▓▒░
zsh: segmentation fault (core dumped)  pulseeffects

░▒▓    ~                                        SEGV ✘  at 20:14:08  ▓▒░
1 Like

A solution was posted here which solved the problem for me:

Or you could install PulseEffects Legacy to have PulseEffects work with PulseAudio.

PulseEffect now works with PipeWire instead of PulseAudio, so if you want latest PulseEffects you need to switch audio system to PipeWire, or you can stay on previous PulseEffect by using PulseEffects Legacy instead.

Thank you have been without internet for awhile and I haven’t tried the suggestions yet but I would like express my eternal gratitude for your help

It worked. I did as you said and I can listen to music finely tuned to give high quality again

Again thank you so much for your help. I really appreciate it

I’m glad to now have your eternal gratitude :rofl:… or do I? :thinking: (not sure who you’re replying to as we’re two to have replied)


The solution I posted worked for me for a couple of days, then no more audio output. Pulseeffects loaded properly but was getting no output. Volume controls were set ok. I did not spend much time troubleshooting (shame on me), but instead uninstalled pulseeffects and anything pipewire related, reinstalled pulseaudio and all optional dependencies, and then installed pulseeffects-legacy.

Same issue here : Pipewire issues since last update - #14 by nam1962

Solved with : What is the correct way to install package “manjaro-pipewire”? - #7 by kagetora13

Not solved after reboot :confused:

[Edit]partially solved on previous link