Pulseaudio custom profile for Focusrite 18i8

So up until I turned my computer on this morning my external (USB) Focusrite 18i8 (2nd gen) was working fine in manjaro via pulseaudio for daily use. However, now it has stopped appearing in pulse audio. Checked with the same machine and setup booting windows and it’s all fine. If I remove the custom files, the device reappears in pulse but as only having 7.1 surround (that’s what the custom configuration was fixing).

It used the following custom files-

SUBSYSTEM!="sound", GOTO="pulseaudio1_end"
ACTION!="change", GOTO="pulseaudio1_end"
KERNEL!="card*", GOTO="pulseaudio1_end"

SUBSYSTEMS=="usb", ATTRS{idVendor}=="1235", ATTRS{idProduct}=="8204", ENV{PULSE_PROFILE_SET}="focusrite18i8.conf"



auto-profiles = no

[Mapping analog-out]
description = Analog Outputs
device-strings = hw:%f
channel-map = left,right,aux0,aux1,aux2,aux3,aux4,aux5
direction = output

[Mapping analog-in]
description = Analog Inputs
device-strings = hw:%f
channel-map = left,right,aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7,aux8,aux9,aux10,aux11,aux12,aux13,aux14,aux15
direction = input

[Profile output:analog-out+input:analog-in]
description = Analog Stereo
output-mappings = analog-out
input-mappings = analog-in
skip-probe = yes

Any help to figure out what’s gone wrong massively appreciated!

EDIT: an update did take place in between me noticing the device working / not working

EDIT: the issue occurred with the move to version 3.99

the custom udev rule appears to have the correct Vendor ID and Product ID
Scarlett 18i8 2nd Gen - linux-hardware.org

But it is probably unable to find the profile-set /usr/share/pulseaudio/alsa-mixer/profile-sets/focusrite18i8.conf because the files have been relocated

Stable update 2020-11-04 included PulseAudio v13.99 with a new package for the ALSA card profiles

alsa-card-profiles                    -            13.99.3-1

profile-sets are now located at - /usr/share/alsa-card-profile/mixer/profile-sets/

So you probably need to find your custom profile-set and relocate for the udev rule to find it

1 Like

Thanks, I’ll give it a go

Thanks for your help, and I agree with your fix. But oddly still doesn’t work. I can’t spot any issues with the conf file in the new destination. Looking at [Bisected] Sound is gone after upgrading PulseAudio (#1009) · Issues · PulseAudio / pulseaudio · GitLab there are similar issues so I suspect I might have to wait until 14.1

You might have a long wait for PulseAudio v14.1.
v14.0 was expected to be released months ago and has not been released yet

The bug report was originally posted to Arch forum 2020-10-13 for PulseAudio v13.99.2
and was marked [SOLVED] by OP on 2020-10-14 “pulse update fixed the issue”
that would be PulseAudio 13.99.3-1 which is still the latest version in Arch repo

Manjaro stable branch never had PulseAudio v13.99.2
users were still using last release version until Stable update 2020-11-04

pulseaudio               13.0-3            13.99.3-1

Ok thanks. If I remove the custom profile the card shows up as a surround sound only card in pulse. Looks like I’ve got some more digging around to do!

PulseAudio is hopeless at detecting multi-channel channel devices except for surround sound
I have 2 stereo outputs on my audio card that are auto-detected as 4.0 surround, but none of the channels work with that profile. I can use the first output, but I have to reconfigure PulseAudio to add the 2nd stereo output

There is not much documentation I can find about PulseAudio profiles for ALSA

The page at Writing pulseaudio profiles - freedesktop.org needs to be updated to change the old folder location /usr/share/pulseaudio/alsa-mixer/ to new location /usr/share/alsa-card-profile/mixer/

There is also some information about creating a custom profile in a comment section at the beginning of file /usr/share/alsa-card-profile/mixer/profile-sets/default.conf