Pulseaudio autostart after last update (2018-07-01)

pulseaudio
#1

Hello,

Yesterday I updated my system as soon as I got notified about updates. I’m using Manjaro i3 and until now everything worked without any problems (I performed clean install of it in the beginning of May). Until this update I already installed all other updates, so there was nothing in the queue until that moment.

So basically I just updated the system and after some time shutdown computer. Today when I powered it on I noticed that sound indicator (pa-applet) does not display icon, but only some free space is allocated for it in the system indicator bar. After some time I figured out that I don’t have sound and started digging into the problem. The first thing to try out was what happens if I kill pulseaudio and start it again - in that case everything worked fine, but after reboot the same problem appeared back. Then I tried to remove local config (~/.config/pulse), but it wasn’t of any help. Lastly I checked system logs with journalctl and found out that rtkit-daemon is starting pulseaudio before my i3 config starts it. The second one was always exiting with error code since it came up after pulseaudio was already started.

So the fix was to comment out custom start of pulseaudio in my i3 config and now everything seems to work as expected. After some reading I’ve concluded that this is probably not the intended way of starting pulseaudio since it should be started by DE (or in my case WM). What should I do now - leave it as is or do you maybe have any opinion on how to fix this thing in the proper way?

Thanks in advance,
Johnny

0 Likes

#2

can you give return

sudo systemctl status rtkit-daemon.service

i have this

rtkit-daemon.service - RealtimeKit Scheduling Policy Service
   Loaded: loaded (/usr/lib/systemd/system/rtkit-daemon.service; disabled; vendor preset: disabled)
   Active: active (running) since Mon 2018-07-02 20:47:52 CEST; 1h 0min ago
 Main PID: 854 (rtkit-daemon)
    Tasks: 3 (limit: 4915)
   Memory: 756.0K
   CGroup: /system.slice/rtkit-daemon.service
           └─854 /usr/lib/rtkit-daemon

juil. 02 20:47:52 mjro systemd[1]: Starting RealtimeKit Scheduling Policy Service...
juil. 02 20:47:52 mjro systemd[1]: Started RealtimeKit Scheduling Policy Service.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Successfully called chroot.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Successfully dropped privileges.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Successfully limited resources.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Running.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Canary thread running.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Watchdog thread running.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Successfully made thread 848 of process 848 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.
juil. 02 20:47:52 mjro rtkit-daemon[854]: Supervising 1 threads of 1 processes of 1 users.
0 Likes

#3

Output is exactly same, except for PIDs/TIDs. I didn’t do any changes to the config from the last post (so rtkit-daemon starts pulseaudio and i3 config has commented line for starting pulseaudio) before running command.

I also noticed that now two things don’t work as before:

  • LED indicator for sound on my machine is by default off on startup when I left sound muted before restart/poweroff (before update this worked as expected - it was on when muted and also now does when I kill pulseaudio and start it again manually)
  • If I have headphones/speakers plugged to audio jack and then power on computer, they are not recognized until I replug them (before update they were already recognized to the time the sound indicator - pa-applet is displayed)
0 Likes

#4

Have a look here: [Testing Update] 2018-06-25 - Mesa, Openbox, QT, Gitlab, Timeshift, PacUI.

Could be this is the same issue?

2 Likes

#5

@grinner That sequence of systemctl commands fixed the problem. I also uncommented exec pulseaudio command in my i3 config and everything works as expected.

Thanks for help! :slight_smile:

1 Like

closed #6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes