Pulseaudio 4.0-1 and bluetooth-modules-bt (no audio profiles showing)


I did a system update this morning and now in the afternoon tried connecting to my Audioengine B1. I run the Bluetooth Manager (I don’t know the English name) hit connect (to the B1). It usually connects within a few secs and then when I right click it I could select between several audio profiles (was using APTX), thanks to the pulseaudio-bluetooth-bt package.

Now however I got “Protocol not available”. Followed How to fix Bluetooth protocol not available in Manjaro - Geeky Hacker and after that I can connect to the B1 without incident, I just don’t get the list of audio codecs anymore. There’s just “High Fidelity Playback (A2DP Sink)” in the Bluetooth Manager, there’s no dropdown with profiles in Gnome settings Audio anymore (and the B1 is showing an unhappy white light because of no APTX signal) (audio works however).

It uninstalled pulseaudio-modules-bt and so I installed first the official 1.4-4. It made no difference in terms of audio profiles. I re-paired the BT to no avail.

I uninstalled that and installed pulseaudio-modules-bt-git but there’s no difference. I’ve unpaired and removed the B1 and repaired the b1. What else can I try?

The -git version has this last comment in the AUR:

Note that after upgrading to the latest pulseaudio 14.0-1 release, you’ll need to force a rebuild of this package. I use chaotic-aur (which hasn’t yet rebuilt against v14.0), and yay, so had to run:

> yay -Sa pulseaudio-modules-bt-git

And I don’t know how that translates to pacman. I haven’t seen a “force rebuild” flag.

Am running Kernel: 5.9.11-3-MANJARO x86_64 w Pulseaudio 14.0-1,

Any help is very much appreciated : )

Well, I just reinstalled / built the -git version of pulseaudio-bt-git via Add/remove programs, then unpaired, repaired and connected the B1 again and now the audio profiles are back. As far as I’m concerned this is the second time I’ve tried just that in the last hour. Well… good evening everyone anyway : ) The “click” as the B1 connects is rather satisfying, I did not get that when it connected with "High Fidelity Playback (A2DP sink) : )