Pulse audio volume control -> configuration

#1

Every time I boot up, I am without any audio. I go into pulse audio volume control, open up the configuration tab and choose from the built in audio list, one of the choices that works. Is there anyway to make that choice automatically load upon bootup without having to do it manually everytime?

Thanks

0 Likes

#2

There were several issues with pulseaudio latetly.

I would recommend to try deleting these components

~/.pulse-cookie
~/.config/pulse

and doing this thing

reboot and see if it helps

0 Likes

#3

I looked all over in home and didn’t find a pulse-cookie.

0 Likes

#4

That can be, don’t worry.

0 Likes

#5

I tried your suggestion but it didn’t resolve the problem.

0 Likes

#6

What does?

$ systemctl --user status pulseaudio.service

returns after boot?

0 Likes

#7

pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2018-07-21 11:32:23 CEST; 3h 34min ago
Main PID: 605 (pulseaudio)
CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
├─605 /usr/bin/pulseaudio --daemonize=no
└─631 /usr/lib/pulse/gsettings-helper

lug 21 11:32:20 ron-pc systemd[598]: Starting Sound Service…
lug 21 11:32:23 ron-pc pulseaudio[605]: W: [pulseaudio] authkey.c: Failed to open cookie file '/home/ron/.config/pulse/c>
lug 21 11:32:23 ron-pc pulseaudio[605]: W: [pulseaudio] authkey.c: Failed to load authentication key '/home/ron/.config/>
lug 21 11:32:23 ron-pc pulseaudio[605]: W: [pulseaudio] authkey.c: Failed to open cookie file ‘/home/ron/.pulse-cookie’:>
lug 21 11:32:23 ron-pc pulseaudio[605]: W: [pulseaudio] authkey.c: Failed to load authentication key '/home/ron/.pulse-c>
lug 21 11:32:23 ron-pc systemd[598]: Started Sound Service.
lug 21 11:32:50 ron-pc pulseaudio[605]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.>

0 Likes

#8

Apologies if stating the obvious, but are you sure it is pavucontrol you are using, and not another panel volume control gui package?
I have been caught by couple of those not being able to write option changes for Pulseaudio.
pavucontrol is usually reliable for this

Try changing profile to ‘Off’ then back on again - has sometimes been enough to cause Pulseaudio playback options to get written

use this command to get Pulseaudio card device number:
pactl list short cards

Use this command to list playback device information to find profile names:
pactl list sinks

Information from those commands can be used for command:
pactl set-card profile [card number] [profile]

for example. I set my device for stereo playback only with:
pactl set-card-profile 0 output:analog-stereo

would use ‘output:analog-stereo+input:analog-stereo’ if need Duplex setting with recording and playback

0 Likes

closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes