Pulse Audio right pane missing in System Settings

Hello - This is my first time here so I apologize for any mistakes.

I have somehow lost the ability to see Pulse Audio settings in the System Settings menu. The whole right pane is blank.

I have reinstalled pulse audio, ran Syyu, rebooted, Installed Alsa ect… I also enabled and started the service.

I get this output
E: [pulseaudio] conf-parser.c: [/etc/pulse/daemon.conf:93] Missing ‘=’.

If you need anymore info please let me know - Sorry if this was posted before! I appreciate your time.
I tried to attach screenshots, but it would not let me embed them.

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3

Kernel Version: 5.17.4-arch1-1-surface (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

provide formated output of:
inxi -Fazy
also im seeing youre running on wayland try switch to x11
also what did you before it disapeared - installed/ uninstalled/ updated … etc?

Try launching systemsettings from the terminal, then look for errors.
In the meantime, you can install pavucontrol or pavucontrol-qt for managing your audio.

Thank you for the reply. I was thinking of going to x11 due to better screen cast / shot apps but I have a Surface Book 2. I like that wayland has better touch support.

I am new to Linux so I have been doing a ton of customizing, which sadly means im breaking everything. I have Manjaro fresh installed from ISO and I had not had the audio working yet. I have been doing so many changes, since ive been adding all my apps and cloud services that I am not exactly sure at which point it broke. It is running fine on my other PC with KDE + Manjaro + Wayland.

Cant post the output to your cmd since it is saying there is a link. One minute. i dont see any obvious “links”.

Ran systemsettings from term, no errors.

there shouldnt be any issues providing output from the command… click this icon: </> in the editor and inside it put the output…
also noticed youre running some strange kernel… maybe related to your audio :thinking:

Yeah it is specific for Microsoft Surface devices.


Kernel: 5.17.4-arch1-1-surface arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-linux-surface
root=UUID=4001c880-19aa-4088-adfb-7da65e699729 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_wayland vt: 2 dm:
1: LightDM v: 1.30.0 note: stopped 2: SDDM Distro: Manjaro Linux
base: Arch Linux
Type: Laptop System: Microsoft product: Surface Book 2
v: 124000000000000000000000D:0B:08K:1F:5C:10P:38
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Microsoft model: Surface Book 2 serial: <superuser required>
UEFI: Microsoft v: 390.3732.768 date: 04.20.2021
ID-1: BAT1 charge: 21.8 Wh (100.0%) condition: 21.8/23.2 Wh (94.1%)
volts: 8.7 min: 7.6 model: DYN M1005046 type: Li-ion serial: <filter>
status: full cycles: 114
ID-2: BAT2 charge: 59.5 Wh (100.0%) condition: 59.5/62.2 Wh (95.7%)
volts: 13.0 min: 11.4 model: SMP M1010958 type: Li-ion serial: <filter>
status: full cycles: 125
Info: model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1257 high: 2332 min/max: 400/4200 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 2332 3: 2312
4: 1415 5: 804 6: 800 7: 800 8: 800 bogomips: 33615
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: Intel UHD Graphics 620 vendor: Microsoft driver: i915 v: kernel
ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:5917 class-ID: 0300
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Microsoft
driver: N/A alternate: nouveau pcie: gen: 3 speed: 8 GT/s lanes: 4 link-max:
lanes: 16 bus-ID: 02:00.0 chip-ID: 10de:1c20 class-ID: 0302
Display: wayland server: X.org v: with: Xwayland v: 22.1.1
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1620x1080 size: N/A modes: N/A
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.8
direct render: Yes
Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging
driver: ipu3-imgu alternate: ipu3_imgu bus-ID: 00:05.0 chip-ID: 8086:1919
class-ID: 0480
Device-2: Intel CSI-2 Host driver: ipu3-cio2 alternate: ipu3_cio2
bus-ID: 00:14.3 chip-ID: 8086:9d32 class-ID: 0480
Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.17.4-arch1-1-surface running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.20 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.49 running: yes
Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie
v: 1.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0
chip-ID: 11ab:2b38 class-ID: 0200
IF: wlp1s0 state: up mac: <filter>
Device-1: Marvell Bluetooth and Wireless LAN Composite type: USB
driver: btusb v: 0.8 bus-ID: 1-6:6 chip-ID: 1286:204c class-ID: e001
serial: <filter>
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Local Storage: total: 953.87 GiB used: 129.36 GiB (13.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZFLW1T0HMLH-000MU size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: CXY74M0Q temp: 34.9 C scheme: GPT
ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
used: 129.36 GiB (13.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Alert: No swap data was found.
System Temperatures: cpu: 44.0 C pch: 36.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 354 Uptime: 58m wakeups: 2 Memory: 15.55 GiB
used: 7.92 GiB (51.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 2261 pacman: 2224 lib: 498 flatpak: 25
snap: 12 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15

and if you install pipewire instead of pulse? install this package: manjaro-pipewire it will automatically remove pulse audio, reboot and check

1 Like

You are awesome. That did it. :blush:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.