Pulse audio draining battery and sometimes it is consuming more power than cpu and Display

When i am running power top command I notice pulse audio is consuming a lot of power sometime it is consuming power more than CPU and it is drastically decreasing my battery life some times close to half .
I have installed tlp, tlpui, intel microcode, auto-cpufreq to optimize my battery. Ihave checked out arch wiki but there is no solution for this .
So can someone tell me how to decrease power consumed by pulse audio (i have tried to kill the program but them my earphones are not working).

Power est.   Usage       Events/s    Category       Description
  3.14 W    555.6 us/s     2.2        Process        [PID 1373] /usr/bin/pulseaudio --daemonize=no --log-                              targ
  2.80 W      5.3%                    Device         Display backlight
  1.14 W    986.6 ms/s     7.5        kWork          intel_atomic_commit_work



By default, audio power saving is turned off by most drivers. It can be enabled by setting the power_save parameter; a time (in seconds) to go into idle mode. To idle the audio card after one second, create the following file for Intel soundcards.


options snd_hda_intel power_save=1

for further information:

i dont see any audio_powersave.conf file in /etc.modprobe.d/ directory and i found a solution asking to remove pulse audio and replace with ALSA is it worth trying reddit

please read, you have to create that file

Just one line of code or is there anything to add and do i need to reboot the system to see the change

options snd_hda_intel power_save=1

yes it’s just that line of arguments and please reboot to make sure it takes affect

No there is no change is there anything to do and do i need to add a # before the argument load-module module-suspend-on-idle in file /etc/pulse/default.pa in pulse audio and should i need to disabling the HDMI audio output, by blacklisting.

Power est.              Usage       Events/s    Category       Description
  3.27 W    302.6 us/s       2.5        Process        [PID 1384] /usr/bin/pulseaudio --daemonize=no --log-target=journal
  3.20 W      5.3%                      Device         Display backlight
  1.12 W      0.0 pkts/s                Device         Network interface: enp4s0 (r8169)
  379 mW    105.5 pkts/s                Device         Network interface: wlp0s20f3 (iwlwifi)

If you add a ‘#’ to comment out module-suspend-on-idle that will likely increase power use

module-suspend-on-idle | freedesktop.org - PulseAudio Documentation
ALSA uses considerably more CPU cycles when pulseaudio has to send empty data to the soundcard during idle. If you don’t plan to have an active stream all the time, set the timer to a low value for best power savings

It may help reduce power by reducing the suspend timeout setting exit-idle-time in /etc/pulse/daemon.conf - default timeout is 20 seconds

pulse-daemon.conf(5) — Arch manual pages
exit-idle-time= Terminate the daemon after the last client quit and this time in seconds passed. Use a negative value to disable this feature. Defaults to 20.

I suspect that 3.27w is total power used for audio - PulseAudio + ALSA + speakers/headphones
that amount of power would be typical for laptop speakers or headphones

Turning off unused input and output devices in ALSA may reduce power but I would not expect much difference if the devices were not in use anyway. If you can reduce audio levels that would be more likely to reduce power