PS3 Controller connection via USB and Bluetooth not working


I’m trying to get my PS3 controller working so I can play games as well as test my own games.

I tried this guide…

…But when I got to the step of connecting the controller via USB, nothing appears in the terminal.

When I plug in the controller, the lights blink, which I think is what it’s supposed to do, and I used lsusb to check if the computer sees it, which it does, even identifies it specifically as a Playstation 3 controller right there in the list.

It doesn’t even seem to be working for games in USB mode either, I’ve tried a few games and none of them seem to recognize any input from it whatsoever. I’ve even tried my other Dualshock 3 controller, and it’s not seeing that one either it seems.

I can’t really seem to find much else online about this behavior, any help would be greatly appreciated


OK, so I got it to a point where the computer will see it, but now I can’t get it to stay connected for more than a few seconds

It keeps asking for a pin. According to what I’ve read online, they say it should give you the pin when it connects, and it’ll connect for a second or two, then immediately disconnect, and it’s not giving me the information it’s supposed to

Is this just a general Bluetooth issue or is this specific to gamepads?


So I’ve downloaded pretty much every single possible program for connecting controllers available on the AUR, tried 3 different joysticks, an old Sixaxis controller, a Dualshock 3, and a generic USB SNES controller, and had absolutely zero success.

I can see the controllers in some programs but not others, it depends on the program or controller or which way the wind is blowing.

I long ago gave up on the ambition of having a functioning Bluetooth mode, I’d just like to see it work on USB mode, and even that shows no input from the controllers.

Any insight at all from anyone…it would be highly appreciated.


Have you try searching the forum?


I already did that for a separate problem with my audio interface.

It’s not a power problem, the LEDs on my PS3 controller stay on as long as it’s plugged in, it’s just a matter of programs not registering the existence of the controller, some do, some don’t, and pretty much none of them register input from any of the controllers I’ve tried, even the ones that see it

Like, lsusb will identify the controller as a Playstation 3 controller, and I tried xboxdrv, and that sees it usually, but at the same time it sees no input from it, none of my games see it and none of the controller test programs I’ve downloaded see it

I’m really not sure what I’m missing