Proton vpn stopped working

This worked for me (needed to install paru first):

pacman -Qoq /usr/lib/python3.9 | paru -S - --rebuild

Neither pacman nor pamac seem to know what paru is.
How do I get one and what is it?

pamac build paru

Ok, Seriously, none of this is working, WHAT is the solution to this?

I ran that pacman command
pacman -Qoq /usr/lib/python3.9 | paru -S - --rebuild
and it does this, what it is suppose to do? Its just stays stuck here:

Maintainer: Proton Technologies AG

Maintainer: Alexandru Cheltutior

pkgname=python-proton-client
_gitpkgname=proton-python-client
pkgver=0.7.1
pkgrel=1
pkgdesc="Official Proton API Python Client, maintained by the Proton(VPN/Mail) >
arch=(“any”)
url=“GitHub - ProtonMail/proton-python-client: Python Proton client module
license=(“GPL3”)
groups=(“ProtonVPN”)
depends=(“python-requests” “python-bcrypt” “python-gnupg” “python-pyopenssl” "p>
conflicts=(“python-protonvpn-nm-lib<3.4.0”)
makedepends=(“python-setuptools”)
source=("https://github.com/ProtonMail/proton-python-client/archive/refs/tags/$>
sha256sums=(‘88d2546a922d9053988b5e1863bf6cf965e97b4c643cd879f16bb3f0b5f02b5e’)
validpgpkeys=(“A884 41BD 4864 F95B EE08 E63A 71EB 4740 1994 0E11”)

build() {
cd “$_gitpkgname-$pkgver”
python setup.py build
}
:

Make sure you are fully up to date:

sudo pacman -Syu

Double check rebuilds against repos:

sudo pacman -S $(pacman -Qoq /usr/lib/python3.9)

Rebuild AUR packages relying on old python (I guess you have paru installed?):

paru -S $(pacman -Qoq /usr/lib/python3.9)

Or, with pamac, the same:

pamac build $(pacman -Qoq /usr/lib/python3.9)
3 Likes

Hello,

I encounter the same issue (and I don’t have paru installed so I was unable to test some of the solutions).

I posted on this closed issue thread, I hope someone will be able to help…

@justinsojolly @Delan

Why with these somewhat-unrelated posts?

If you dont have paru, then install it or dont use it.

It is one of many AUR helpers. By default Manjaro already has one - pamac.

Please see my post above and/or the wiki:

https://wiki.manjaro.org/index.php/Main_Page#Software_Management

https://wiki.manjaro.org/index.php/Arch_User_Repository

Little bit offtopic but while you try to get protonvpn working
you can use windscribe vpn
It doesnt have a GUI like proton vpn but it just works and it is much faster than protonvpn

pamac install windscribe-cli
sudo systemctl enable windscribe

#following commands have to be executed everytime you want to connect
sudo systemctl start windscribe
windscribe connect

But its a different service provider and application … that isnt really applicable, and borders on ‘product recommendation’.

Well I still don’t know what a paru is and I needed a rustup apparently and well this what I get…


Never mind I’ll make do without my VPN until I get a magic updated that fixes it again. I’ve got problems connecting to a new printer to sort out first.

Cannot reproduce, at least not if I do it the proper way as outlined above, and I dont care enough to try any other way when it seems obvious everything works when operated correctly.

Not unrelated: I have the same issue as the main one of this topic: protonvpn-cli, installed through AUR, just stopped working. I now try to get it working and none of the solutions that I was able to try works:

pamac: sudo pacman -S $(pacman -Qoq /usr/lib/python3.9) raises these errors (sorry, it’s in French: translate roughly as “error: impossible to find the target: X”)
erreur : impossible de trouver la cible : python-configparser
erreur : impossible de trouver la cible : python-proton-client

paru: you propose (among other) to use paru, that I don’t know. If it’s just an AUR helper, then indeed pamac should do the job just fine. I just mention in my post that I did not test that part of your solution.

The problem seems to be on protonvpn-cli or on the AUR script side. Someone managed to solve it in the git thread posted (using yay, which from what I understand is a AUR helper - the default Arch Linux one?), but I can’t reproduce it with pamac.

That is pacman not pamac, and of course it throws those errors, because it only interacts with the repos, not the AUR.

No I dont, it was just suggested higher up, so I kept the commands in-line with that.

You still did not use pamac, and I assume you never installed paru.

Again, this is unrelated because it is simply not understanding packaging, not an issue with protonvpn.

I have installed it above, and again after your posts, to confirm.

( I also suggested, and wrote out, the only true way of installing an AUR package, to assuage any doubt)

3 Likes

From comments on the AUR page. I don’t use protonVPN and don’t care to try…

 commented on 2022-01-06 01:56	

I fixed my issue by following https://github.com/ProtonVPN/linux-cli/issues/57#issuecomment-994694954https://github.com/ProtonVPN/linux-cli/issues/57#issuecomment-994694954

yay -Rs protonvpn
rm -rf ~/.cache/protonvpn

And then reinstalling protonvpn using pamac (Manjaro user here).
~~~

:man_facepalming:t2:
my bad for the confusion pacman/pamac, and I read your post as a “1. check that system is fully up to that 2. double check against repo (3 commands proposed)”. I did run the last command involving pamac (pamac build $(pacman -Qoq /usr/lib/python3.9)) and it now works!
Thank you very much for taking the time to explain this :stuck_out_tongue:

Slightly off topic, I’m not sure to understand the underlying problem here. I also use protonvpn-cli on another computer that runs Fedora. It is installed through RPM and updated through dnf. Both computers use Python 3.10.1 and ProtonVPN CLI 3.11.0 (and the same packages versions), and on Fedora the update went without a hitch. What is the difference? Is is related to the job done by the AUR script vs the dnf update? Or does dnf rely on pre-compiled binaries? I’m interested by any explanation on this topic.

Well, RPM packages are build in RPM format which Fedora is using. Therefore, correct, the whole build process written in the RPM scripts differ from the Arch packages which Manjaro is using.
Also these RPM packages are maintained by Fedora or some other community and AUR is a user repository where the packages are maintained by the user him/herself, so if something changed in the newer kernel or in any distro update, which affects your installed software, then you either need to wait for this particular user to fix the issue in the software or you may fix it by yourself.

Correct me if I’m wrong @cscs

1 Like

Were you able to resolve the issue on your end by now? :slight_smile:
Here was a possible solution which you may also try: Proton vpn stopped working - #34 by jrichard326

To answer your questions.
How to remove orphans in UI:

  1. If you go to “Add/Remove Software”
  2. There you will find “Installed” tab
  3. There, on the left side you see the “Orphans” menu point
  4. Select that and if you see any entries, you will also see a button somewhere top right “Remove all”
  5. Click that button and repeat if any new entries appear :slight_smile:
  6. profit

How to find packages on AUR (if you yet not did that already)

  1. Open “Add/Remove Software” again
  2. Then on top right you see the “burger” Button which opens new small menu where you can open “Preferences”
  3. There by going to “Third Parties” tab you will see AUR and you are able to toggle the switch on and off.
  4. This will enable the “Add/Remove Software” tool to also search for packages in AUR :slight_smile:
  5. profit

Thanks for trying, but I decided to simply install protonVPN on my cell phone then USB tether to the internet thru that and it’s working so I’m OK for now :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.