Prompt doesn't render properly when I SSH into fresh Manjaro install


When I login to my fresh Manjaro installation from an Ubuntu 18.04 or MacOS system (iterm2) the shell prompt doesn’t render properly. I haven’t had this issue with other distros. Any ideas how to fix this?
I thought maybe it’s a font issue. I checked locale and that looks right I think. I tried installing a number of the nerd fonts on Ubuntu, but that didn’t seem to improve the siutation. I figured getting it to work on another Linux distro first would be the easiest, but I eventually want to make it work when I SSH from iterm2 on my MacOS system as well. Maybe I need to simplify my prompt instead of trying to make the flashier, default prompt work? I love zsh and the new prompt looks nice.

Which shell are you using and which fonts did you setup to use?

The most complete (that a word?) font package that I’ve found is AUR (en) - nerd-fonts-complete
(The download is really big and because GitHub sucks with large downloads, it might break in the middle.)

1 Like

You should just need to build: Packages / Community / TrueType-font / nerd-fonts-noto-sans-mono · GitLab

You may also need to have powerline10k installed.

nerd-fonts-noto-sans-mono is in the community repo, there’s nothing to build.

Did you mean zsh-theme-powerlevel10k? :wink:

I was thinking these pkgs need to be installed on the Mac host for the prompt to display properly over ssh? After that it should source the zsh config from guest for session.

Sorry to take so long - got super busy. Thanks for responding.
I’m using the default setup on my recent Manjaro gtk install. I am using the default, and my favorite, shell: zsh. It does seem to be using powerline10k.
I like @airclay 's suggestion and was thinking I need to try installing those fonts on my MacOS and Ubuntu hosts. I tried finding something similar for Ubuntu and didn’t have any luck. I figured it might be easier to get another Linux system working first, and then move to MacOS. Has anyone got this working on those other hosts?

I found something that solves half the problem for MacOS! I use iTerm2. I ran into a setting there called “Use built-in Powerline glyphs” in the Preferences->Profiles->Text settings. Now I think I’m only missing the little icons - which are probably part of the font. I also found a bunch of other settings like the ability to turn off title bars and scroll-bars, how to switch between transparency on and off with one key-stroke and a bunch of other things. My desktop is starting to look pretty nice. Will be working on the rest of my issues.

1 Like

Got MacOS the rest of the way there. I navigated to GitHub - romkatv/powerlevel10k: A Zsh theme and installed the four fonts there, and then selected them from the Preferences->Profiles->Text settings page. I even disabled “Use built-in powerline glyphs”. I had to restart iTerm2 to get it completely enabled. It looks amazing. I’ll try loading the same set of fonts on my Ubuntu system and I’ll be that’ll get it.

1 Like