Program crashes when opening Gtk FileChooser

This happens for example in Nautilus when the FileChooser is called to appear.

Here is the error. I have already ran sudo pacman -Syyu

GLib-GIO-ERROR **: 14:40:51.399: Settings schema 'org.gtk.gtk4.Settings.FileChooser' does not contain a key named 'view-type'

Running the following command shows that the key does exist:

cat /usr/share/glib-2.0/schemas/org.gtk.gtk4.Settings.FileChooser.gschema.xml | grep "view"
 <key name="view-type" enum="org.gtk.gtk4.Settings.FileChooser.ViewType">

Hi @Yiannis128,

Almost looks like the gtk4 GObject-based multi-platform GUI toolkit is missing, if I’m correct. I use KDE, and I have it installed:

$ pamac search 'libgtk'
gtk4                                                                                                                                                                                                                      [Installed] 1:4.8.3-3       extra
GObject-based multi-platform GUI toolkit

…and it’s in the extra repository. So can be installed with:

pamac install gtk4

…or if it is already installed, reinstall it with:

pamac reinstall gtk4 --overwrite='/usr/*'

Followed by a reboot ans seeing if it helps!

Hope it helps!

Hi, gtk4 is already installed, so I ran the command to reinstall it and nothing has changed. The same error.

In that case, I have to be honest with you:


Fs in the chat… RIP