Problems with WPS-office

When starting any of WPS apps they appear only a split second and then they’re gone.

No idea which desktop you use cause you didn’t write that, but in your start menu you have to find out which program is started when you click the menu item. Copy past that into a terminal followed by the enter key. You will then get errors saying what is wrong.
What you also need to do is read this: How to provide good information in your posts and act accordingly. Now it is not possible to give you a good answer to what is your problem.

1 Like

If you just finished an update of the system and you rebooted, yet WPS-Office is not working, since is an AUR package try to reinstall/rebuild as the first time …
Also, if you look at the comments on the AUR page, someone is mentioning almost the same thing
https://aur.archlinux.org/packages/wps-office

I reinstalled it twice, the latest version as well as the older stable version and they both don’t work.

Like Demus said you need be more specific ,

In anyway what i did with wps office (When i used it) was:

Downloaded from WPS Comunnity -->http://wps-community.org/downloads
I downloaded wps-office_10.1.0.6757_x86_64.tar.xz

It is only “unzip the file” and run the file .sh (yes it is writen in bash, works for every distro without special intallation).

If you have KDE and you get to a installer to arch distro you should see it for add to meny entry " -style gtk " so what the software can run.

I hope it help you a bit.

I installed it from the AUR using yay and also from the package manager with AUR enabled. I am using Manjaro Deepin.

All three WPS pgms continue to launch fine here, so it can’t be the pgms themselves that are faulty, presumably.

I reinstalled Manjaro Deepin. Problem is solved.

this is comparable to chopping off a finger when you get a splinter. re-installing for WPS, thats a new one. :rofl:

did you do a clean build?

Oh noooo, so you mean that i could have avoided the situation these days that i have to type with my knuckles? Rats!

2 Likes

If you want to keep your keyboard, don’t try to do the typing with the elbows :see_no_evil:

1 Like

How would one proceed?
If one want to keep his fingers where they are!

(I did try reinstall but not clean build… has you figure I am a NEWB making progress)

I will keep looking on how but clean build on duckduckgo doesn’t seems to give much more of an answer

cleanbuild meaning rebuilding the package you already built previously. anyway if you dont have wps already installed, install it. i just installed with yay, no issues at all.
if you dont already have base-devel and kernel headers installed, do that first.
headers depend on which kernel your using, for example:
4.19 kernel = linux419-headers
5.0 kernel = linux50-headers

sudo pacman -S linuxXXX-headers base-devel yay
yay -S wps-office ttf-wps-fonts

done.

if wps is already installed and your having issues with it, uninstall it first. when you use yay to install it you’ll be asked which packages to clean build like this:

[Aur: 1]  wps-office-10.1.0.6758-1

  1 wps-office                               (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
#Select A for ALL

that will rebuild the packages being installed.