Problems with User rights and write access after replacing /home directory

Do you know a better solution?

Its my first time to make this filesystem changes, im total unexperienced with that.

I just want to have normal access to my homefolder files.
The backup did something wrong here.

I think that simply changing ownership to yourself would suffice. Just because the files and directories were root-owned doesn’t yet mean that the permissions were wrong. Changing ownership to yourself should probably restore everything to how it’s supposed to be.



Make backups including permissions

Make Backups:


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Okay thats good to know. But i just used:
sudo chmod a+rwx /home/koboldx/
Should i revert this? And how do i revert this? if needed.

You restore your backup or leave as is…

Is there a simple command, to revert this command?

Is this a security problem now?

borg extract --list /path/to/my/backup

It’s your home directory: everything should be yours anyway, so: no


Note borg is the backup program that multiple people have pointed you to by now. :stuck_out_tongue_winking_eye:
Note 2: That was your wake-up call to start making backups. Next time you might not get so lucky!


I have actually alot backups, but im still unexperienced with Linux and i used Timeshift backup (including all files).


If you do chmod or chown without -c, it is impossible to revert.
Because there is no log of what changed.

If you do chmod or chown with -c, it is only difficult to revert.
Because it is not easy to revert the actions from the log (,but it is possible).

1 Like

im only did:
sudo chmod a+rwx /home/koboldx/

Then please investigate why the permissions are not in your backup !

A backup without file-permissions is often (!) useless


I just used Timeshift UI and selected backup everything :face_with_peeking_eye:

Hmm if i remember correct, i used copy -Rv command to replace my Homedirectory, maybe that lead to the problem?

Really? And why is that? Atleast my backup replacement finally works now.
Of course its not perfect. But im the only user on my PC/Laptop, is this really a problem for a single?

Because of this?


1 Like

Security is a valuable asset. manjaro takes great care to ensure security. This includes file permissions. Incorrectly set file permissions undermine this security. But they are not an immediate risk.
However, when a computer has been broken into, incorrectly set file permissions may turn a problem into a disaster.

1 Like

Is this also related to the Home and its subfolders/files?

One example:
~/Desktop/*.desktop need to be executable
~/Downloads/* should never be executable


2 posts were split to a new topic: No, please don’t do this?

Here’s a snippet to fix permissions - making files non executable.

find . -type f | sudo xargs -d'\n' chmod 600
find . -type d | sudo xargs -d'\n' chmod 700
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.