Problems with partitioning

I tried to install to Manjaro-Plasma, after booting from the usb, and it wasn’t working.
The given Info is:

Create a new partition table (type: gpt) on ‘/dev/data’

Job: Create new partition table on device ‘/dev/data’

I am sorry for any language-inconveniences, and Thank you for any help, because I am obviosly a Total-Noob.

I would partition as follows:
/boot/efi 300MB VFAT
/boot 1GB ext4
swap same as RAM size
/(root) 100GB ext4
/home 200GB ext4

I assume you have a drive with sufficient size.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Thank you both :smiling_face_with_three_hearts: ,
these are my specs, for more information: its an Thinkpad T470s.

CPU: dual core Intel Core i7-7600U (-MT MCP-) speed/min/max: 800/400/3900 MHz
Kernel: 5.15.50-1-MANJARO x86_64 Up: 4h 16m Mem: 3609.7/23918.0 MiB (15.1%)
Storage: 0/491.39 GiB Procs: 214 Shell: Zsh inxi: 3.3.19

Just in the terminal? or where?
I suppose my drive is big enough with its 500 gb.

I think this could be Important, that I had some problem with the Distro before, which was Ubuntu 22.04,
At some point it wasn’t booting just a failing-message, and I looked it up, it was kind of common I guess, it was a Problem with the File system, and I had to run Fsck manually, I tried it but I failed. :sweat_smile:
Because of that I decited to try out some other Distro (I have this laptop since 3 weeks or so, because of that the losing of my data wasn’t a problem for me.).
I just randomly tryied installing windows, because I wasn’t sure what distro to use yet, and it wasn’t working, because of some Partition-Problem as well.
I read some where, that that booting problem, can be caused of not optimized software, or a not proper shut down.

The thing is, that I had exactly before an issue that I had 3 times before, which was some kind of glitch, where the screen froze, an pink lines on the underpart of the screen.
The first Time it happend, was when I tooked the thinkpad from the Docking Station where an External Monitor was hooked up.
This Monitor has quiet a high resolution, and because of the resolution the overall performance wasn’t as good as on the build in screen, which made me think, that the Gpu was just over overloaded.
I made a restart after that it was normal again.
A few days later, I played quied a long time Half-Life (which is a 24 year old game), and the same thing accured.
It then happend 3 times after that, because I tried it again and again.
The last reboot, it couldn’t boot because of said problem.
After all this happend, I did a complete lenovo diagnosis, and there were no problems.
I hope, I don’t have any mayor issues with the harware, because otherwise I would have to return it, and I really like it.
I thougt that the Problem with the freeze, would maybe caused by the overloaded Gpu.
But according to the Information with the causes, the reasons why the file system problem accured, is not related to the problem I described now, which leaves it as an ongoing Mystery.
If you could help me with the whole situation, I would be really relieved.
(also this might be really important)

It could be simply due to this:

when you boot your live iso, that you want to install from
your disk(s) get recognized and automatically mounted

which then in turn prevents the installer
to make actual changes to them

solution in this case:
make sure none of the disks you want to install to is mounted

launch the file manager
and unmount the disks/partitions
before you start the installer

… it is a bit speculative - not only but also because of
missing information

… you decided to heavily truncate the inxi output which @andreas85 advised you to provide …

This is what I do with a 512-SSD

BiosGrub-- Unformatted 8MB (Flags and apply the bios_grub flag to it)
(The 8MB partition at the beginning of the GPT drive is for legacy (bios) boot using Grub2.
It should not be formatted. It should be flagged as bios_grub)

ESP = 512MB of fat32 (apply the esp flag)-- set 512MB always SET AS /BOOT/EFI

Root / = 65 gigs = 65000mg (Set as root)

Swap = 8192 MB (Set as Swap)

Home /home= 50 gigs = 52000mg

Data /data= remainder

Timeshift /timeshift 60gigs= 60000mg

I move all folders and my data to the /data partition, and create shortcut to /home for my folders from the /data drive

what can I do to given further information?
And excuse me for my lostness, but do I have to physically remove the ssd? or what do you mean with mounted and unounted.
If you could give me a noob version of your guidance, I would be very gradeful.

I am again sorry for my total lostness, but I don’t know what to do now. :sweat_smile:

I found this message in the “internal-drive”-folder
An error occurred while accessing ‘MANJARO_KDE_2132’, the system responded: The requested operation has failed: Error mounting /dev/sda1 at /run/media/manjaro/MANJARO_KDE_2132: /dev/sda1 already mounted or mount point busy

I guess, this could be very useful.

this is confirming that the issue is with what I said.

I could - but I won’t.

This is basic stuff you can google yourself.
I told you how to check (using the file manager).

We where all new at one point - the info is out there, easy to find.
I’ll not be your relay to a search engine interface :wink:

ok, thanks. :smiling_face_with_three_hearts: