Problems with LUKS+LVM installation with manjaro-architect



Hey together,
I try to install LVM on Luks with KDE minimal systemd on a x230 with legacy boot.
But in the end it will not boot!
Can somebody help me?

I found already bugs in the installer.

  1. When I open an already existed Luks partition and I delete the volumegroup and create an new one. The installer hangs when I create new logical volumes. When I press ctrl+c it says the logical volume is created succesfully. And it ist!
  2. When I have to choose the locale I can press space or enter key and it dissapears like I chose already something, but I get no feedback at all. When I set the timezone architect asks me if this is the one I want to choose and I confirm. I like this much more!
  3. According to the arch wiki the /etc/mkinitcpio.conf is not created correct. I had to add “encrypt lvm2” manually

And my problem is, that I don’t know if I have to add “sd-encrypt sd-lvm2” or "encrypt lvm2"
Would be awsome if somebody could help me with my installation.
After several tries without luck, I’m at the point where I have to review my config files.


Installation with Manjaro-Architect ISO

Thank you. I’ll check these things.
Unfortunately I have zero experience with luks and lvm. Where are the experts here?


For everybody who wants to know. Wehn you use systemd + luks + lvm2 like me you usually need following hooks in mkinitcpio

base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt sd-lvm2 filesystems fsck


I think the file /etc/crypttab is also not generated correct from architect when you install lvm on luks + systemd.


As of now the installer doesn’t even touch /etc/crypttab :wink:
What is it that needs to be changed there according to the information you found?



It should look like this:

# Mount /dev/lvm/swap re-encrypting it with a fresh key each reboot
 swap	/dev/lvm/swap	/dev/urandom	swap,cipher=aes-xts-plain64,size=256

# Mount /dev/lvm/tmp as /dev/mapper/tmp using plain dm-crypt with a random passphrase, making its contents unrecoverable after it is dismounted.
tmp	/dev/lvm/tmp	/dev/urandom	tmp,cipher=aes-xts-plain64,size=256 

# Mount /dev/lvm/home as /dev/mapper/home using LUKS, and prompt for the passphrase at boot time.
home   /dev/lvm/home


Thank you. About mkinicpio entries and crypttab this is already very helpful information.

Regarding locales:
Hitting [Enter] will of course use the currently highlighted entry, just like everywhere else in the menu and if the user should be in doubt about having made the right choice he can just revisit the entry. So I don’t see a problem there. I already find the feedback and double confirmation for the time zone a little superfluous and I’m not really happy about introducing this also for the locale. I was in fact already thinking about removing it for the timezone :wink:

When I hit [Space] I get this:


@john-soda I’ve reworked the lvm menu. Some things were just not right there :wink: Creating, deleting, naming, sizing of groups and LVs should now work properly (with the next update).
One bug was that the changes to mkinitcpio.conf were simply not applied although already accounted for.
However we still have encrypt and lvm2 hooks there instead of the systemd hooks you suggest. The link you posted is talking about a specific situation and a combination with hibernation, not that the sd- hooks would be absolutely necessary. It would certainly make the installer’s live easier if we could keep traditional hooks (thinking of openrc and additional bootloader adjustments needed …) … ?

Regarding /etc/crypttab: How exactly did you determine your entries there and what would be a possible global procedure? We just need to find a way to write a config based on what the installer can know about the existing install, if you see what I mean :wink:
Your advice after your fresh experiences will be much appreciated! :slight_smile:


I still have no working systemd lvm on luks installation, but I read a lot in the arch wiki and I think it depends on the case but it can get really complex.
My case is not this difficult, because I use lvm on luks on only one hard drive.

I will try the updated installer on the weekend again, and then I will write you a longer message. Because I don’t have time to do it before.
In short: if you use lvm and luks together you need to modify mkinitcpio and you have to set kernel parameters in the bootloader.

About crypttab: "Note: When using systemd-boot and the sd-encrypt
hook, if a non-root partition’s passphrase is the same as root’s, there
is no need to put that non-root partition in crypttab due to passphrase

and then there are two special cases:

Thanks for this great installer. Will write you again on the weekend

PS: don’t forget the mkinitcpio hooks are worked off in order. This means:

  • lvm on luks need “encrypt lvm2”
  • luks on lvm need "lvm2 encrypt"
    and if you want to use resume for hibernate you need for lvm on luks "encrypt lvm2 resume"
    and if you want that systemd is handling this stuff what is (I think) recommended you need “systemd sd-encrypt sd-lvm2 resume”


Ok. Thanks! If there’s no updated stable package available, yet for your next try, please use the manjaro-architect-dev package on unstable branch and launch the installer directly with manjaro-architect, so you will really get the adjusted version.


Up to now, I used the manjaro-architect-dev.iso from here
and only typed in setup with established internet connection. Will I get there the adjusted version?


I’ll update to 0.8.6 soon, tomorrow hopefully. Then you will get it like that :slight_smile:


I tried only for testing uefi boot with automatic partitioning and here is also a bug!
The installer has to recognize that the computer is using uefi, which I think, it does not.
Because it creates a 512MiB ext2 boot partition with boot / esp flag but it has to create a 512MiB (at least 256MiB) fat32 boot partition with boot / esp flag.

More I hope I can test later. But at the moment I’m really short on time!


The installer recognizes that I have an efi system because later after manual partitioning of efi partition he asks me to point to the efi partition when I do the mounting.


This bug is still present for


If this is correct

The installer should ask me for the /boot partition when I use LUKS encryption.
And should give the advice that the boot partition has to be not inside the LUKS partition.
See also

And if I use my 5GHz wifi on my x230 (it’s an Intel 6205 wifi card) it says “connection could not be established” or something like that. But it is connected/activated.


After I rebooted my whole system I opened my luks partition and deleted all vg and lv and started to create new ones. The first entry went fine, the second and third entry showed my only a “has been created” after I press ctrl+c.
So the bug hast definitely to do with the delete vg lv entry.
Only if I use “delete all” or (“delete vg” this I did not try) it happens that I have to use ctrl+c otherwise it hangs.

And in my opinion there should be an option to list the already existing volumegroups and logical volumes.

Ok, enough testing for me today!


The architect installer is at the moment not usable with bios or efi boot together with systemd and lvm on luks.


Made a last attempt.
And deleted all vg* lv* and so on and then rebooted my system.
Opened my Luks partition and created new logical volumes. When I created the 4th volume the system was hanging again and I had to press ctrl+c again.


Ok made another attempt.
in the grub.cfg file there is this entry missing for luks on lvm