Problems with copy pasting after Feb 19 update

#1

After installing latest update push for Manjaro, I am facing a peculiar copy pasting problem in copy pasting text from Kate to Libre Impress (also sometimes in Libre Writer). None of the copied text appears on Impress. Also sometimes, Impress exits abruptly…

Are any of you facing similar problems?

1 Like
Odd clipboard behavior
#2

KDE Plasma?

export SAL_USE_VCLPLUGIN=gtk3; libreoffice 

May solve.

#3

Yes KDE Plasma…
Thanks it worked (at least to some extent) … But still auto resize on paste is not working.
However I am facing no problem whatsoever with Libre Calc…

#4

Thank you! It helped!!!

#5

But not everything :frowning: Still can’t copy in Libreoffice and paste in Firefox :frowning:

#6

You can choose to use libreoffice-still instead of fresh if you like.
(upstream is aware of the issue, but fixes arent here yet)

2 Likes
#7

Thank you! I have to use copy and paste without any troubles so decided to downgrade to libreoffice-still and waiting for errorless version :slight_smile:

#8

:slight_smile: glad you are glad.
… I’m not sure, but I think I will mark ‘still’ as the solution this time.
[in the future you can do this yourself by hitting the :ballot_box_with_check: button under a post]

#9

Ok. It’s cleare

#10

Unfortunately still the same problem after last upgrade: KDE + Libreoffice 6.2.1.2
Can’t paste from Firefox to LO. Horror!

#11

Yaaa, it is a horror :frowning: you can use gtk3 LO:

SAL_USE_VCLPLUGIN=gtk3_kde5  libreoffice --writer

#12

Thanks! Now it works.

#13

What about personalization in LO? It seems that only builtin themes are working. Firefox themes are death :frowning:

#14

The horror!!! :scream:

#15

So what does this do exactly? Thanks!

#16

Changes the default LO Visual Component Library - if you use Plasma (KDE), LO works on dedicated KDE5 VLC (and because of this, the app looks like qt5/kde5 app), but since some version, this component has a bug - a temporary solution is use another VLC.

#17

Thank you!