Problems with building bspwm-mate iso

Hi there,

linux-aarhus has written here that you can build your own bspwm-mate iso, this doesn't work.

I get the following error:

[hpcompaq6005 thomas]# buildiso -fp bspwm-mate
==> ERROR: bspwm-mate is not a valid profile or build list!
==> ERROR: Profile [/usr/share/manjaro-tools/iso-profiles//bspwm-mate] sanity check failed!

Is bspwm-mate not available anymore, or am I simply making a mistake?

It appears to be still valid, did you clone the iso-profiles and edit your config?

Try watching this for a full explanation from philm

A valid profile consist of a number of files and folders - some are symbolic links some are not.

It is an old profile - maintenance are to be expected.

Is there another step I would need to take except those you wrote in the other post mentioned in the OP?
Because I get the same error with xfce, which is certainly not old, being the flagship of Manjaro.

I simply did what you wrote. Complete newbie here, concerning packaging...

It looks like it is looking in the profiles at /usr/share/manjaro-tools/iso-profiles//bspwm-mate

I am guessing that isn't where you cloned the profiles to.

Did you watch the video which goes through what you need to do step by step?

I just noted - manjaro-architect profiles.

You will have to use the master branch.

For simplicity you can do before
buildiso -i this command download the iso-profiles and when report an issue with buildiso please use
-qv flag and past the result to debug your job :wink:

Seems to work now. - Created a folder in my ~ and tried again.

Will post if there're problems.

1 Like

Oh yes, that's true:

Quite many. - The files really seem to be old.
But I like adventures, as linux-aarhus has put it so nicely, so trying anyway. :smiley: :wink:

OK where would I need to change something that it works?


==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/initramfs.img
==> Image generation successful
cp: cannot stat '/var/lib/manjaro-tools/buildiso/bspwm-mate/x86_64/bootfs/boot/amd-ucode.img': No such file or directory
==> ERROR: A failure occurred in make_image_boot().
--> overlayfs umount: [/var/lib/manjaro-tools/buildiso/bspwm-mate/x86_64/bootfs]

EDIT: Sure that bspwm-mate still can be build? @linux-aarhus It says on branch master, as well as on branch manjaro-architect:
This repository has been archived by the owner. It is now read-only.
(See also my error-message above I get when trying to build it. Cleaned the packages, but I can't build it anyway, since there's a problem with amd-ucode.img)

Just ensure the package amd-ucode is in Root-Packages

1 Like

OK will try in the evening. - I'm just on another computer. Thank you

Wow, amazing. That really worked:
Bildschirmfoto vom 2020-05-15 16-15-31

Good news first: the iso is installable.
Bad news: everything is broken, you get a standard mate, as well as an empty bspwm. :smiley:

I think we call that 'vanilla' :wink:

yep. - didn't change much though in the package-list, commented only the packages out that don't exist anymore...

Project not successful you could say.

Hopefully you as maintainer of bspwm will be more successful than I was. :wink:

To clarify; You were successful. The installs aren't broken, they are simply 'vanilla' or stock versions of mate/bspwm.

1 Like

I cloned them from Manjaro's github. - Were they made vanilla? :thinking:
There's been a bspwm-mate edition once. so... Or do I simply not get the idea of packaging yet, and I'd needed to do something first before building.

I'm not sure what the standard for that edition is. I would check your packages and dot files against the iso-profile and desktop-settings pkgs for bspwm-mate on the manjaro gitlab.

Forum kindly sponsored by