Problems with AOM and after system update

I’m having an issue with one of the latest updates…on KDE/Plasma.
I made a post in the latest “update thread” but it was suggested to me that it might be good/better to make a separate post about the issue.
So I’ll just quote my own post here.

This issue presented itself after the 2021-04-09 update. I figured I’ll just give it a couple of days to try to figure it out or maybe an update will roll out. But since there hasn’t any fixes or solution out, or I couldn’t find any after looking around. I thought it’s time to make a post, but the thread for the last update is closed, so I’ll post here.

The problems I’m having is when trying to start applications that are dependent on the aom package for AV1 codec.
So far I’ve seen it on digikam, ksysguard, kdenliva and cantata, mpv with celluloid and also having problem viewing some online content.
And the error message I get if I try to start the applications from the terminal is the following:
[application name]: error while loading shared libraries: cannot open shared object file: No such file or directory

I have tried to:

  1. Reinstall aom
  2. Removed aom and build/install aom-git
  3. Reinstall the applications that are affected both standard and building git-versions of them.

I have tried to search and find solutions but to no avail.
The only thing that works is downgrading aom all the way to version 2.0.2-1
I did find this bug report for Arch Linux.

This is working for me for now. But long term, this is a dealbreaker, regardless of where the problems lie or who’s fault it is. I need to trust that the media and codecs are working without any stupid problems like this, for my work.

Any suggestions as to why this happens and maybe a possible fix ?

Apparently you’re dealing with Google here, so good luck trying to file an application bug with a library developer.

The best thing to do would be for you to file an application bug (one of digikam, ksysguard, kdenliva and cantata, mpv with celluloid) and the application developer filing a bug with the library developers, unless you’re a developer yourself and can trace back where exactly in the LIB the error sits.


1 Like

First of, thanks for taking the time to answer, much appreciated.

OK…sure, but how could it be that so many others who use those packages doesn’t seem to be affected ? (Not suggesting that should have the answer…I’m just "thinking out loud).
I didn’t choose to install the aom package it must have been installed as a dependency. Those applications that are dependent on aom doesn’t start at all, dead in the water, so to speak, without (aom)

If there is a bug that causes this it should affect MANY more !

Nah, it’s probably a side effect of mixing bleach and ammonia in the toilet to clean it better and then you get poisonous Chlorine gas! So stop mixing both! so file a bug yourself…


The latest Manjaro aom package provides

and no longer, hence the error message. What is strange is that the applications you mention should not request specifically. On my system digikam and ksysguard work fine with

Are you sure that they are all fully updated? Can you check the output of ls -al /usr/lib/libaom* and ldd /usr/bin/digikam | grep libaom?

Well as sure as I can be I guess.
I do my updates manually anything between 1-3 times a week.
And I did it just now before trying your commands.

Her’s the output of ls -al /usr/lib/libaom*:
lrwxrwxrwx 1 root root 11 Feb 11 23:23 /usr/lib/ ->
lrwxrwxrwx 1 root root 15 Feb 11 23:23 /usr/lib/ ->
lrwxr-xr-x 1 root root 6841608 Feb 11 23:23 /usr/lib/

And here’s the output of ldd /usr/bin/digikam | grep libaom: => /usr/lib/ (0x00007fb4437df000)

As said before I order for the applications to function I’ve had to downgrade aom till version 2.0.2-1.

OK but to resolve the issue you should document the issue, not the working workaround.

You should also share the installed versions of packages that cause problems (Digikam, Ksysguard, etc.)

Your system is partially updated, changed mirror and update again

mpv is compiled against libaom 3 here

1 Like

Exactly what do you mean by documenting ?
Do you mean filing a bug report ?
Otherwise, there is not much to document.
I updated my system the usual way (sudo pacman -Syu) and after a rebot applications stopped working, end of story.

Affected package versions I’ve come across so far as follows:
Digikam 7.2.0-1 (from AUR without akonadi,mediawiki,vcontacte)
But I have also tried the latest one from official repos 7.0.2-3
Ksysguard 5.21.4-1
Kdenlive 20.12.3-2
Mpv 1:0.33.1-1 (Celluloid 0.21-1)

This is so far from the individuation for the problem, which is a mismatch between between compiled programs and underlying library that they need.

Nothing to do with both of the upstream projects.

Given that the programs come from official repository, this is a partial update (unless something slipped in Manjaro update process but is not the case)

Digikam will need to be rebuilded after the update

Prefer -Syyu options

1 Like

I’ve done that 3 times, ones after every downgrade of aom.
None of the applications or versions of the will work.
The only thing that works is when I downgrade aom to 2.0.2

I usually do that to. But when I point that out, a lot of times I get bashed about it and people telling my that I shouldn’t be doing that way.

I’ve just now changed the mirror list from “worldwide” to Sweden (where I’m located), German, Switzerland, Danish, Norwegian and back to worldwide. After every time refreshed the database and even done a fast track of the 5 fastest servers. Nothing gets further updated.

I’ve also tried to manually uninstall and reinstall every affected application after every rebuild of the database.

I use only mirrors from Germany (which are relatively near)

The mirrors you are using are actually updated?

 $ pacman-mirrors
 Pacman-mirrors version 4.21.0
 Local mirror status for stable branch
 Mirror #1   OK  01:53   Germany
 Mirror #2   OK  00:53   Germany
 Mirror #3   OK  01:53   Germany
 Mirror #4   OK  00:03   Germany
 Mirror #5   OK  00:03   Germany
 Mirror #6   OK  01:53   Germany
 Mirror #7   OK  00:13   Germany
 Mirror #8   OK  00:03   Germany

Do you have chromium-90.0.4430.85-0.1 firefox-88.0-0.1 in the repository right now?

Ok but it is really needed when you change mirror

As far as I can tell, YES !

Yes and Yes.

Maybe some database issue, I would suggest do those steps:

  1. delete pacman db:

    sudo rm -r /var/lib/pacman/sync/core.db
  2. restore pacman db:

    sudo pacman -Syy

and then pacman -Syu or pacman -Syyu


Thnx for taking the time…much appreciated.

Tried that as well, but no change, didn’t trigger any updates.

Weird. This is clearly an issue only on your system and looks like an obvious case of partial update, yet the usual solutions aren’t working. Hmm…

Try command to re-install all native/repo packages:

sudo pacman -Qenq | pacman -S -

Hopefully this command still works. It changes sometimes.

Also, check if you haven’t made any manual changes, namely, if you haven’t created a symlink to this old library that is causing issues now.

1 Like

Same here, happened randomly after a system update, tried all of the above and nothing fixed it.

What did help was removing a custom dependency (ffmpeg libfdk_aac) …