Problems starting new microsoft flight simulator

Hey all,

I recently purchased the new Microsoft flight simulator, game of the year edition on steam. The game appears to start up when using Proton Experimental and adding "-FastLaunch " in the games properties. However I then run into an issue, after signing into a Microsoft account the game would just crash whenever I hover my mouse over any option in the game accessibility configuration screen to change the settings, which is odd.

I tried changing kernels, making sure the driver is up to date and messing around with the launch options but I cannot seem to get the game working as intended.

What I am running:
Kernel 5.15 xfce
Ryzen 5 5600x
RTX 3060
16gb 3600mhz ram

Do you have Windows installed, too ?

Unfortunately no, It would probably be easier to just dual boot, however users on protondb have mentioned getting it running easily on manjaro no issue… so I am not sure if anyone else has had simular issues and figured out a solution, or if its just a problem that I cannot fix right now.

After reading the protondb I would rather say that any online activity including sign in, cloud sync, multiplayer does not work correctly. Never played that game, but is it possible to play it without an account in single player mode?

Nah its forcing me to sign in with an xbox account to continue.

signing in works, and then it takes me to this “choose your settings” screen or whatever, and it seems to crash whenever I hover over any button or slider… but leaving the mouse on the side or scrolling with the scroll bar is perfectly responsive. Tried clicking “next” to possibly skip this part, however hovering over the “next” button does the same thing before I can even click it, crashes the game.


  1. Do run it in dx11 mode or dx12?
  2. Did you disable steam cloud sync for that game?

I tried changing between dx11 and dx12 however both show the same results, I also have disabled all syncing to the cloud as people said that that’s what they had to do to get it running.

Something I do have is another PC, with different specs… I could try to see if it runs as expected on there and see if it could potentially be a driver issue with my system.

Then please run it with these startup options:


and then share the log here, located in your home directory.

I saw a file mentioning microsoft flight simulator often, i’m no linux expert but I believe this may be the one.

In any case, Flight Simluator crashed and I suspect that a dependency or DLL is missing or buggy.

It is best to delete the Proton prefix. It can be found under compatdata in the Steam directory.


And then run it again. It recreates the directroy from scratch.