Problems installing Manjaro on Toshiba Satellite Pro C50A

I‘ve just got a Toshiba Satellite Pro C50A which came with Windows 10 pre installed.

I‘m installing Linux onto this laptop for a friend who‘s technophobic, schizopjrenic, and on medication. One of the main uses, if not the main use will be to watch downloaded videos and/or streaming videos.

Unfortunately, when I first got this laptop, there were problems with the DVD drive and it seemed that Windows 10 was making life difficult as well. The DVD drive wouldn‘t boot up from any Linux Live DVDs, although it displaed their contents on the Windows desktop. Eventually, it started ejecting all DVDs, saying “Please insert a disc“. I bought a DVD cleaner disc and cleaned it, but this made no difference. I tried to clean it again, but it just ejected the disc!

I‘ve since been given a replacement DVD RW drive by the seller.

Before I fitted the replacement DVD drive I felt I had to stop Windows from starting up by pressing the Power button. I wasn‘t sure exactly what was happened with the Linux Live DVDs I was trying to boot from. This may have caused problems later.

After fitting the new DVD drive, things improved. The DVD names and contents were displayed on the Windows desktop. However, however when I tried to boot up from any DVD it always stopped at some stage. The error messages displayed were “The disk contains an unclean file system (0,0). Metadata kept in Windows cache, refused to mount“ that the Windows NTFS file system was in a unsafe state because Windows hadn‘t closed down properly. It demanded that I restart Windows, login, then close down, not us sleep mode or hibernation. I hadn‘t done either of those things anyway! It also recommmends me running chkdsk /r . I‘ve done this, let it run for over 90 minutes, until it said it was fixed, but it made no difference! Since then, it‘s even asked to do it again, and was scheduled to take 4-5 hours, so then I just stopped it! This Windows installation has just one user account called “User“ which logs in automatically as it starts up. I don‘t know if there‘s a password. After starting up and closing down Windows I keep getting the same error message! Not only that, but there‘s another error message that won‘t go away. This says “USB read error -22“. According to another message, this is caused by unplugging a USB device without first selecting an option to safely remove it. I haven‘t even done this and don‘t know how this message can keep coming up after so many reboots, especially before booting into Windows!

1 Like

Hello there!

Uhh.. Why can't you just make a USB drive bootable with a Manjaro ISO using Etcher?

Go into BIOS and turn off secure boot, fast boot, and CSM.
It'll probably be in security or booting section of the BIOS.

The system won't let you boot with unclean Linux software. You can thank Secure boot for that.
:slightly_frowning_face:

I haven't got a USB stick available at the moment. Why would I need to do that? I want to put lots of stuff onto the 500Gb hard drive anyway!

From what I can see this is a NON UEFI BIOS! There's nothing like that under either Security or Boot. Pressing F2 just after the Power button brings up a familiar screen. At the top it says "Aptio Setup Utility - Copyright (C) 2012 American Megatrends, Inc". Windoze 10 has just tried to start up again while I was pressing F2. I saw during one session only that the hard drive has not only a C: partition, but also another called something like "System Reserved Disk". Perhaps I should download and burn a DVD of Puppy Linux or Knoppix.

Because a USB can be more reliable than a media that is from the 1990s haha

Worth a shot, just try a USB

ActuallY, DVDs and USB sticks are BOTH from the 1990s!

:expressionless:

Yes:

Essentially, you've broken Windows through multiple hard power-off operations, and then broken it even more even more by

I recommend you fix Windows, e.g. via a system restore or full reinstallation, before doing anything more with Manjaro.

That is, get your PC into a known working state before going any further.

This isn't a Windows support forum so you may have to ask elsewhere for more information about how to fix Windows.

Once you have a working system PM me and I'll re-open this thread.

2 Likes

Forum kindly sponsored by Bytemark