Probleme mit dem Appimagelauncher


#1

Hallo!
Ich habe mal Freecad als Appimage runtergeladen und nach dem ersten Start wurde es installiert.
Ich kann über das Startmenü => Anwendungen => Grafik darauf zugreifen und es funktioniert.
Soweit so gut.

Jetzt hätte ich gern einen Link auf der Arbeitsfläche.
Wenn ich unter Startmenü => Anwendungen => Grafik einen Rechtsklick auf Freecad mache wird angezeigt “Zur Arbeitsfläche hinzufügen”. Wenn ich es anklicke bekomme ich eine Verknüpfung auf die Arbeitsfläche.

Beim benutzen dieser Arbeitsfläche kommt aber ein Feld mit Optionen, anstatt des Programms, hoch.

Da ich nichts fand um ein Bild anzuhängen habe ich eine Link hier:
https://www.bilder-upload.eu/bild-ea168b-1550418328.png.html

Wie kriege ich es hin das der Link auf der Arbeitsfläche gleich Freenet startet.

MfG R.Lehmeier


#2

Hallo R. Lehmeier,

Das ist eine Fehlermeldung, daß die Option --instance offenbar mehrmals angegeben wurde:
“option --instance cannot be specified more than once”
Also sieh mal nach, was in der Desktop-Datei steht. Benutze kein KDE, aber nehme an, daß dort die Datei auch freecad.desktop heisst und darin wahrscheinlich eine Zeile so aussieht:
Exec=freecad --instance --instance
bzw. bei Exec die Option --instance in irgendeiner Weise mehrfach vorkommt.

viele Grüße gosia

PS.
wenn du magst, kannst Du hier
https://www.manjaro-forum.de/viewtopic.php?f=12&t=2019
Miners erklären, wie Du FreeCAD zum Laufen gebracht hast. Er hatte dort Probleme FreeCAD zu installieren.


#3

Das scheint es nicht zu sein ich finde keine solche Anomalie : https://www.bilder-upload.eu/bild-b2604c-1550503594.png.html

P.S:
Miners habe ich einen Vorschlag gesendet - vielleicht hilft es ja.


#4

Hallo R.Lehmeier,

ich hab versucht herauszufinden, was --single-instance eigentlich macht. Dabei bin ich auf folgenden (englischen) Forumthread gestoßen:
https://forum.freecadweb.org/viewtopic.php?t=27784

Anscheinend dient die Option dazu, zu erzwingen, dass immer nur eine Instanz von freecad läuft. Ich denke dabei beim Suchen der Instanz geht etwas schief. Wenn du darauf verzichten kannst über den Starter immer auf die selbe Instanz von freecad zuzugreifen, kannst du die Option entfernen und ausprobieren obs dann vielleicht klappt.


#5

Ich habe bei dem Link auf der Arbeitsfläche die “Eigenschaften” geöffnet und dort unter “Programm => Befehl” den Anhang " --single-instance %U" entfernt.

Jetzt startet sie einmal, beim nächsten Start ist der Eintrag wieder da und somit auch die Fehlermeldung.


closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.