Problème matériel intempestif avec touche tactile "Windows" sur ThinkPad Yoga15 (convertible tablette)

gnome

#1

Bonjour aux utilisateurs de Manjaro, je suis assez nouveau sur cette distrib, donc pas encore mes marques.
Je cherchais une machine pour faire de la régie spectacle, son et lumière, donc quelque-chose de stable et robuste.
J’ai donc récemment acheté d’occasion cette machine (ThinkPad Yoga15) qui était sous Win10, et lors de son essai, j’ai remarqué ce problème assez gênant car intempestif et imprévisible :
En pleine utilisation, de n’importe quel programme, l’écran se met à vibrer (eh oui, Lenovo a eu la fabuleuse idée de mettre un vibreur dans l’écran de cette machine convertible) et passe en “aperçu des activités”, comme si j’avais appuyé sur la touche “super”, et qui vient donc couper tout application en cours d’usage.
Je me suis dis ensuite qu’une fois passé sous Linux, je ne serai plus embêté par ce satané bouton tactile Windows placé juste sous la dalle de l’écran !

iu

Mais en vain, une fois manjaro installé, le problème persiste, et pas d’une moindre manière car il arrive que l’action “super” + vibreur se déclenche 5 à 6 fois en l’espace de 10sec sans que je ne touche à rien. Il arrive même que le vibreur reste actionné pendant plus de 30sec parfois, avec le désagrément sonore qui l’accompagne. Le seul moyen de l’arrêter momentanément est d’appuyer sur cette fameuse touche tactile Windows, et n’empêche pas que ça recommence 10sec après…

Voilà la situation, et je suis un peu dépourvu de solutions. J’aimerais trouver une possibilité logiciel de désactiver complètement l’usage de cette touche, avant d’avoir recours au fer à souder pour la dézinguer, ce qui ne m’enchante guère plus, vu les possibilités de démontage de la dalle.

Je vous remercie d’ores et déjà pour vos réponses et suggestions. Au plaisir de vous lire.
Florentin


#2

A ce que je lis, il semble que cette “fonctionnalité” en énerve plus d’un, et difficile en effet de trouver comment le désactiver. La piste la plus proche que j’ai pu trouver concerne un Yoga 2 sous Windows: https://www.reddit.com/r/24hoursupport/comments/4bgsmn/laptop_randomly_vibrating_lenovo_yoga_2/

J’ai cherché rapidement pour une documentation ou des paquets qui pourraient aider sur ce sujet, mais je n’ai rien trouvé. Désolé de ne pas être d’une grande aide. :pensive:


#3

Pour la partie vibreur je doute qu’on puisse faire quelque chose au niveau de l’OS, si c’est le bouton qui physiquement fait le gogol :unamused:. Mais bon ça coute rien d’essayer.
Pour la partie touche “Super” par contre on doit pouvoir ignorer l’évènement:

  1. Cette commande affiche la liste des “devices” en input:
libinput list-devices
  1. Cette commande va afficher tout ce qui ce passe au niveau des entrée en temps réel:
    Une ligne par evenement, ne déplace pas ta souris si tu veux pas faire un carnage :smiley:.
sudo libinput debug-events
  1. Faudra que tu isoles la ligne correspondant au fameux bouton tactile vibromassant.

  2. Tu pourras normalement pondre un fichier Xorg pour ignorer l’évènement.


#4

Désolé d’avoir trainé à répondre, j’ai chopé un état grippal entre temps.
Merci Maycne pour ta réponse rapide, et je crois qu’on tiens un truc avec YoyO.

Du coup, j’ai fais ce que tu m’as suggéré, et en retour de libinput debug-events, j’ai eu ces lignes :

-event0   KEYBOARD_KEY     +14.99s	KEY_LEFTMETA (125) pressed
 event0   KEYBOARD_KEY     +15.01s	KEY_LEFTMETA (125) released
 event0   KEYBOARD_KEY     +17.06s	KEY_LEFTMETA (125) pressed
 event0   KEYBOARD_KEY     +17.07s	KEY_LEFTMETA (125) released
 event0   KEYBOARD_KEY     +220.31s	KEY_LEFTMETA (125) pressed
 event0   KEYBOARD_KEY     +220.32s	KEY_LEFTMETA (125) released

“event0” correspondant à :

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event0
Group:            8
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Cependant, je ne sais pas encore ce qu’est un fichier Xorg, peux-tu m’en dire plus ?
Merci YoyO


#5

Je suis pas un grand maître XorgFu mais normalement en créant ce fichier, ça devrait le faire:
(NB: Tu peux changer le nom du fichier mais garde la structure XX-foobar.conf, les chiffres déterminent l’ordre de “chargement”.
Idem pour la section Identifier.)

/etc/X11/xorg.conf.d/70-vibromasseur.conf

Section "InputClass"
        Identifier "CaresseMoiLEcranCaMeFaitVibrer"
        MatchDevicePath "/dev/input/event0"
        Option "Ignore" "on"
EndSection

man xorg.conf.d si tu veux de la lecture :stuck_out_tongue_winking_eye:.