Problème de sons (dummy input + micro qui ne marche pas) depuis l'installation de Manjaro (Acer Swift 5)

Bonjour,
J'ai récemment installé Manjaro (a coté de Windows et Kubuntu) et j'ai le son qui ne fonctionne pas du tout.
En fait depuis que j'ai commencé à etre sur Linux (il y a environ 10 mois), j'avais des problèmes de sons sur ubuntu déjà, et j'ai le micro qui ne marchait pas du tout depuis le début. J'ai essayé de nombreux tutos et discussion un peu partout, mais je n'ai toujours pas réussi à comprendre et régler mon problème.
Je suis assez débutant avec Linux (je connais pas le fonctionnement des différentes commandes), je souhaiterais comprendre et etre autonome, donc est-ce que vous pouvez expliquer ce qu'il faut faire et pourquoi ?

peux tu nous fournir

inxi -Fxxxza

lance pavucontrol , et verifie la liste materiel
et il y a alsamixer pour verification du son

@stephane

inxi -Fxxxza

donne :

System: Host: RS-Manjaro Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=5e59daff-9c9f-4a39-b30d-47fe83cf471c rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: Acer product: Swift SF514-53T v: V1.05 serial:
Mobo: WL model: Carlsberg_WL v: V1.05 serial: UEFI: Insyde v: 1.05 date: 01/18/2019
Battery: ID-1: BAT0 charge: 24.1 Wh condition: 24.1/36.0 Wh (67%) volts: 8.3/7.7 model: PANASONIC AP16L5J type: Li-ion
serial: status: Not charging
CPU: Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142)
stepping: B (11) microcode: CA L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808
Speed: 2773 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 2773 2: 1183 3: 1461 4: 1728 5: 1000 6: 2187 7: 1587
8: 2513
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3ea0
Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes
Audio: Device-1: Intel Cannon Point-LP High Definition Audio vendor: Acer Incorporated ALI driver: sof-audio-pci
bus ID: 00:1f.3 chip ID: 8086:9dc8
Sound Server: ALSA v: k5.6.16-1-MANJARO
Network: Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3
chip ID: 8086:9df0
IF: wlp0s20f3 state: up mac:
Drives: Local Storage: total: 238.47 GiB used: 52.72 GiB (22.1%)
ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3256GJ1 size: 238.47 GiB block size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: rev: E8FK12.3 scheme: GPT
RAID: Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4060 bus ID: 00:17.0
chip ID: 8086.282a rev: 30
Partition: ID-1: / raw size: 68.36 GiB size: 66.79 GiB (97.70%) used: 49.47 GiB (74.1%) fs: ext4 dev: /dev/nvme0n1p1
ID-2: swap-1 size: 7.45 GiB used: 3.26 GiB (43.7%) fs: swap swappiness: 10 (default 60)
cache pressure: 100 (default) dev: /dev/nvme0n1p6
Sensors: System Temperatures: cpu: 47.0 C mobo: 30.0 C
Fan Speeds (RPM): N/A
Info: Processes: 369 Uptime: 2h 41m Memory: 7.63 GiB used: 4.56 GiB (59.7%) Init: systemd v: 245 Compilers: gcc: 10.1.0
Shell: zsh v: 5.8 running in: yakuake inxi: 3.0.37


alsamixer :

à cause de la restriction des nouveaux sur le forum, j'ai pu poster que le screen d'alsamixer :
pavucontrol :
info-pavu-output

tu as quel choix proposé dans la liste pavuvontrol > configuration ?

1 - a voir pour mise a jour du bios
2 - ajoute le noyau suivant 5.7

sudo mhwd-kernel -i linux57

redemarre , Esc ou F8 ou Shift pour faire apparaitre Grub > details
pour la selection du noyau ( par default il démarre sur celui en * sinon version noyau le plus élevé )

Il n'y a rien dans les configs de pavucontrol :
pavucontrol-config

Je suis en train d'installer le noyau (ce qui me fait un peu peur parce que je n'ai jamais osé toucher aux kernels pour l'instant). Et je redémarre et je te dis.

Voilà j'ai changé de kernel, via les options avancés de GRUB au redémarrage :

Mais pour l'instant c'est toujours pareil.

il y a ce topic

ajoute le noyau 5.4 et redemarre dessus
( a priori 5.6 et 5.7 Ko )

OOOOOOOhhhh, merciiiiiii !!
Y a le son qui fonctionne très bien maintenant ! Donc je note que si j'ai des problèmes de sons, faudra que je pense à changer de kernel.
Par contre le micro ne fonctionne toujours pas (même depuis le début) :

malgré le fait que ça s'affiche comme si ça fonctionnait

(et c'est quoi le rythme des mises à jour environ au fait ?)

les diffusions de noyaux stables sont faite environ 1/semaine
côté manjaro Testing nous les avons entre 1 a 3 jours par la suite
ensuite c'est lié à la fréquence de diffusion en Stable
( 1 a 3 semaines )

tu gardes donc le noyau 5.4 et le 5.7 ,
la version 5.6 peux etre retirer ( fin de vie- EOL )

sudo mhwd-kernel -r linux56

D'accord, merci en tout cas.

Et est-ce que tu sais pour le probleme de micro ?

a priori non résolu sur ce sujet ( évoqué je crois dans mon lien précédent )

Ah oui je viens de voir, je vais voir pour me renseigner alors.

Forum kindly sponsored by