Problemas en tiempo de carga de Manjaro Gnome 18.0.2


#1

Hola. He realizado una instalacion limpia de Manjaro Gnome en mi portatil y tarda muuucho en iniciarse. Como es un problema que ya tuve hace tiempo y que me solucionaron en el foro, “buceando por el foro” he instalado y activado el proceso “haveged”, lo cual ha solucionado el problema, pero me gustaria saber si esto puede venir activado por defecto al instalar la ISO, pq al instalar “haveged” me advierte que ya esta instalado, asi que seria solo activar este proceso por defecto.

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

Gracias.

PD.: Solo me pasa con el portatil con el ordenador de sobremesa, no tengo este problema. Mi portatil:

System:
  Host: atreides-pc Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Gnome 3.30.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP G62 Notebook PC 
  v: 0497100000252710001020000 serial: <root required> 
  Mobo: Hewlett-Packard model: 143A v: 60.21 serial: <root required> 
  BIOS: Hewlett-Packard v: F.0A date: 06/14/2010 
CPU:
  Topology: Dual Core model: Intel Core i3 M 350 bits: 64 type: MT MCP 
  arch: Nehalem rev: 2 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18093 
  Speed: 931 MHz min/max: 933/2266 MHz Core speeds (MHz): 1: 964 2: 977 
  3: 1200 4: 996 
Graphics:
  Device-1: Intel Core Processor Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: AMD Park [Mobility Radeon HD 5430/5450/5470] 
  vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.3 driver: radeon 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.3.1 
  direct render: Yes 
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: 90:fb:a6:a8:06:2c 
  Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network 
  Adapter 


#2

¡Hola @vernius!

Que me corrija algún veterano del foro, pero para conseguir lo que dices debes realizar una ISO personalizada con Manjaro Architect: https://manjaro.org/download/architect/

Un saludo.


#3

Es curioso, por que tanto en una instalación de 1 mes de vieja hecha con el Architect en el sobremesa, como otra de muchos meses en el portatil, en ambos casos me venía con el servicio “haveged” activado por defecto. Eso si, en KDE.

El caso es que mirando en el gitlab en los perfiles de las ISOs es verdad que parece que no esté puesto por defecto en ninguno de los perfiles :thinking:

También es verdad que me hago un lio con el gitlab. Pero vamos si, la solución sería o hacer una instalación personalizada con el Architect (ahora mismo no recuerdo si te deja elegir los servicios en la instalación aunque creo que si), o mejor aún, hacerte tu mismo una ISO personalizada con las “Manjaro-Tools”.

https://wiki.manjaro.org/Build_Manjaro_ISOs_with_buildiso

Sería en principio tan sencillo como editar el profile.conf correspondiente y añadir el “haveged” a los servicios a activar tal y como en este commit antiguo:

Si pilotas ingles aunque sea un poco, Phil hace un videotutorial magnífico al respecto y no es tan dificil: