Problemas con claves PGP

Hola a todos.
Como mi inglés no es todo lo bueno que me gustaría recurro a nuestro idioma para ver si me podéis ayudar.
Llevo un año utilizando Manjaro en su variante xfce en todos mis ordenadores y estoy encantado y aprendiendo continuamente. Nunca más espero volver a usar el sistema de las ventanitas en mis ordenadores personales aunque en el trabajo es lo que hay.
Bueno, no mas rollo y voy al grano:
Salida de consola al actualizar:

Tamaño total de la instalación: 4709,40 MiB
Tamaño neto tras actualizar: 58,41 MiB

:: ¿Continuar con la instalación? [S/n] s
(405/405) comprobando las claves del depósito [######################] 100%
descargando las claves necesarias…
:: ¿Importar clave PGP 428F7ECC7117F726, «Helmut Stult helmut@manjaro.org»? [S/n] s
error: no se pudo buscar la clave «428F7ECC7117F726» de forma remota
:: ¿Importar clave PGP 428F7ECC7117F726, «Helmut Stult helmut@manjaro.org»? [S/n]
Y así en todos los casos. Estoy aburrido de buscar información y no hay manera de solucionarlo. Tengo otros tres ordenadores en casa y no me pasa con ninguno de ellos. O sea que no creo que sea por puertos bloqueados en el router . Todo lo que me podáis enseñar al respecto os lo agradezco

Hi!
Imagino que no es problema de red, entonces puedes probar esto para ver si es cosa de los repositorios o de las claves pgp

sudo pacman-mirrors -f 3 && sudo pacman -Syyu

Esto eligira los 3 mirrors mas rapidos y actualizara tu systema

Hola, prueba a hacer esto:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Hi!
Esa me la guardo!!!

Pues no me funciona. Pongo salida
acer@acer-aspirem3641 ~]$ sudo pacman-mirrors -f 3 && sudo pacman -Syyu
[sudo] password for acer:
::INFO Downloading mirrors from repomanjaroorg
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
0.993 United_States :
0.751 United_States :
1.080 United_States :
0.609 United_States :
1.320 Costa_Rica :
::INFO Writing mirror list
::United_States :
::United_States :
::Costa_Rica :
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Sincronizando las bases de datos de los paquetes…
core 168,8 KiB 657 KiB/s 00:00 [######################] 100%
extra 2013,9 KiB 1711 KiB/s 00:01 [######################] 100%
community 6,1 MiB 2,31 MiB/s 00:03 [######################] 100%
multilib 194,9 KiB 5,60 MiB/s 00:00 [######################] 100%
:: Some packages should be upgraded first…
resolviendo dependencias…
buscando conflictos entre paquetes…

Paquetes (2) archlinux-keyring-20200820-1 manjaro-system-20200723-1

Tamaño total de la instalación: 1,29 MiB
Tamaño neto tras actualizar: 1,29 MiB

:: ¿Continuar con la instalación? [S/n] s
(2/2) comprobando las claves del depósito [######################] 100%
descargando las claves necesarias…
:: ¿Importar clave PGP 8DB9F8C18DF53602, «Stefano Capitani ? [S/n] s
error: no se pudo buscar la clave «8DB9F8C18DF53602» de forma remota
error: la clave necesaria no está presente en el depósito
error: no se pudo realizar la operación (error inesperado)
Ocurrieron errores, por lo que no se actualizaron los paquetes

:: Iniciando actualización completa del sistema…
:: ¿Remplazar intel-tbb con extra/tbb? [S/n] s
resolviendo dependencias…
buscando conflictos entre paquetes…
advertencia: se ha detectado un bucle de dependencias:
advertencia: bashrc-manjaro se instalará antes de su dependencia bash
advertencia: se ha detectado un bucle de dependencias:
advertencia: mesa se instalará antes de su dependencia libglvnd
advertencia: se ha detectado un bucle de dependencias:
advertencia: usbmuxd se instalará antes de su dependencia libimobiledevice
advertencia: se ha detectado un bucle de dependencias:
advertencia: lib32-mesa se instalará antes de su dependencia lib32-libglvnd

Paquetes (406) acpid-2.0.32-2 alsa-lib-1.2.3.2-1 alsa-topology-conf-1.2.3-1
alsa-ucm-conf-1.2.3-2 alsa-utils-1.2.3-2
android-tools-30.0.3-1 android-udev-20200613-1 aom-2.0.0-1
apparmor-2.13.4-6 archlinux-appstream-data-20200720-1.1
audacious-4.0.5-1 audacious-plugins-4.0.5-1 automake-1.16.2-3
babl-0.1.78-1 bash-5.0.018-1 bash-completion-2.11-1
bashrc-manjaro-5.0.018-1 bauh-0.9.6-1 binutils-2.35-1
bison-3.6.4-1 bleachbit-4.0.0-3 btrfs-progs-5.7-1
ca-certificates-20181109-4 ca-certificates-mozilla-3.56-1
ca-certificates-utils-20181109-4 catfish-1.4.13-3
confuse-3.3-1 cups-2.3.3-3 curl-7.72.0-2 dav1d-0.7.1-1
dbus-x11-1.12.20-1 desktop-file-utils-0.26-1 dhcpcd-9.1.4-2
dnsmasq-2.82-2 docbook-xsl-1.79.2-7 ecryptfs-utils-111-4
elfutils-0.180-1 engrampa-1.24.1-1 exfat-utils-1.3.0-2
exo-0.12.11-5 ffmpeg-2:4.3.1-2 file-5.39-1 fluidsynth-2.1.4-1
fontconfig-2:2.13.91+48+gfcb0420-2 foomatic-db-3:20200822-1
fribidi-1.0.10-1 fuse-common-3.9.3-1 fuse3-3.9.3-1
galculator-gtk2-2.1.4-5 game-devices-udev-0.7.9-1 gcc-10.2.0-1
gcc-libs-10.2.0-1 gcolor2-0.4-9
gdk-pixbuf2-2.40.0+6+g5432316df-1 gegl-0.4.24-2 git-2.28.0-1
glib-networking-2.64.3-2 glib2-2.64.5-1 glibc-2.32-2
gnome-desktop-1:3.36.5-1 gnome-icon-theme-3.12.0-6
gnupg-2.2.21-1 gnutls-3.6.14-2 gpgme-1.14.0-1
graphene-1.10.2-1 grub-2.04-11.1 grub-theme-manjaro-20.1-1
gssdp-1.2.3-1 gst-plugins-bad-1.16.2-13
gst-plugins-bad-libs-1.16.2-13 gst-plugins-ugly-1.16.2-4
gtk-update-icon-cache-1:3.24.22-1 gtk3-1:3.24.22-1
gtkhash-1.4-4 gtkhash-thunar-1.4-4 gupnp-1.2.4-1
gvfs-1.44.1-4 gvfs-afc-1.44.1-4 gvfs-gphoto2-1.44.1-4
gvfs-mtp-1.44.1-4 gvfs-nfs-1.44.1-4 gvfs-smb-1.44.1-4
harfbuzz-2.7.1-1 harfbuzz-icu-2.7.1-1 haveged-1.9.13-1
hidapi-0.9.0-2 hplip-1:3.20.6-3 hwids-20200813.1-1
iana-etc-20200812-1 imagemagick-7.0.10.26-1 imlib2-1.7.0-1
intel-tbb-2020.2-1 [eliminación] intel-ucode-20200616-1
intltool-0.51.0-6 inxi-3.1.05+2-1 iproute2-5.8.0-1
iptables-1:1.8.5-2 iputils-20190709-3 iso-codes-4.5.0-1
jasper-2.0.17-1 jdk8-openjdk-8.u262-1 jre8-openjdk-8.u262-1
jre8-openjdk-headless-8.u262-1 json-c-0.15-1 kauth-5.73.0-1
kbd-2.3.0-2 kcoreaddons-5.73.0-1 keyutils-1.6.3-1
kitemmodels-5.73.0-1 krb5-1.18.2-1 kvantum-qt5-0.16.1-1
kwindowsystem-5.73.0-1 lcms2-2.11-2 ldb-1:2.1.4-1
leptonica-1.80.0-1 lib32-alsa-lib-1.2.3.2-1
lib32-dbus-1.12.20-1 lib32-fluidsynth-2.1.4-1
lib32-fontconfig-2:2.13.91+48+gfcb0420-2 lib32-fribidi-1.0.10-1
lib32-gcc-libs-10.2.0-1 lib32-gdk-pixbuf2-2.40.0+6+g5432316df-1
lib32-glib2-2.64.5-1 lib32-glibc-2.32-2 lib32-harfbuzz-2.7.1-1
lib32-keyutils-1.6.3-1 lib32-libcap-2.38-1
lib32-libelf-0.180-1 lib32-libgcrypt-1.8.6-1
lib32-libglvnd-1.3.2-1 lib32-libgpg-error-1.38-1
lib32-libidn-1.36-1 lib32-libjpeg-turbo-2.0.5-1
lib32-libldap-2.4.50-1 lib32-libpng-1.6.37-3
lib32-libva-2.8.0-1 lib32-libva-intel-driver-2.4.1-1
lib32-libva-mesa-driver-20.1.6-1 lib32-libvorbis-1.3.7-1
lib32-libx11-1.6.11-1 lib32-llvm-libs-10.0.1-1
lib32-mesa-20.1.6-1 lib32-mesa-vdpau-20.1.6-1
lib32-nspr-4.28-1 lib32-nss-3.56-1 lib32-p11-kit-0.23.21-1
lib32-pango-1:1.46.1-1 lib32-pixman-0.40.0-1
lib32-sqlite-3.32.3-1 lib32-systemd-246.2-1 lib32-tdb-1.4.3-1
lib32-vulkan-icd-loader-1.2.148-1 lib32-vulkan-intel-20.1.6-1
lib32-vulkan-radeon-20.1.6-1 lib32-zstd-1.4.5-1
libappindicator-gtk3-12.10.0.r296-1 libbytesize-2.4-1
libcap-2.42-1 libcups-2.3.3-3 libde265-1.0.5-2
libebml-1.4.0-1 libelf-0.180-1 libevdev-1.9.1-1
libevent-2.1.12-1 libexif-0.6.22-1 libfdk-aac-2.0.1-2
libfontenc-1.1.4-3 libgcrypt-1.8.6-1 libglvnd-1.3.2-1
libgusb-0.3.5-1 libheif-1.7.0-2 libidn-1.36-1
libimobiledevice-1.3.0-1 libindicator-gtk3-12.10.1-9
libinput-1.16.1-1 libjpeg-turbo-2.0.5-1 libldap-2.4.50-2
liblouis-3.14.0-2 liblrdf-0.6.1-4 libmatroska-1.6.2-1
libmbim-1.24.2-1 libmfx-20.2.1-1 libmicrohttpd-0.9.71-1
libmm-glib-1.14.2-1 libnfs-4.0.0-4 libnftnl-1.1.7-1
libnghttp2-1.41.0-1 libnm-1.26.2-1 libnma-1.8.30-1
libnsl-1.3.0-1 libopenraw-0.1.3-2 libp11-kit-0.23.21-1
libpipeline-1.5.3-1 libplist-2.2.0-1 libpng-1.6.37-3
libproxy-0.4.15+33+g454a499-2 libpurple-2.14.1-3
libqmi-1.26.2-1 libraw-0.20.0-1 librsvg-2:2.48.8-1
libsodium-1.0.18-2 libsynctex-2020.54586-4 libteam-1.31-1
libtool-2.4.6+42+gb88cebd5-14 libusbmuxd-2.0.2-1
libutf8proc-2.5.0-2 libutil-linux-2.36-2 libva-2.8.0-1
libva-mesa-driver-20.1.6-1 libvorbis-1.3.7-2 libvpx-1.9.0-1
libwacom-1.4.1-1 libx11-1.6.11-1 libxcrypt-4.4.16-3
libxslt-1.1.34-5 lightdm-1:1.30.0-4
lightdm-gtk-greeter-1:2.0.8-1 lilv-0.24.8-2
linux-api-headers-5.7-1 linux-firmware-20200817.r1695.7a30af1-1
linux54-5.4.60-2 llvm-10.0.1-1 llvm-libs-10.0.1-1
lmdb-0.9.26-1 logrotate-3.17.0-1 lua-5.4.0-2 lua52-5.2.4-5
man-db-2.9.3-1 man-pages-5.08-1
manjaro-application-utility-1.3.3-1
manjaro-browser-settings-20200629-1 manjaro-release-20.1-0
manjaro-settings-manager-0.5.6-10
manjaro-settings-manager-notifier-0.5.6-10
manjaro-xfce-settings-20200811-1 matcha-gtk-theme-20200727-1
mesa-20.1.6-1 mesa-vdpau-20.1.6-1 mhwd-0.6.4-3
mhwd-db-0.6.4-12 mhwd-nvidia-440xx-440.100-1
mhwd-nvidia-450xx-450.66-1 modemmanager-1.14.2-1 mpfr-4.1.0-1
mpg123-1.26.3-2 mtpfs-1.1-4 nano-5.1-1 ndctl-69-1
neon-0.31.2-1 net-snmp-5.8-6 network-manager-applet-1.18.0-1
networkmanager-1.26.2-1 nfs-utils-2.5.1-1 nfsidmap-2.5.1-1
nm-connection-editor-1.18.0-1 nspr-4.28-1 nss-3.56-1
ntp-4.2.8.p15-1 onlyoffice-desktopeditors-5.6.0-1
openexr-2.5.3-1 openmpi-4.0.4-1 openresolv-3.11.0-1
openssh-8.3p1-3 opera-70.0.3728.119-1 p11-kit-0.23.21-1
pacman-5.2.2-2 pam-1.4.0-3 pamac-cli-9.5.8-1
pamac-common-9.5.8-1 pamac-gtk-9.5.8-1
pamac-snap-plugin-9.5.8-1 pambase-20200721.1-2
pango-1:1.46.1-1 papirus-icon-theme-20200801-1
patchutils-0.3.4-4 pciutils-3.7.0-1 pcsclite-1.9.0-1
perl-5.32.0-1 perl-alien-build-2.29-1
perl-alien-libxml2-0.16-2 perl-capture-tiny-0.48-4
perl-clone-0.45-2 perl-dbi-1.643-2 perl-encode-locale-1.05-7
perl-error-0.17029-2 perl-ffi-checklib-0.27-2
perl-file-basedir-0.08-5 perl-file-chdir-0.1011-4
perl-file-desktopentry-0.22-7 perl-file-listing-6.04-8
perl-file-mimeinfo-0.29-4 perl-file-which-1.23-4
perl-html-parser-3.72-10 perl-html-tagset-3.20-10
perl-http-cookies-6.08-3 perl-http-daemon-6.06-2
perl-http-date-6.05-3 perl-http-message-6.25-1
perl-http-negotiate-6.01-8 perl-io-html-1.001-7
perl-ipc-system-simple-1.30-2 perl-libwww-6.47-1
perl-lwp-mediatypes-6.02-8 perl-mailtools-2.21-4
perl-net-http-6.19-4 perl-parse-yapp-1.21-3
perl-path-tiny-0.112-2 perl-timedate-2.33-2
perl-try-tiny-0.30-5 perl-uri-1.76-4
perl-www-robotrules-6.02-8 perl-xml-libxml-2.0205-2
perl-xml-parser-2.46-2 perl-xml-writer-0.625-6
polkit-gnome-0.105-5 poppler-0.90.1-1 poppler-glib-0.90.1-1
poppler-qt5-0.90.1-1 popt-1.18-1 powertop-2.13-1
protobuf-3.12.4-1 python-3.8.5-1 python-distlib-0.3.1-1
python-html5lib-1.1-1 python-idna-2.10-1
python-importlib-metadata-1.6.1-1 python-more-itertools-8.4.0-1
python-ordered-set-4.0.2-1 python-pillow-7.2.0-1
python-pip-20.1.1-1 python-psutil-5.7.2-1
python-pyqt5-5.15.0-3 python-pytoml-0.1.21-4
python-reportlab-3.5.48-1 python-requests-2.24.0-1
python-resolvelib-0.4.0-1 python-setuptools-1:49.6.0-1
python-sip-4.19.23-1 python-urllib3-1.25.10-1
python-yaml-5.3.1-2 qt5-base-5.15.0-4 qt5ct-1.1-1
rav1e-0.3.3-1 rsync-3.2.3-1 sdl2-2.0.12-2 seahorse-1:3.36.2-1
shadow-4.8.1-3 snapd-2.45.2-1 splix-2.0.0-15 sqlite-3.33.0-1
steam-manjaro-1.0.0.64-1 subversion-1.14.0-2 sudo-1.9.2-1
suitesparse-5.8.1-1 systemd-246.3-2 systemd-libs-246.3-2
systemd-sysvcompat-246.3-2 tbb-2020.3-1 terminus-font-4.48-3
tesseract-4.1.1-3 tesseract-data-eng-2:4.0.0-1
thin-provisioning-tools-0.9.0-1 tslib-1.22-1
ttf-bitstream-vera-1.10-14 ttf-dejavu-2.37+18+g9b5d1b2f-2
ttf-droid-20121017-8 ttf-indic-otf-0.2-11
ttf-liberation-2.1.1-1 tumbler-0.2.9-1 udiskie-2.2.0-2
udisks2-2.9.1-1 unrar-1:5.9.4-1 upower-0.99.11-3
usb_modeswitch-2.6.1-1 usbmuxd-1.1.1-1 util-linux-2.36-2
viewnior-1.7-3 vlc-3.0.11.1-2 vmaf-1.5.2-1
vulkan-icd-loader-1.2.148-1 vulkan-intel-20.1.6-1
vulkan-radeon-20.1.6-1 webkit2gtk-2.28.4-1
wireless-regdb-2020.04.29-1 wpebackend-fdo-1.6.1-1
x264-3:0.160.r3011.cde9a93-1 x265-3.4-1 xapps-1.8.9-3
xcape-1.2-4 xcursor-simpleandsoft-0.2-9
xfce4-time-out-plugin-1.1.1-1 xfce4-timer-plugin-1.7.1-1
xfce4-weather-plugin-0.10.1-2 xfce4-whiskermenu-plugin-2.4.6-1
xfsprogs-5.7.0-3 xfwm4-4.14.5-1 xkeyboard-config-2.30-2
xorg-server-1.20.8-4 xorg-server-common-1.20.8-4
xorg-twm-1.0.11-1 xxhash-0.8.0-1 zbar-0.23.1-2
zenity-3.32.0+50+gc229637-1 zeromq-4.3.2-2
archlinux-keyring-20200820-1 manjaro-system-20200723-1

Tamaño total de la instalación: 4709,40 MiB
Tamaño neto tras actualizar: 58,41 MiB

:: ¿Continuar con la instalación? [S/n] s
(405/405) comprobando las claves del depósito [######################] 100%
descargando las claves necesarias…
¿Importar clave PGP 428F7ECC7117F726, Helmut Stult »? [S/n] s
error: no se pudo buscar la clave 428F7ECC7117F726» de forma remota

No vienen los enlaces de los mirrors porque no me deja meterlos el post

Salida:
[sudo] password for acer:
:: Sincronizando las bases de datos de los paquetes…
core está actualizado
extra está actualizado
community está actualizado
multilib está actualizado
:: Some packages should be upgraded first…
resolviendo dependencias…
buscando conflictos entre paquetes…

Paquetes (2) archlinux-keyring-20200820-1 manjaro-system-20200723-1

Tamaño total de la instalación: 1,29 MiB
Tamaño neto tras actualizar: 1,29 MiB

:: ¿Continuar con la instalación? [S/n] s
(2/2) comprobando las claves del depósito [######################] 100%
descargando las claves necesarias…
:: ¿Importar clave PGP 8DB9F8C18DF53602, «Stefano Capitani stefano@manjaro.org»? [S/n] s
error: no se pudo buscar la clave «8DB9F8C18DF53602» de forma remota
error: la clave necesaria no está presente en el depósito
error: no se pudo realizar la operación (error inesperado)
Ocurrieron errores, por lo que no se actualizaron los paquetes

advertencia: manjaro-keyring-20200603-1 está actualizado – reinstalándolo
resolviendo dependencias…
buscando conflictos entre paquetes…

Paquetes (2) archlinux-keyring-20200820-1 manjaro-keyring-20200603-1

Tamaño total de la instalación: 1,45 MiB
Tamaño neto tras actualizar: 1,29 MiB

:: ¿Continuar con la instalación? [S/n] s
(2/2) comprobando las claves del depósito [######################] 100%
descargando las claves necesarias…
:: ¿Importar clave PGP CAA6A59611C7F07E, «Philip Mueller philm@manjaro.org»? [S/n] s
error: no se pudo buscar la clave «CAA6A59611C7F07E» de forma remota
error: la clave necesaria no está presente en el depósito
error: no se pudo realizar la operación (error inesperado)
Ocurrieron errores, por lo que no se actualizaron los paquetes

Con el comando refresh keys salida:

[acer@acer-aspirem3641 ~]$ sudo pacman-key --refresh-keys
[sudo] password for acer:
gpg: renovando 21 claves desde hkps://hkps.pool.sks-keyservers.net
gpg: renovación al servidor de claves fallida: Error general
==> ERROR: La clave local especificada no se pudo actualizar desde un servidor de claves.

Pues parece que es hora de sacar la artillería pesada :slight_smile:

Según la wiki de Arch, hay que revisar unas cuantas cosillas:

  • La hora del equipo tiene que ser correcta
  • Borrar la cache de paquetes con pacman -Sc
  • Borrar como root la carpeta /etc/pacman.d/gnupg y después regenerarla con:
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro

Veamos si esto ayuda

Lo he estado revisando y la hora del equipo no está bien. Por alguna razón en alguna actualización se ha ido al traste porque estaba bien. Aún así he seguido el segundo y tercer paso y ahora por lo menos ya importa las claves de los desarrolladores aunque al final no instala las actualizaciones por un error en clave local.
Gracias por tu ayuda cfinnberg. Voy a buscar para intentar poner bien la hora del sistema y sigo contando

Pues no hay manera. He corregido la hora y sigo sin poder actualizar y lo mismo me pasa al intentar cambiar de kernel. Importa las claves de los desarrolladores casi en todos los casos pero finalmente :
:: ¿Importar clave PGP 51E8B148A9999C34, «Evangelos Foutras foutrelis@archlinux.org»? [S/n] S
:: ¿Importar clave PGP 51E8B148A9999C34, «Evangelos Foutras foutrelis@archlinux.org»? [S/n] S
:: ¿Importar clave PGP CAA6A59611C7F07E, «Philip Mueller philm@manjaro.org»? [S/n] S
error: no se pudo buscar la clave «CAA6A59611C7F07E» de forma remota
:: ¿Importar clave PGP CAA6A59611C7F07E, «Philip Mueller philm@manjaro.org»? [S/n] S
error: no se pudo buscar la clave «CAA6A59611C7F07E» de forma remota
:: ¿Importar clave PGP 94657AB20F2A092B, «Andreas Radke andyrtr@archlinux.org»? [S/n] S
error: la clave necesaria no está presente en el depósito
error: no se pudo realizar la operación (error inesperado)
Ocurrieron errores, por lo que no se actualizaron los paquetes
[acer@acer-aspirem3641 ~]$

Prueba a cambiar el servidor de claves. Edita /etc/pacman.d/gnupg/gpg.conf y cambia la línea de keyserver así:

keyserver hkp://pool.sks-keyservers.net

Lo haré así en cuanto pueda. He tenido que tirar por la tremenda editando el fichero correspondiente y cambiando las líneas a Never como se indica en el wiki para evitar que se verifiquen las firmas. Así ya se actualiza pero es un problema de seguridad importante y no voy a dejarlo así. Gracias