Problema durante l'avvio del sistema.

Buongiorno, dopo gli ultimi aggiornamenti, durante l'avvio del sistema mi ritrovo questa scritta: "error resume no device specified for hibernation". Come mai? non ho mai utilizzato questa funzione e cercando soluzioni su internet, mi sono accorto che la scritta esce solo ha chi elimina la partizione di swap, cosa che non ho fatto.
Grazie in anticipo!

Hello, after the latest updates, during the system startup I find this writing: "error resume no device specified for hibernation". Why? I have never used this function and looking for solutions on the internet, I realized that the writing comes out only has those who delete the swap partition, which I did not do.
Thanks in advance!

System:
  Host: gianfilippo-pc Kernel: 4.19.62-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.1.0 Desktop: Xfce 4.13.6 tk: Gtk 3.24.10 
  info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId 
  serial: <filter> Chassis: Hewlett-Packard type: 10 serial: <filter> 
  Mobo: HP model: 81F1 v: 64.66 serial: <filter> UEFI: Insyde v: F.46 
  date: 11/16/2018 
Battery:
  ID-1: BAT1 charge: 11.6 Wh condition: 39.8/41.6 Wh (96%) volts: 15.1/14.6 
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Charging 
CPU:
  Topology: Quad Core model: Intel Pentium N3710 bits: 64 type: MCP 
  arch: Airmont rev: 4 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12805 
  Speed: 480 MHz min/max: 480/2560 MHz Core speeds (MHz): 1: 480 2: 480 
  3: 528 4: 555 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:22b1 
  Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (Braswell) 
  v: 4.5 Mesa 19.1.3 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k4.19.62-1-MANJARO 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 2000 
  bus ID: 02:00.0 chip ID: 10ec:b723 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 1000 bus ID: 03:00.0 
  chip ID: 10ec:8136 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 11.07 GiB (1.2%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 4C scheme: GPT 
Partition:
  ID-1: / size: 907.59 GiB used: 11.07 GiB (1.2%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.14 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 173 Uptime: 9m Memory: 3.70 GiB used: 947.6 MiB (25.0%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: xfce4-terminal inxi: 3.0.35 

Ciao,

posta

lsblk -f
e
cat /etc/default/grub

lsblk -f
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                   
├─sda1
│    vfat         6F12-BD62                             299,1M     0% /boot/efi
├─sda2
│    ext4         2857642f-9d2a-4b37-a8b8-3038a027bab6  851,6G     1% /
└─sda3
     swap         49fa9649-fd7b-4c1a-8840-1aaa1191bf3f                [SWAP]
sr0                                                                   

cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 audit=0"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

prova questo:

sudo update-grub
sudo mkinitcpio -P
sudo reboot

provato, grazie, ma il messaggio di errore persiste

grep "^HOOKS" /etc/mkinitcpio.conf

cat /etc/fstab

HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6F12-BD62                            /boot/efi      vfat    defaults,noatime 0 2
UUID=2857642f-9d2a-4b37-a8b8-3038a027bab6 /              ext4    defaults,noatime 0 1
UUID=49fa9649-fd7b-4c1a-8840-1aaa1191bf3f swap           swap    defaults,noatime 0 2

togli "resume"
poi

sudo mkinitcpio -P
sudo reboot
1 Like

grazie mille per il tuo tempo, ha funzionato!

con piacere :grinning: !

1 Like