Problem with update (can't boot into system)

Hello and welcome to the new forum! Unfortunately I’ve ran into some problems and I need your help if possible! I’m on manjaro gnome and I tried to update last night to the latest stable, but something happened during the procedure and my system froze and rebooted (I have no idea what, I wasn’t doing anything at the time). After that I’m getting an error from grub “You need to load the kernel first”.

I’ve tried to fix it in grub by the set root=(hdx,x) command, but it doesnt seem to work. I’ve now booted into a livecd and chroot into my installation, but when I try to run pacman -Syyu I get the following error message:

pacman: error while loading shared libraries: /usr/lib/ file too short

I’m now lost and I would appreciate any help please! I have no idea what to try now. My last resort is to just reinstall manjaro, but I would like to avoid that if possible. Thanking you very much in advance :slight_smile:

Reinstalling would sadly likely be the easiest and most time efficient option, as we don’t know which files are broken besides gpg library. That would depend though on the amount of work you invested in the system.
You could still save the data in your home directory and likely even the configs in /etc/ though.

Otherwise you could try to reinstall the gpgme package with pacman -Syyu gpgme

1 Like

Follow this guide if you have an incomplete/crashed update process:

If downloading the packages takes long then in future you can use the wait parameter in pacman to wait until all packages are downloaded from the mirror. The command would be

sudo pacman-mirrors -f && sudo pacman -Syuw

After download is completed

sudo pacman -Syu
1 Like

Addition to the kindly provided information above, since /lib/ is owned by core/gpgme, try to reinstall gpgme
sudo pacman -Syyu gpgme

1 Like

Thank you very much guys for your replies. It seems that my system is veery broken. :confused: I’m in the process of backing up files and reinstalling. I’m making sure to create a different partition for /home this time to avoid this hussle in the future. Again thank you very much for your replies, I’m really wondering what went wrong, I just did pacman -Syu like I always do.

The problem was the crash of the system and not your doing. As long as you haven’t overclocked your system you have nothing to blame yourself for… next time it would be wise though to make atleast a backup with timeshift before updating. It can really help in the case of something going awry.

Just bad luck then I guess. Anyway, thanks again for the suggestions!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.