Problem with sudo/Lightdm XFCE

Well, this only happens in Manjaro, when I type sudo and enter my password, everything works fine, but most of the time it shows the wrong password. The same when I lock the XFCE4 screen, I need to restart the computer to make it login. Can someone help me? I can’t even update packages, nothing without my sudo password.

have you tried resetting it, replace “user-name”:
sudo passwd user-name

I had this issue once after installation.

For me this worked:

Boot from live usb, chroot and upgrade all packages

sudo pacman -Syyu

If mirrors are not available - exit chroot, update miracles in the gui software manager and try once more.

I’ve been watching this thread to see what happened.

What do you mean by the above?

Some things you might review on your system.

Are you root (Yikes!) or another user?

If this isn’t a new install, when did this problem start? Do you recall what commands were executed just prior to it happening? Was something installed?

Check permissions and ownership of your home directory.

echo $USER ; whoami                      # make sure who you are
find $HOME \! -user $USER -ls            # find files not owned by you in your home directory
find $HOME \! -writable -ls              # find files not writable by you
find $HOME \( ! -writable -o ! -user $USER \) -ls   # the above 2 commands combined

When I run the above find commands on a default XFCE system, there are 0 files returned.

Try updating from a tty,

  • alt-f1 (usually f1-f6, with f7 being graphical)
  • sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

Could also try creating another user and logging in as that user. This would prove that the problem is localized to that specific user id.

My first thoughts were that this looks like the $HOME directory is messed up and it is no surprise root has no problem. Based on the information provided, I’m 50% sure :slight_smile: