Problem with Proton/Wine on a fresh install of Manjaro

I don’t think this is a Proton/Wine problem (Didn’t impact my mate on an install that’s been running for a while) so I’m asking here. Whenever I run anything (particularly games) under proton, there’s a strange sound that occasionally plays, similar to Windows’ sound when a window has focus and you try to click off it. I will post over on proton/wine. It seems to correspond with a spike in CPU/GPU.

I’ve tried a few different proton versions, a fresh install of wine, etc.and it’s made no difference. It’s really been getting on my nerves and I can’t seem to work it out myself so I’m looking for a hand if anyone’s got ideas.

Also can someone remind me of the inxi parameteres used on here. I can’t remember, it’s been a while since I’ve asked on here.

Is the forum search not working?

Not sure, I spent a bit looking but couldn’t find it. Might have just been me searching the wrong terms.


Anyhow, this is inxi output.

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=67fc1b1e-4b64-478f-8e51-46a5a2e6befa rw quiet apparmor=1 
  security=apparmor resume=UUID=3255be71-4677-4e11-a662-5bf5638412ac 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: Strix GL704GM_GL704GM v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: GL704GM v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: GL704GM.305 date: 04/24/2019 
Battery:
  ID-1: BAT0 charge: 55.6 Wh condition: 55.6/66.0 Wh (84%) volts: 15.7/15.7 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 3900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3900 2: 3900 
  3: 3900 4: 3900 5: 3900 6: 3900 7: 3900 8: 3900 9: 3900 10: 3900 11: 3900 
  12: 3900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c20 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-9:4 chip ID: 13d3:56a2 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4") 
  s-diag: 748mm (29.4") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128 
  size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
  OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10f1 
  Device-3: Corsair CORSAIR VOID ELITE Wireless Gaming Dongle type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5:3 chip ID: 1b1c:0a51 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: eno2 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 324.82 GiB (27.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-256G-1002 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: 20110000 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST1000LX015-1U7172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition:
  ID-1: / raw size: 221.13 GiB size: 216.66 GiB (97.98%) 
  used: 89.44 GiB (41.3%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.04 GiB used: 10.5 MiB (0.1%) 
  priority: -2 dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 73.0 C mobo: N/A gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): cpu: 5600 
Info:
  Processes: 326 Uptime: 2h 44m Memory: 15.49 GiB used: 4.85 GiB (31.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1285 lib: 366 
  flatpak: 0 Shell: Zsh v: 5.8 running in: konsole inxi: 3.1.05 

Do you use prime-run when opening the games with proton? Or did you try to make use of the optimus-manager ?

This is what I’ve been using, same as on the previous install. I’m not sure if it’s working on the new install, seems that everything’s running a little sluggish now. I’ve not read about prime run, though on the wiki it doesn’t appear necessary if I’ve got this up and running?

It seems that at this point you switched to dGPU, but what i meant is to switch to iGPU and see if by using prime-run aka render offload you have the same performance. If is the same, then there is something off about when running only trough dGPU. At least that is how i see it.
Personally i think you will have better results with optimus-manager.

1 Like

Swapped to optimus-manager and it fails to put me to nvidia. I also couldn’t get prime-run to start things successfully. Do you have any recommendations?

The problem that the swap is not just like that. You have to make sure of all the steps as described here:
https://archived.forum.manjaro.org/t/guide-install-and-configure-optimus-manager-for-hybrid-gpu-setups-intel-nvidia/92196

Sadly there are no longer pictures to help visually what is what, but the tutorial si straight forward.

I forgot one step from the last time I tried to use it, my bad. It seems to have fixed a lot of the performance problems, but the strange sound and associated performance drop is still there. Not really sure how to debug this. Last night it persisted after the proton game was closed, making the noise every 3 minutes or so.

Considering just doing a new install, noting everything I change and then reporting where the noise is introduced.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.