Problem with pacman database refresh and selection of mirrors


#1

Hi I’m Bill and new to Manjaro but not Linux. Currently I have Mint running without trrouble as a virtual machine under VirtualBox. I also use various other Linux ditros on USB keys.

I am trying to get Manjaro as a virtual machine with Virtual Box (same as Mint). I have tried to install it and also run a Live version and have same problem as follows

I am trying to load other apps but am being stopped by the following,

I try to load various mirrors using the Preferences. It creates the lists in the etc/pacman-d directory but when I then tried to refresh the database it fails with a bad url message.

Can anyone suggest a solution.

Thanks
Bill


#2

What is the exact error?
404 on the databases? Use another mirror.
404 on the packages? Update the database with sudo pacman -Syyu.


#3

Hi Strit

Thanks for the response. I use preferences to get a mirror list then Refresh databases wheich gives following error.

The message I get is,

Failed to synchronise any database … as Title of error window

Failed retrieving file ‘community.files’ from repo.manjaro.org.uk : The requested URL returned error :404 Not found … as actual error message.

I have tried mirror listing from UK, Ireland, USA and France error is always same except the mirror address.


#4

The mirror seems to be up.

Are you running i686 / 32-bit Manjaro?


#5

Yes I am as Virtualbox I have only supports 32bit.

The actual internet connection is ok as it is used for these messages and several other sites using the browser.

It seems odd that I get the 404 error as that usually means an incorrect URL


#6

Manjaro stopped supporting 32-bit in November, but there’s a community effort to keep it going.

32-bit manjaro requires some changes to work again.

See this thread for more info:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.