Problem with nvidia driver

hello guys, i using dual graphics card with driver(video hybrid amd nvidia prime) but my nvidia is not working, i can set nvidia in nvidia x server setting but when i check on setting just have amdgpu is work

link screenshot

The NVIDIA driver is installed correctly,the first screenshot that program only shows the first GPU it sees.

Normally programs are able to automatically detect the NVIDIA card and use it,but in case is not working or if you want to force it you can use prime-run command before the name of the program.

For example
Try running the command

glxinfo | grep vendor

It should output something with AMD,now if you type

prime-run glxinfo | grep vendor

It should output something with NVIDIA,that means the NVIDIA card is working,with prime-run you force glxinfo to run with the NVIDIA card.

but why i don’t have “run application with graphics card”, and when i check nvidia with nvtop, gpu memory is always only 4 mb, i tried running some apps that use graphics, but it still doesn’t change

That is something I don’t know as I don’t use GNOME.

Did you try

prime-run glxgears


thanks for help, I got the answer to my problem

You can also use the Main Menu app that is included with Manjaro and search for the application and type prime-run at the start of the command,so you can start the app with the NVIDIA card straight at the GNOME menu.

If you want the “Launch with dedicated GPU” option,according to this, its the package switcheroo-control from the AUR that enables that functionality and Manjaro doesn’t have that preinstalled.
If you really want it,then try installing that package with

pamac build switcheroo-control-git

then reboot the system and check if you have the “Launch with dedicated graphic card”.

it work, thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.